Hyperion.NG, Amlogic improvements

I did that multiple times yesterday but nothing helps. I have also noticed that with Hyperion Control addon enabled the colors don’t change in the menu - some random leds are glowing with some random colors but they don’t move as you go through the menu. Without the Hyperion Control addon they behave properly when going through the menu and change accordingly.

EDIT: So it looks like Hyperion Control does something - when you stop the video - it sets some random colors to the LEDs but it doesn’t turn them off. They don’t change when you go through the menu, so platform capture is off, but the LEDs are still on?

Try to turn off all Effects in Hyperion web interface.

@Feromon THANK YOU SO MUCH! You were right! As it turns out the Hyperion Control was turning on “Warm mood blobs” when it wasn’t playing any video. Disabling General > Effects > Background Effect/Colour fixed the issue. One more time thank you!

Hi guys, have you any idea why when Hyperion.ng is on my all videos and IPTV run with SW decoding and loading cpus 100% and then shuttering and buffering. But when Hyperion.ng is off, box is using HW decoding and is workinf flawless? Tried 2 boxes with fresh stable CE, one is beelink gt king and another magicsee n5 plus s905x3 4GB.
Any advice please. :slight_smile:

Hyperion.ng on: http://prntscr.com/s0ixto
Hyperion.ng off: http://prntscr.com/s0iynd


I also have Hyperion Control 1.0.1 to disable hyperion in kodi menu, but it does not work. the leds are still active (and changing according to the displayed menu).
My hyperion-ng is also latest version 9.2.103 and I disabled api auth.

Any idea what else can i check ?


Read the posts above about disabling API access and disabling effects.

yes, already disabled API access and all effects, forgot to mention it.

Are you sure that both API authentications are off in Hyperion Config? Can you try deleting the Hyperion Control and installing it again? Try also restarting the whole box after installing Hyperion Control. You can also post screenshots of your Hyperion Control configuration.

Hyperion.NG 9.2.103 in CoreElec 9.2.2 Protocol Buffers Server does not work

New Version works fine with local grabbing.
But with Signal from Hyperion Android Grabber via Port 19445 there is no function anymore.

Had to go back to Hyperion.NG 9.2.101

posted an issue here
but it was closed today.

any hints to get that working again ?


it now works :slight_smile:
I deleted both Hyperion Control and Hyperion-NG, reinstall and reconfigure (same as before).


You need to be more detailed. I have no idea how to use this function. So describe your setup an how I can reproduce the issue please.

I will try to explain - but english is not my mother tongue…

Well I do own a Mecool M8Spro+ box with Coreelec 9.2.2 stable.
I have installed Hyperion.ng as an addon. It is working fine with my ambilight.
My Led stripe has its own microcontroller with WLED and gets its data via udpraw.
As already said : everything is running fine.

Hyperion.ng has as standard its protocol buffer Server on port 19445.

I use android devices with my TV, too. On android is an app called Hyperion Android Grabber


This application will run a background service to capture the content of your screen and send it to a local instance of hyperion to control ambilight-like lights.

Coreelec changed the Version of hyperion.ng some days ago.
In the new Version the Protobuf Server on Port 19445 does does not work anymore.
Its working only locally with Version 9.2.103.

I went back to hyperion.ng 9.2.101 : working fine again with the android app.

The same Problem in the living room :
Hyperion.ng running on a Mecool KI pro
Hyperion Android grabber running on a Shield TV
Version 9.2.101 running fine
Version9.2.103 not working with data grabbed on the shield

I guess it’s the Android App:

[hyperiond PROTOSERVER] (ERROR) The priority 50 is not in the proto-connection range between 100 and 199.

But I have adjusted the priority to 150 in the Android app!?

It’s working! Adjust the priority between 100-199 and stop recording on the App. Start it again and it’s working.

I will test it tomorrow and report
thank you for your support.
It was hard work for me to get the ambilight thing done ( self made ).

tried this time with my new Magenta TV Stick (S905y2/2G)
and installed Coreelec NG stable

Had again to step back to Hyperion.ng 9.2.101 because Version …103 did not work with TVheadend live TV client and not with Disney plus addon , too (using internal grabber)

u know that u have to setup a new hyperion.ng configuration?
without any debug log what should I tell you?

Maybe best to consult the magic lamp :face_with_hand_over_mouth:.

Hey guys, I am having troubles with my hyperion setup and the current coreelec 9.22 release. I have tried to reinstall the hyperion NG addon several times but my LED strips don’t do anything.

I can see that the addon is set up correctly as I get a “live video” stream in the web interface. When I switch back to coreelec 9.21 everything works as expected. Is there anything that might need additional activation?

I am running corelec on a odroid C2 with APA102 LED stripes. I can provide a debug log if needed.

You need to setup a new LED hardware configuration by Hyperion web interface.

Hi, thank you for the quick reply. That was the first thing I did when nothing worked. So I did not load a precious configuration. Instead I created a completely new config. But this did not solve the problem.