Hyperion.ng, Boblight server broken

#1

hi Portisch,
ive installed hyperion.ng , running so far, only Boblight does not work, crosscheck with normal hyperion my config is good. with hyperion.ng no response to my leds. the client connect to boblight but nothing appears…

ps: “kodiVideoChecker” is not build in yet? how can i disable GUI grabbber in idle mode?

Slow down of Hyperion.ng
#2

I am not the main coder of hyperion. I only have solved the amlogic problems. So please go to the official hyperion forum.

1 Like
#3

Here’s the addon that allows you to disable the Hyperion in the Kodi menu : https://github.com/hyperion-project/hyperion.ng/issues/474

#4

thanx for the link, tool does nothing in my setup :frowning:
Grabbing in Menu stills on, boblight does not work.

#5

First of all open up a new thread - this one is about Hyperion slowdowns.

Also - are you using Hyperion or Hyperion.ng? This addon will only work with Hyperion.ng. It won’t work with Boblight and it has nothing to do with Boblight itself.

1 Like
#6

Boblight server function is broken with 100.3
Going back to 100.1

#7

yes, 100.2 is broken too, on hyperion-project nobody helps… the problem is that 100.1 has no amlogic grabber like 100.2…

i try since 7days to compile myself on windows10 with Vmware and Ubuntu + qemu + docker… but when i get files, no one is running on my s912… :frowning: tried aarch64,arm32v7,armvf), dont know if i make it right…the orginal hypernoid is ~16mb from nightly, my only 5mb…

#8

Why you just don’t use Boblight?

#9

@Ray
why offtopic?
Boblight Server is inbuild Hyperion and is broken up since AML patches…

@andy5macht
Boblight is real old and LEDs are not so smooth as Hyperion…

#10

As Ray already told you this thread is about slowdowns. So if you have any other issues you need to search for a thread or open a new one.

And about the Boblight server: I pushed the version of hyperion to the newest state. It was before 1-2 years old. So in this time it looks like it was broken. This is not because of my changes I have done.

#11

@Portisch,
i am not a DEV, i have seen that the version of 100.1 was from 20.12.2018 build and there are all fine.
all newer are broken. but its ok.(i think one of the patches from the Hyperion Dev Paulchen-Panther is the problem)
i give up now!
will buy an second arduino and installing directly to my Enigmalight and put it parallel to the other output from Hyperion with an Hardware-Switch (only solution i know).

Must say that the new Hyperion.ng with your patches runs great without Slowdowns! Thx for good work

#12

I moved all about the boblight issue to this new thread. Please give me a description how to setup a boblight server/client to simulate the issue.

#13

to activate boblight server in hyperion.ng put this in hyperion.config.json:
“boblightServer”: {
“enable”: true,
“port”: 19333,
“priority”: 201
},

or use the webconfig of hyperion.ng->http://your.box.ip:8090/#conf_network, scroll down to boblight.
iam using an VU+Solo2 with Enigmalight as client, have set the settings to my.box.ip:19333
if i start enigmalight output it connected to boblightserver on port 19333, source pops up for ~1sec and disappear

i think this software for android can help to test,if you have no Sat-Receiver…
https://apkpure.com/de/bobdroid/com.mitjahenner.bobdroid

under hyperionwebconfig :http://your.box.ip:8090/#remote under Remote-Control/source selection you can see for ~1sec that the server goes as source active when activate in bobdroid the connection and than disappears…
in 100.1 it stays at sourceinput an runs fine
hope it enought info :slight_smile: thanx for your help

#14

So you run hyperion on CE Amlogic device? But you get frames from a sat box by Boblight protocol to hyperion. Or how this works?
How the frame grabber of Amlogic get disabled? Please tell me your setup. I never used another function as the Amlogic grabber.
How are the hardware LEDs connected?

#15

i installed Coreelec, setup hyperion.ng on my S912.
enabled Boblight Server, thats all what i can do in hyperion.ng
if the client connects to hyperion.ng the source automatical goes to Boblightserver (seeing in Remote.Source selection) to version 100.1 this source is automatical set when i send data or an color-effect.

as i know hyperion.ng switch automatical to source with a higher prio.
boblight client takes frames yes, but can control with an command to setup leds effects to, but this does not working too… never light up.

with the andorid app you can send boblight command to the server, the source must switch permamently to Boblightserver, but does not (i can see an source-selection for ~1 sec in webconfig) when i press the connect button on left corner in the android app ( must setting the right ip and port before in settings)

the hardware is an arduino nano connected to my s912 with usb on TTYUSB0,
the lights working like charm when watching an movie, (Amlogic Grabber)
i switched the internal framegrabber off for testing, set random prio to boblightserver… all the same, no source but the client says connection is up!

i disable the framegrabber with hyperion-remote control web interface (there are all sources with play/stop button on the interface,>Platform Aufnahme)

(ich habe mal einen debug log vom der 100.3er angehängt, vieleicht hängt es mit dem PriorityMuxer zusammen???)
ive attach an debug log from100.3,seems problem with PriorityMuxer???

100.3 error.txt (19.2 KB)

(So sieht die Remote Source bei 100.1 aus wenn ich einen Boblight Client aktiviere (in diesem fall die Android app))

thats the remote/source selection from 100.1 when activate an boblight client (this time i start the android app bobdroid and connect)

#16
[hyperiond DAEMON] <DEBUG> <PythonInit.cpp:20:PythonInit()> Initializing Python interpreter
[hyperiond SettingsManager] <INFO> Selected configuration file: /storage/.kodi/userdata/addon_data/service.hyperion.ng/config/hyperion.config.json
[hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:129:SettingsManager()> Settings database initialized
[hyperiond EFFECTFILES] <INFO> 36 effects loaded from directory :/effects/
[hyperiond EFFECTFILES] <INFO> 19 effect schemas loaded from directory :/effects/schema/
[hyperiond SettingsManager] <INFO> Selected configuration file: /storage/.kodi/userdata/addon_data/service.hyperion.ng/config/hyperion.config.json
[hyperiond SettingsManager] <DEBUG> <SettingsManager.cpp:73:SettingsManager()> Settings database initialized
[hyperiond BLACKBORDER] <DEBUG> <BlackBorderProcessor.cpp:65:handleSettingsUpdate()> Set mode to: default
[hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Blackborder detector: enabled
[hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> LED device: enabled
[hyperiond LEDDEVICE] <WARNING> latchTime(0) is bigger/equal rewriteTime(0)
[hyperiond LEDDEVICE] <DEBUG> <LedDeviceAdalight.cpp:53:init()> Adalight header for 75 leds: Ada 0x00 0x4a 0x1f
[hyperiond LEDDEVICE] <INFO> LedDevice 'adalight' configured.
[hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Smoothing: enabled
[hyperiond LEDDEVICE] <INFO> Opening UART: /dev/ttyACM0
[hyperiond EFFECTENGINE] <INFO> run effect Rainbow swirl fast on channel 0
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'System/EFFECT' with priority 0 as inactive
[hyperiond HYPERION] <INFO> Inital foreground effect 'Rainbow swirl fast' started
[hyperiond EFFECTENGINE] <INFO> run effect Warm mood blobs on channel 254
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'System/EFFECT' with priority 254 as inactive
[hyperiond HYPERION] <INFO> Inital background effect 'Warm mood blobs' started
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'System/GRABBER' with priority 250 as inactive
[hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Framegrabber: enabled
[hyperiond BOBLIGHT] <DEBUG> <BoblightServer.cpp:24:BoblightServer()> Instance created
[hyperiond BOBLIGHT] <INFO> Started on port 19333
[hyperiond ComponentRegister] <DEBUG> <ComponentRegister.cpp:67:componentStateChanged()> Boblight server: enabled
[hyperiond DAEMON] <INFO> Hyperion initialized
[hyperiond DAEMON] <INFO> set screen capture device to 'amlogic'
[hyperiond AMLOGICGRABBER] <DEBUG> <Grabber.cpp:33:setVideoMode()> Set videomode to 0
[hyperiond FRAMEBUFFERGRABBER] <DEBUG> <Grabber.cpp:33:setVideoMode()> Set videomode to 0
[hyperiond FRAMEBUFFERGRABBER] <INFO> Display opened with resolution: 1920x1080@32bit
[hyperiond AMLOGICGRABBER] <DEBUG> <AmlogicGrabber.cpp:31:AmlogicGrabber()> constructed(160 x 160), grabber device: /dev/amvideocap0
[hyperiond DAEMON] <INFO> AMLOGIC grabber created
[hyperiond JSONSERVER] <DEBUG> <JsonServer.cpp:23:JsonServer()> Created instance
[hyperiond JSONSERVER] <INFO> Started on port 19444
[hyperiond FLATBUFSERVER] <INFO> Started on port 19400
[hyperiond AMLOGICGRABBER] <INFO> FB mode
[hyperiond PROTOSERVER] <INFO> Started on port 19445
[hyperiond WEBSERVER] <DEBUG> <WebServer.cpp:96:handleSettingsUpdate()> Set document root to: :/webconfig
[hyperiond WEBSERVER] <INFO> Started on port 8090 name 'Hyperion Webserver'
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:231:setInputImage()> Priority 250 is now active
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:330:setCurrentTime()> Set visible priority to 0
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:192:setInput()> Priority 254 is now active
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:231:setInputImage()> Priority 0 is now active
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:290:setCurrentTime()> Timeout clear for priority 0
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:330:setCurrentTime()> Set visible priority to 250
[hyperiond HYPERION] <ERROR> setInputImage() used without registerInput() for priority '0', probably the priority reached timeout
[hyperiond EFFECTENGINE] <INFO> effect finished
[hyperiond BOBLIGHT] <INFO> new connection
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:153:registerInput()> Register new input 'Boblight@::ffff:192.168.1.15/BOBLIGHTSERVER' with priority 201 as inactive
[hyperiond HYPERION] <DEBUG> <PriorityMuxer.cpp:330:setCurrentTime()> Set visible priority to 201
"boblightServer": {
    "enable": true,
    "priority": 201,
		"port": 19333
},

It’s look like working here. Please check your config file.
You had instead of " in your config example above, maybe this is the problem

#17

what do you mean with " instead of " ?
dont understand… my config is running with old 100.1…

#18

thats not possible, you are right man,
“priority”: 201,
“port”: 19333
works!
the generated with webend not. it wrotes
“port”: 19333,
“priority”: 201
to my config file

it must an change from 100.1 to newer… if i delete complete the boblightserver settings in config and using webfrontend it adds:
“boblightServer”: {
“port”: 19333,
“priority”: 201

now it runs too (Android app)… i see know… you mean an other ascii " ,dont know i have only german layout… i am really confused

but with my enigmalight sat receiver the source still pops up for only 1 sec , with 100.1 runs fine. i think thats is not your problem anymore… Big Thx for your work

#19

think i’ve found “The, (My)” problem:

i see that the BobDroid Android App sends an priority command to the boblight server and i guess newer versions of hyperion.ng are using this… seems it must match with priority setting in hyperion.ng config!
i dont know why because in my eyes there is no reason for this…
the enigmalight boblightclient seems to set the priority to 122, have not found any setting for this to change(seems hardcoded in bin)
to 100.1 this command seems to ignored, now it must match.
i set the priority in hyperion config for
“boblightServer”: {
“enable”: true,
“priority”: 122,
“port”: 19333
},
and now it works!

is this an bug or it is wanted?
this behavior is comprehensibly when i set the android app Bobdroid to a other priority as set in the hyperion config too!

ive testet the last hour the setup, runs all fine, one small glitch, it seems that the boblight framedata not pass throug the black-border detection, dont know if technical possible…

1 Like
#20

Crazy bug, but this solve my proglem too :slight_smile:

BigMike66, are you using boblight plugin with your Receiver or Enigmalight?