I need CoreELEC-S905.arm-8.95.7.tar


#1

Hello i have Problems with 8.99.2 and i have no spare time at the moment to figure it out i would like to revert to CoreELEC-S905.arm-8.95.7.tar but i dont find a download anymore for it can someone help me out with the tar ?


#2

#3

the only download i see is a tar.gz that dont look like i can flash it
only 20 mb all my other updates are around 160mb
do i miss something ?


#4

All previous releases have been deleted because they are incompatible with the latest versions of the binary addons.

Kodi Leia is now also final and we do not really want people using alpha/beta versions that have other issues.

If your having a problem then how about telling us what it is so that we can try and help you?


#5

Hi,
I’m also having trouble with the newest release (8.99.2). AutoUpdated from 8.95.7 and now my AmLogic S905x-Box does not boot anymore, the screen stays black, ssh also not possible.

I also tried to use latest nightly from https://relkai.coreelec.org/, but this is not even installed after copying it to the .update-folder, the file just gets deleted.


#6

What S905x device do you have? What dtb file do you use?
Did you try fresh install on different sd card?
As you described before somehow you have an access to update folder. How does your system available?


#7

It is a M96X TV BOX Android 7.1 S-905X Quad Core 2+8GB WiFi. I have this for about a year and never had any issue until now. I have not tried a fresh install (is there a way to preserve all your settings / addons?) I just dowloaded Paragons Linux File Systems for Windows and got access to the SD Cards-Update-Folder. Fortunatly I have a second one from wich I copied the System and Kernel.img so I could recover my device (now back on 8.95.7).

It sounds a little like the problems in this thread: Fail to boot with media_build (8.99.1). But I really don’t know what to make of it.


#8

An issue from 8.99.1 was solved in this build
Backup of settings and data you can make here: Coreelec->system->backup
Could you give me an output of this 2 commands on this box:
ls -l /flash
cat /proc/device-tree/le-dt-id


#9

KodiStudio4k:~ # ls -l /flash
total 157592
drwxr-xr-x 3 root root 8192 May 5 2018 Android
drwxr-xr-x 2 root root 8192 Dec 31 2014 LOST.DIR
-rwxr-xr-x 1 root root 151121920 Jan 1 2015 SYSTEM
-rwxr-xr-x 1 root root 48 Apr 22 2018 SYSTEM.md5
drwxr-xr-x 2 root root 8192 May 5 2018 System Volume Informati on
-rwxr-xr-x 1 root root 795 Feb 4 05:35 aml_autoscript
-rwxr-xr-x 1 root root 16919 Dec 4 13:27 boot-logo.bmp.gz
drwxr-xr-x 2 root root 8192 Feb 5 19:36 device_trees
-rwxr-xr-x 1 root root 40775 Feb 5 19:36 dtb.img
-rwxr-xr-x 1 root root 10119168 Jan 1 2015 kernel.img
-rwxr-xr-x 1 root root 48 Apr 22 2018 kernel.img.md5

cat /proc/device-tree/le-dt-id
gxl_p212_2g


#10

Doesn’t the 8G version have 1GB RAM?


#11

Yep, on Ali I’m also found only 1Gb/8GB and 2GB/16Gb versions.
So correct dtb file is gxl_p212_1g if you have 8GB EMMC and not a _2g


#12

cat /proc/meminfo | grep MemTotal
MemTotal: 1833328 kB

Seems like 2GB, but I’ll try that.


#13

Well thats strange it seems M96X is a bit generic the multi coloured version is 1/8 2/16 and the black wedge one comes in a 2/8 variant


#14

I found one with 2Gb/8Gb
In that case I recommend you to try fresh install on new card with _2g (rename it to dtb.img) and check if it works or not. If not - to try _1g version.

P.S.: You always can return kernel.img and SYSTEM file in Windows without additional programs, just connect SD/Flash card and replace them with correct one.


#15

Did either of you have the GUI resolution set to 4K before upgrading?

And do either of you see the CE logo when booting?


#16

Fresh install works (with 2gb). After applying my backup, I get a black screen again (so it must be related to my settings). The CE-Logo is showing up. GUI resolution might be 4k (I’ll investigate this further tomorrow).


#17

Delete guisettings.xml and you should be okay.


#18

Deleting the guisettings.xml did not make any difference. I even downgraded again, set the resuloltion to 1080p and updated again, still only a black screen after the CE-logo. But ssh is working (I was wrong). So maybe there is a startup-log which could help?