Install CE from SD card to eMMC on VIM3

I spent several hours experimenting today. Something weird going on. After Coreelec release 20.0 no update or install is successful, eg. messing up network. So use the 20.0 image from oowow and switch off update.

Try Amlogic-no, it’s the future anyway.

Do all addons that are working on Nexus work on NO as well? I understand that NO is Kodi 21 which is still a pre-release

For me it’s mostly subtitle addons and a few others like virtual filesystems. I’m looking for smooth operation so I can watch videos and relax and less to worry about bugs and stuff that would not work yet (like addons). This is why I stayed with CE 9 for 4 years, it still worked fine enough for me not to go through the changes.

My one issue with Kodi has always been you need to configure everything again when you move from one generation to another. At least I’m not aware of a method that would let me import basic stuff from one Gen to another.

I think I can use my 9.2.8 settings for some stuff on NG and NO if I could only find how to get to the userdata files. As my CE is currently on SD card, I tried to get to that on the File Manager part so I can pull some xmls and edit them on pc and import them back and replace, but I can’t seem to see how to get to that directory. How do I do that?
It was very easy when I had Kodi installed on eMMC.

Most important for me is the network share settings which always take me a while to figure out and remember how to do correctly.

As far as I know A311D is not supported in Amlogic-no. I personally use a lot of plugins so experiental setup is not a daily driver for me.
To make a configuration is not easy and takes time. The Kodi team made much effort to make the process so easy as it can be.
If You wish to manually edit the .xml files then you know already that you can get them if you ssh in your running coreelec system and take them from /storage/.kodi/userdata/
If you are not familiar with ssh you can use MobaXterm.
You mentioned that there is no PC nearby. From your phone You can ssh in for example using ConnectBot
To add share in Coreelec go to File manager and there Add sources there Browse and there Add network location.
Now it is possible to chose from different protocols what your system has, SMB or NFS, etc., chose yours and give here the server IP adress, port and credentials if necessary. After this process you made a basic connection to your server/source which can be used / browsed for add shared movies, music etc. later.

1 Like

You’re wrong. A311d is supported in no. I’m using it right now in the libre computer Alta device.

1 Like

Okhttps://discourse.coreelec.org/t/amlogic-no-new-order/44728

1 Like

Thank you for your very detailed response.

I’ve been using Kodi since it used to be called XMBC (on Windows). I’m just not a power user when it comes to Kodi variations like CE that are not windows.

Thanks for the tip on XMLs from SSH. I assumed I could do it but I was not able
to locate them there either, but tbh I didn’t dig into it much. Also not sure how to “download” from SSH to local PC, which is how I usually do it. Grab the XML edit it on PC and replace old file. I thought I could just reach the CE user files on the SD card with the file manager and copy it into a USB stick.
Perhaps it’s not doable this way and I have to move CE to the eMMC which is what I was trying to do all along.
Since that doesn’t seem to work, no matter what Android version I tried and oowow is above my class, I think I will just move it to eMMC in dual boot (unless that fails too).

I basically know how to do network file shares on Kodi as I set it up a few times before when I have an Odroid and when I got the VIM3 years ago. It’s just always something I have to remember again how to do and involves a lot of annoying clicking on an onboard keyboard letter by letter. One error and it needs to be repeated…I’m pretty sure my old CE 9.2.8 has all that info saved on XML in plaintext so I should be able to just replace the new XML with the old one, or at a minimum use the info and edit it manually into the XML without dealing with the GUI keyboard.

I actually have several PCs only they are all rather old before USB-C has become a standard. so flashing with USB Burning Tool was a challenge.

And? Can you point the part it says it’s not supported?

Yes it is not easy to configure a system. However you may enable settings/services/control the web interface of your device and then http://<IP of Kodi device>:8080/ can sit back with a beer by the PC and can copy paste the main settings on a web interface.

I did manage to get almost everything ready. As always, I had to dust off my memory and do some workarounds. I’ve not set it up in like 4 years.

For now I’m thinking I’ll keep running it from the SD card and wait for stable 21/NO.
Thanks again for your help.

@karmantyu
@Portisch
Maybe you guys can help me with a small issue I can’t quite figure out (instead of opening another thread):
Under Settings–>Player–>Subtitles–>Font - there is only an option to use Default DejaVu Sans and I want to switch it to Arial.
I place arial.ttf inside /storage/.kodi/media/fonts/ and rebooted hoping this will allow me to choose Arial. No go.
Then chageed “subtitles.fontname” in guisettings.xml to Arial in every way I could think of and after reboot it always reverted to default.
Tried switching the Skin default Fonts to Arial based as well, but that only changed the gui fonts.

Try with /storage/.kodi/media/Fonts.

Thanks, but that’s what I tried.
I placed arial.tff in /storage/.kodi/media/fonts/ and rebooted hoping this will allow me to choose Arial. No go. Still only showing me Default DejaVu Sans in the settings menu.
I believe this is the right path (unless I’m wrong):

CoreELEC:~/.kodi/media/fonts # ls -al
total 1015
drwxr-xr-x    2 root     root          1024 Feb 10 22:23 .
drwxr-xr-x    3 root     root          1024 Feb 10 21:13 ..
-rw-r--r--    1 root     root       1036584 Feb 10 22:23 arial.ttf
CoreELEC:~/.kodi/media/fonts # stat arial.ttf
  File: 'arial.ttf'
  Size: 1036584         Blocks: 2026       IO Block: 1024   regular file

Did I do something wrong?

You didn’t read correctly: it is Fonts not fonts (capital F).

@vpeter
I see. I did notice, but that was the folder (empty) already in that path, and I just moved the file there.

I renamed it to Fonts and now it works!

Curious why it’s named fonts to begin with if it needs to be with a capital F?

Thanks :smiley:

1 Like

I was in the same boat, I wanted to do a complete clean install of CE to the eMMC of my VIM3 but ceemmc kept on throwing errors.

I burned all Android firmwares one by one (newest to oldest) and tried to install to eMMC using ceemmc from CE20.3 after every burn. These are firmwares I tried:

  • vim3-android-9-32bit-v231122
  • vim3-android-9-32bit-v230720
  • vim3-android-9-32bit-v221228
  • VIM3_Pie_V210908
  • VIM3_Pie_V210128
  • VIM3_Pie_V201112
  • VIM3_Pie_V200917

After all these attempts I decided to try booting CE19.5 from SD and run ceemmc from there, and lo and behold it would install just fine.

As a test I burned the latest Android firmware again (vim3-android-9-32bit-v231122) and tried to write CE to eMMC again using CE19.5 from SD and ceemmc would still install to eMMC just fine. After that I did a manual upgrade from the CE menu inside Kodi to get to CE20.3.

So my conclusion: the issue is not with the Android firmware on the eMMC, but something in CE20 broke the ceemmc tool. Note: I also tested CE21-Amlogic-no and it has the same issue as CE20.

TL;DR
In order to use the ceemmc tool on a VIM3 you need to use CE19.5 (you can burn the latest 32bit Android firmware though).

1 Like

Made some investigations and checked the g12b_a311d_khadas_vim3.dtb images from NEXUS 20.0-20.4 and found the following.
Release Nexus 20.0 and 20.2 using the same dtb and network is ok on VIM3 pro.
Release Nexus 20.1, 20.3, 20.4 using an other dtb and the nertwork adapter is disfunctioning on VIM3 pro.

Dear CoreElec Team, could you look in to this problem?

Thank You again,

https://wiki.coreelec.org/coreelec:ce_support

I know rules are rules, but.
My post is not a support request. I’ve answered to this specific topic, why @timfolk and myself can’t install some CE releases.
If the wrong DTB is packaged to the CE 20.1 and 20.3 releases please correct it.

Will try to report the problem as support request of course as soon as possible.
Thank You.

1 Like

Is no support request?
When we have no log, we have no issue.
There was no changes for vim3, since long long time. Maybe you got a newer hardware revision?
What version you have labeled on PCB?

OK. I’m sorry.
I will try to make the request as soon as I am able.
My vim3 pro is an old one. I think V12.
I’ve experienced the same problem as @timfolk some times ago that is why I’ve tried to find a solution.
So extracted the g12b_a311d_khadas_vim3.dtb files from Nexus ng 20.0, 20.1, 20.2, 20.3 and 20.4 nightly images and made binary comparisons because the files were obviously not the same size. 20.0 and 20.2 has the same DTB and that is the working version for our vim3. 20.1, 20.3 and 20.4 nightly had the same DTB what gives not working network for us, eg. the adapter gets wrong IP, subnet etc. from DHCP and not able to connect. Correcting the settings helps not, the network is not able to connect.
So there are at least two different DTB for vim3 in the different NEXUS ng releases.