Install issues x96 max plus S905X3 4GB/64gb

Hi Kostaman

Long time no speak. Hope you are keeping well.

I have two friends here who purchased the X96 Max Plus 4/32GB X905X3 box on my advice and I set up for them the fast 16GB SD cards to boot into CE 9.2.4.2 I prepped the cards properly and first booted them with no problems on my 4/64 X96 Max+ box and all was working fine. I am pretty sure it should make no difference using the SD card firstly in my 64Gb box and then they trying to boot it in their 32GB same model boxes as the storage partition is created on the SD card on first boot and not in the internal memory. However we cannot get the SD card to boot on their 32GB boxes both which they ordered seperately directly from a very reliable Chinese supplier in Shenxhen who gets the boxes directly from the factory and with whom I have dealt with for years. I thus recommended that supplier to them. So I am pretty certain the boxes are genuine and not clones.

Have tried everything with different DTBs etc all the usual stuff as I am well familiar with setting up these SD cards for booting into CE. At first I thought it was maybe a faulty box with the first friend but when the other friend had the same problem a few days later then I knew there is somehting different about the latest X96 Max+ boxes to mine.

So I search the CE support forum here and came across this thread. So seems it is the UBoot on the new Android firmware. So what can I do to help them as I feel responsible to both of them ?? Will a fix be forthcoming on CE build or DTB though if its a UBoot problem I cannot see how this can help.

Your advice would be very much appreciated.

1 Like

As a sudden thought would it be worth trying to boot into CE from a bootable USB stick instead of the SD card. My limited knowledge of UBoot is not good enough to know whether that might work but my feeling is that it wont. Is it worth a try or not ??

How far into not boot are you getting ?
Fresh install the SD Card or try USB.
Does CE go into install progress and freeze on CE splash or something else after install boot.

Also see Freaktab

Hi Kostaman. Thanks for getting back to me/ It does not even get to the CoreELEC logo screen. It either freezes with the X96 logo or that goes off and get a blank screen. I have tried both the toothpick method and the Android Terminal Emulator app withthe reboot update command and gives the same result. My secodn friend says he gets the same problem too but booth of them are not local to me here so have to work with them on the phone.

Tried that link but I don’t speak Russian lol. I’ll look again and see if I can derive anything from the video anyway.

Cheers
RayW

Yes treid a complete fresh install and a reformatted and set up SD card but same result. Not tried a USB stick yet but will do if you think it might help. I did test both these SD cards in myhown X96 Max+ 4/64GB box too and they both worked perfectly booting up straight into CE with the toothpick method.

Only a UART log will solve your issue.
Open the device and and search for the connection.

Or you get one SDIO adapter:

Maybe it’s just a fake box like this:

I have now got my friend to prep a CE bootable USB stick and this in one of the two USB sockets brings up the Android recovery screen which I told him to shut down teh box and try again with the other USB port. The second USB port gives the same symptoms as the SD card did with it stuck on the X96+ logo screen. Both times that he tried in each of the USB ports he used the toothpick to hold in the reset button. Once he removes the SD card (or USB stick) the box boots normally into the default Android OS.

I have a hunch that they may have as you say changed the uBoot ROM in the boxes as it only seems to be a problem with the 4/32GB X96 Max+ box as I have now heard from another friend in Bangkok that he changed his X96 Max+ 32GB box which would not boot for a 64GB one and that booted from my prepped SD card immediately into Corelec using the toothpick method. Though I have a local friend here with the 32Gb box he purchased a few weeks ago and that is fine with CoreELEC. So my hunch is that as the 32Gb box is cheaper it will be more popular and sell much quicker thus any newer box with a new UBoot ROM will have come through the supply chain quickly whereas with the 64 GB boxes there are propably still the older stocks available at the retail suppliers. Just a hunch though I must add.

Finally I have asked my supplier contact in Shenzhen to directly have a word with the factory technical support guys where they make this X96 Max+ box to see if he can find out what is possibly causing this problem. I will of course feed back here any info I get.

In the meantime anyone buying this otherwise excellent box should opt for the slightly dearer 4/64GB version and let us know here if this problem occurs with that version, just make sure you can return the box and exchange it before you buy though. Hopefully soon we will have the answer to this problem.

I have 4gb/64gb version, x96 max + and it doesn’t boot up from usb or microsd card

It’s been a problem with the 4/64gb version as well.
Check your working 4/64gb Rom Version against this dated version

Not sure how to do that Kostaman. What is AIDA64, never heard of that ? So how do I get the ROM version as I do want to know the difference of course.

The failed to boot to CS boxes my friends have definitely say S905X3 processor as stated on the packaging box details and in the system info Android screen. Still waiting for a response from China re what changes they have made to UBoot

Seems that the user has already tried with 2GB dtb and apparently with older firmware it worked.
@Portisch do you know if the encrypted firmware is set at fuse level in the CPU, so it is not possible then lo load a plain Uboot+firmware?

From Android go to Settings / Device Preferences / About
You will see the details of your Rom Build

Well I found and installed from the Play Store AIDA64 and indeed it is an excellent small app.

From the results when I ran it just now it seems that the difference is in the Android details for my 64GB box that works fine with CE, You will see from the attached screen shot that my Android build ID is dated 20200818 and is version 2014 which is a later version than the 1719 20200620 dated one shown on rccardude’s screen shots from his AIDA64 report.

SInce I got my X96 Max+ box back on 23rd July 2020 it has though had an OTA update to the Android firmware so not sure what the original version was but anyway after the update a couple of weeks ago the box did need the toothpick routine to get it to boot again from the CE SD card but that was absolutely straight forward and no problems at all were experienced.

So it seems maybe it is a later version that works rather than as I suspected an earlier version. I will check with one of my two friends what Android build is installed in his box that refuses to boot into CE.

Here are my screen shots:

IMG_0363 IMG_0364-1 IMG_0365-1

I’ll try a ota update and also within the about, system, system update page.

How quick are the ota/system update notification as it took a long time and didn’t report anything back.

Not sure as my update happened from an onscreen notificatuion which I said yes to the update. Typical Android kludgy interface as I had to switch the remote to mouse mode to even be able to select the option to go ahead and update, grr Should use my wireless keyboard really but it is often not close to hand and I find it difficult to get up from my chair due to bloody old age and anyway the remote should work at least as well as it does in CE KODI IMHO!!! I really detest Android as find it not fit for purpose compared to the much superior CE KODI.

Anyway I got feedback from my friend who installed AIDA64 and can confirm he also has this rogue build ID version 1719 too and when he tries a manual Android update it just says his system is up to date !!! Go figure ???

So why can we not simply update these boxes with version 1719 to the latest version 2014 ???

Because there is no 2014 version on the server that your box connects to to check for updates…
The solution is to find this version for download and update manually.

And hopefully the hardware specs are the same.

Aida only reads the Build.prop file in the OS.

So there may be a chance the specs are spoofed.

My Chinese supplier and long time friend has told me the factory are unwilling to help at all as they say the box is supplied for Andorid and nothing else !! Typical. Anyway my supplier sent me an update image file download link at Mediafire dated a few days ago . But I need confirmation that this is correct for my box. It is called aml_upgrade_package.img but no mention of the X96 Max+ box or any box??? I have asked my supplier in China to try to get confirmation that this will update the firmware in the 4/32GB Max+ box. Of course I need the Amlogic Burn Card Maker tool for my more techy friend with the problem box to be able to use this image file without the way too complicaed for him USB burn tool and having to connect the box direct to his PC wiht a suitable male to male usb lead.

The best .zip file I can find for the easiest simple to use update is dated in March 2020 but is a later version number than the rogue 1719 as is version 1743. Strange as the offending 1719 version is dated 20th June 2020 ??? Weird. But will this 1743 work I wonder. Anyone got any experience of this version ?? This shold be simplest way as just place the unopened zip file on a USB stick or micro SD card and boot up with the toothpick activated reset button pressed.

Tried to do update but nothing popped up

About | FAQ | Terms of Service | Privacy Policy | Legal Notice