Installation on Mecool KM9 Pro

Okay guys, I got CoreELEC running on KM9 Pro 4/32 GB version with the standard installation steps and it really went smooth. Boot up and everything works perfectly. With the remote conf file from @moa999 remote is working okay, except you dont have long press of ok button that brings context menu, as well as long press of arrow keys won’t work for continuous scrolling of long lists. I didn’t have to do the BL301 Inject for remote power button for shutdown and start, it is working as expected. Thanks to @stm @moa999 @kostaman for dropping by and giving valuable help. So the Mecool google “certificated” boxes seem a good deal for those who want decent ATV experience with chromecast, play store, Widevine and Playready DRM (Amazon prime works in 1080p) etc. and at the same time allowing dual boot to CoreELEC. Only problem is no root access in Android.

1 Like

Does CE support bluetooth remote, i mean is it possible to pair the mecool voice remote in Bluetooth mode instead of IR mode? I put the remote in discovery mode pressing ok and vol down buttons and went to Bluetooth screen of CE but nothing shows up for pairing.

@rakeshchn Is your KM9 running Android 9 ???

@kostaman Yes its running Android 9.

Well that’s great news.
There’s 47 pages of Mecool KM9 discussions at Freaktab regarding the Mecool KM9 versions.
They’re mostly 8.1 versions with no Google Certification.
Your box is the First Google Certified box I’ve heard of that boots an OS from SD Card.
Thank’s for feedback.

I think this may be correct as Mecool KM9 2/16 may not be updated in the list.
All these Mecool KM9 versions that are Google Certified are an updated version which were supplied with Android 9 .
All other versions using Oreo seem to be non Certified by Google.
All this comes from my reading up on Freaktab users.
Mass confusion.

It seems that there are a few boxes
Per http://www.videostrong.com/Google%20Certified/99.html
KM9 running 8.1/9.0 Android Skinned
KM9 Pro Classic 2/16 running 9 ATV
KM9 Pro Deluxe 4/32 running 9 ATV + AC/Gig
KM3 4/64 or 4/128 running 9 ATV + AC/Gig

The latter 3 seem to be Google Certified (ie. Run proper AndroidTV) but not Netflix/WV3 but also bootable via reset into CoreElec on SD.

I have as well KM9 PRO 4/32 Android TV 9.0 with working Chromecast and some DRM and I can run CE without problem.

Is your remote slow with press after enter ssh command and cant power on device?

Is there a way to select Autoboot Android or CE with removing the SD Card?

Hi, I have a km9 pro and I can’t start coreelec, what device tree do I have to use? thanks

g12a_s905x2_4g.dtb

¡gracias! this afternoon I will do it when I leave work and I will put here the results

Great. It works very well for me. I just can’t be bothered to remap the original remote as I use another.

If you get it working properly post the config :grin:

Hi all,

I’m having problems installing CoreELEC 9.2.4.2 on MECOOL KM9 Pro (s905x2, 4gb). I use g12a_s905x2_4g.dtb. Have also tried g12a_s905x2_2g.dtb, just in case.

When I insert the SD card and boot with the “Toothpick method” I get the MECOOl (“TV Box”) splash screen after which I get a complete black screen. I get the same “error” when I simply boot with the SD card inserted (not using the toothpick). The CoreELEC logo never appear. I have succesfully booted in android recovery using “Toothpick method”.

I’m not able to run ‘reboot update’. In Termux I get ‘unknown command’. In Qute Terminal I get ‘permission denied’. I’m in developer mode as well.

Any ideas on how to solve this?

It seems that others have been able to install CoreELEC e.g. Installation on Mecool KM9 Pro

My setup:
MECOOL KM9 Pro (s905x2, 4gb)
Android 9, Google Certificated Voice Control Android TV Box
Burned CoreELEC using Rufus onto SanDisk Mirco SD HC 8GB (previously used on LibreElec with Raspberry Pi).
Tried two different HDMI cables, both work when booting into android.

Check the Android version on your KM9 Pro.
The Freasktab link you posted shows the Android Version in this picture

This guy on the same forum has issues with updated Android

Thanks,

I have the exact same version as on the picture you link - not Android 10. Sorry if I misunderstand your reply, but as I understand it, the folks in the Freasktab topic only experience problems with Android 10, not version 9? Seems like ‘andymarc’ actually had CoreELEC working on Android 9, but that it broke when he update to Android 10? (I know that you can answer for him, just trying to figure things out).

I haven’t been able to find any help on installing CoreELEC in the Freasktab topic. Maybe I’m missing something?

Eliminate this SD Card and try a more updated SD Card or try USB stick.

I only just noticed the SD Card you are using.

Some SD Cards can cause issues with booting.

Will do. Is there difference in speeds when using a USB (KM9pro got usb 3.0)? Is it slower?

Ok so I tried two different USB sticks - one USB 2.0, one USB 3.0. Using the g12a_s905x2_2g.dtb (figured out that it is the 2gb box that I have). Same error. Also tried to format the sticks from two different USB ports in my computer. No luck with this method either :frowning:

I’m not sure what you can do without UART log.
No other way to debug what’s happening on boot.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice