IR remote not working

I have a TV Box with S905X 2GB and 16GB (when the box starts it shows a bootlogo “X96”). I have installed CoreELEC 8.95.2. When I use terminal (from WinSCP) and use the command “dmesg -c” I get the ir codes for all button of my ir remote control. So far so good. But inside Kodi the ir remote control isn’t working.
I do this:
type in “systemctl stop kodi”
type in “systemctl stop eventlirc”
now when I type in “ir-keytable” I get an error. So my box doesn’t use Lirc right?
When I type in “remotecfg remote.conf” or even “remotecfg /storage/.config/remote.conf” I get an error too. So my box doesn’t use remotecfg right?

So what do I have to do to get the ir remote controller working inside Kodi.

  1. Why are you on 8.95.2 instead of 8.95.3?
  2. Make sure that you use the DTB file from the device_trees folder, and don’t download it from the internet…

Probably I have downloaded the DTB from another source. I don’t know anymore. So: How can I change the device tree now? I don’t want to loose all my addons and settings!

I have installed CoreELEC with “installtointernal”.

Can you give me some advice please?

If you installed to a usb/card just copy the new dtb to the card. renaming to dtb.img overwriting the old dtb

No I have installed to internal. The box is much faster when installed to internal.
I installed now the CoreELEC image 8.95.2 again on USB with a device tree out of the sub-folder and I booted from this USB and now the cursor down is working. So it seems that I have installed to internal memory with a wrong device tree.
Can someone tell me how to “copy” this correct device tree to internal memory?

If you forgot to use a new device tree or used wrong one and your device doesn’t boot :

  • don’t panic!
  • if booting from SD/USB, simply connect SD/USB to your computer, download a proper device tree, rename it to dtb.img and place on SD/USB
  • if booting from internal:
    1. Boot this build from SD card or USB with correct device tree.
    2. Login over SSH and execute dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256k
    3. Power off, remove SD/USB, boot from internal.

I tried these two commands already but it’s not working. I get errors when executing these two commands.

Make a frehs install at your sd card and install it to internal

Great. Now it’s working.
Using both command lines (see above) I got errors (see screenshot). Trying to install with WinSCP and terminal command “installtointernal” didn’t work too. Then I tried with Putty and terminal command “installtointernal” and that worked.

I made a post here stating that after upgrading from to the remote doesn’t work anymore.
I tried everything posted in this thread with no avail.
I have CoreELEC installed to internal and it seems it’s all there, only the remote doesn’t work.

Is there another way to “inject” the dtb in the installation?
If not, what should I do to backup every change already made (kodi addons, tvh configuration, …)?

Any help would be appreciated

I have upgraded, & my remote no longer works. I am pretty certain, I used the correct dtb.

H96 Pro using Logitech 650 with Mecool KIII pro profile.

I am in the process of trying to restore an earlier backup.

If anyone could link to the earlier CoreELEC version I would be grateful

tried to go to a nightly from 1st Nov, that didn’t fix the remote. so I restored a backup from a couple of weeks ago.
Now the remote works, the version, is the same as the nightly.

Sorry to followup myself.
As I didn’t get any feedback I will revert to and wait for the next version.
I hope that the backup of /storage/.kodi is enough. :worried:

Can you ssh and do cat /proc/device-tree/le-dt-id

Thanks for pulling in :+1:

I posted it in the news thread for
I’m now again with, and the result is the same: gxl_p230_k1_pro

OBS: I picked the only one with “k1” in the name and it works. Is this the correct one?

I had also trouble with my X96 mini remote. Worked in earlier CE Versions perfectly.

In it stoped working. It was a new clean install.

ir-keytable -a /storage/.config/rc_maps.cfg -s rc0

placed in solved the problem for me.

Thanks dbasabe your advice works. But the remote is not working. Did you managed to make it work? Did you had to upload a proper remote.conf?


This file makes the remote work. However the volume buttons don’t work.