Issues with SMB sources after Router's firmware update (SMB v2 & 3)

Hey all !

So I need yor help to understand something.
My setup is the following:

  • A Fritz!Box 4040 router (firmware / OS version 7.14) and two usb hard disk drives plugged on it. I use these two hard drives as SMB sources for my video / movie files.
  • A Mini M8s II TV box with CoreElec setup to access / view these two SMB sources.
  • A Windows 10 PC with KODI that also has access to these SMB shares.

My current setup worked fine. BUT:
Yesterday I tried a new beta firmware (7.24) for my Fritz 4040 router. After the update, my CoreElec TV Box has issues with the SMB shares. When I start playing a movie, it stops after a few seconds, KODI seems to hang and after ~1 minute it brings me to the main KODI menu.
My Windows 10 PC KODI has no such issues.

When I revert my Fritz 4040’s firmware to the current stable / official one (7.14), the issue is fixed ! I can -again- play my SMB shared movies without problems on my TV Box.
What worries my is that this beta firmware is just weeks from being released as stable. So I’m trying to see what happens, so that I will not be disappointed when I update my router in the future. I would also like to send feedback to the router’s devs so that no one will have issues when the new firmware is released as stable.

Now, I don’t know if this helps but here is some info that might be related to the issue. If this info does have to do with the issue, I’m just not sure how to connect the dots to understand what exactly is happenning here, and that’s where I need your help.

  • The new beta firmware for my Fritz 4040 router (7.2X) has a changelog which among other release notes states the following:
    “Do you use USB storage media on your FRITZ!Box? FRITZ!OS 7.20 delivers improved performance when using the Windows network drive function for access to data and files. Starting with FRITZ!OS 7.20, FRITZ!Box also supports the SMB v2 and v3 file-sharing protocols.”

  • So the way I see it, my Fritz router’s current (stable firmware 7.14) does NOT support SMB v2 and v3, right? To test that, I went to CoreElec Kodi settings -> services and put minimum SMB to v2 and maximum to SMB v3. And yeap, I started getting errors, saying that my network (something) is not accessible.

  • So maybe when I install (again) the new (beta or stable 7.2X) firmware on my router I should go and change some settings within CoreElec Kodi ? Should I go to settings-> services and change the minimum SMB version to v2 and the maixmum to v3 ? Not sure. The way I see it, leaving the option to “none” does not exclude v2 and v3, so I shouldn’t have to change those settings (unless I want to change those settings for security reasons, which is a whole different story), right?

  • Am I doing something wrong with the new beta firmware, is there anything that I should be doing, or maybe the beta firmware has some bugs that affect the SMB sharing?

I would appreciate any feedback on this.
Thanks in advance.

Which CE version are you running?
Try the nightly builds, IIRC, there were some SMB related changes.

Hi.
I’m running CE 9.2.5 (stable / not the -ng)

A lot of these routers run rudimentary smb1 version which is now getting problematic for OS support as smb1 is actively deprecated.

Ultimately its a good idea to upgrade to a simple NAS.

Shoog

It just makes me wonder because with the current firmware of the router (that supports only SMB 1) I have no issues.
The issues appeared when I tried the new / beta firmware that supposedly “supports the SMB v2 and v3 file-sharing protocols”. Should I make any changes to CoreElec’s SMB settings for that new firmware to work well ?

Then try a nightly build, preferably -ng.

It maybe that they have moved over your shares to SMB2 or 3, which would require password authentication. I would test be attempting to add the share again in CE and see what it asks you.

Shoog

On the CoreElec configuration page -> Services >Samba, I can see that the Minimum supported protocol is set as “SMB2” and the Maximum is SMB3.
But on the Kodi -> settings -> services I have “none” set up on both.
Do we know which is the one that matters most ?
If the CoreElec settings is the one that matters, then how is this playing nice with my router’s stable (old) firmware that supposedly does not support SMB 2 and SMB 3 ?

Anyway, I guess I will have to try what Shoog suggested.
Flashing my router with the new/beat firmware again and setting up my SMB shares from scratch to see what happens.

The Coreelec SMB settings is for the inbuild samba server, the Kodi smb settings is for the client side. So you need to ensure that your client is set correctly.

Shoog

Yeah I flashed again the new/beat firmware on the router.
Same issue.
So I cleaned the library.
Now, when I go to add a new source, I choose “Windows Network (SMB)” and it does not even show me my hard drives.
Something definitely has changed regarding the Samba shares.

On the router it says: “For access via FTP or via a network drive (SMB), a FRITZ!Box user with the right to access NAS contents must be configured. Configure the users in the “System > FRITZ!Box Users > User” area.”

When I go to the User area I do have a user set up, with username and password.
The problem seems to be that CoreElec Kodi does not ask me to enter the credentials of this user when I try to browse my SMB network shares and add a source. How could I do that ?

Sounds like CE is trying to use SMB1, try setting minimum client to V2 on Kodi settings.

You can configure an SMB source manually in Kodi, with user\pass.

My mistake is that I forgot to mention that on both CoreElec and Kodi I have already set up
Minimum SMB2
Maximum SMB3

I just can’t get why it does not even see / let me browse my SMB sources.
I even tried to type by myself the SMB path for my TV series and I got a “invalid argument” error message.

Now next try is to edit the sources I already have, set type to NONE, clean the library and then set type again to TV Shows and see if the Movie Database scraps the files.

Yeah, I just read this:

“SMB v2 and later does not support Browse. You must type the folder name…”

I guess that’s why I cannot browse my sources.
Makes me wonder, though why it does not see the already set up sources I have and just ask me for username and password (one time).
So I’m gonna go clean the library, then add the sources manually and see what I’ll get.

p.s. the irony: I just found a setting within my router’s new firmware that allows me to enable SMB v1.

As part of the security enhancements with SMB V2 and 3 you can’t successfully browse and locate network shares. I have found that the simplest option is to set fixed IP addresses in my router for any devices hosting media for Kodi and then set those IP addresses as the source and the share name for the folder in my Kodi config. I also set a user and password on the shares and use that in the source setup. It’s a bit of a faff for a home network but it works consistently for me, particularly in a mixed linux/windows 10 network.

Its a good idea to drop SMBV1 from your system.
I find that I can still navigate to my shares using Zeroconfig when setting your sources, but not everyone has the same experience.

Shoog

@Joe_90
I have fixed IP addresses for all my network devices, too. I assign the fixed IP addresses via the router’s settings.
In my case the network shares have my router’s IP, because they are two USB hard drives plugged to the router.
Could you please clarify what Kodi config file you mean? Maybe give me an example?
Do you mean the sources.xml like this one?

@Shoog
I tried with Zeroconfig, too but it does not work. I get “invalid argument”, here too.

I tried setting up my network shares from the start (add new network location) and typing myself the path. It got it but when I tried to browse within that path to see the files/ movies I have in there, I got the same issue. It would hang.
I even tried enabling the SMB v1 within the settings of the new firmware, and setting max and min SMB to “none” in the KODI settings, but still I cannot browse the network shares.

For now I reverted again to the stable / current firmware and I will send this topic to the Router’s firmware devs to have a look. Let’s hope that by the time the firmware is released as stable the issue will be fixed. Thanks for the feedback.

In the Kodi dialogue to set up a new source, you specify the router IP address, the share name and the user/password. This will affect the sources.xml file and the passwords.xml file. I found it easier to just set passwords on the shares as this works on my N2 Kodi and also on my satellite box running enigma. I’ve abandoned SMB V1 altogether as I have made sure my various boxes are running up-to-date software.

Here’s a snip of my passwords.xml and sources.xml files:



music
smb://192.168.0.112/Multimedia/music/
true


multichannel
smb://192.168.0.112/Multimedia/multichannel/
true

<passwords>
    <path>
        <from pathversion="1">smb://192.168.0.112/Multimedia</from>
        <to pathversion="1">smb://kodi:password@192.168.0.112/Multimedia/HomeVideos/</to>
    </path>
</passwords>

Thanks.
My third effort. Here are the steps I followed:

  • I flashed my Fritz router with the new beta firmware that supports SMB2 & 3.
  • I launched CoreElec. I set up minimum SMB 2 and maximum SMB 3 on KODI settings
  • I cleared the Kodi library
  • I modified the sources.xml and I checked the passwords.xml to have the right username and password. I put them in the userdata folder of my CoreElec box and overwrited the old ones.
  • I checked that I have set up the specific user with the right access regarding the SMB shares within the router’s settings.
  • I rebooted CoreElec

The sources were there. I could see that the scrapping was stuck to 0%. This gotta mean something right? I went to play a movie file via Files. Same issue.The movie would play for a few seconds and then stop.

  • I went to my router’s SMB settings and created a new user and gave it the right access permissions on the SMB shares I have.
  • I edited the sources and the passwords.xml to reflect the changes
  • I put the files to the CoreElec box userdata folder overwriting the old ones.

Same issue again.

BUT, to make it even more weird, this time I also found out this:
So I have three shared folders:

    <name>TV Series</name>
    <path pathversion="1">smb://coreelecuser:mypass@FRITZ-NAS/FRITZ.NAS/INTENSO/Video/TV Series/</path>
    <allowsharing>true</allowsharing>
</source>
<source>
    <name>Movies</name>
    <path pathversion="1">smb://coreelecuser:mypass@FRITZ-NAS/FRITZ.NAS/SlimVideoBook/Video/Movies/</path>
    <allowsharing>true</allowsharing>
</source>
<source>
    <name>Various Videos</name>
    <path pathversion="1">smb://coreelecuser:mypass@FRITZ-NAS/FRITZ.NAS/INTENSO/Video/Various Videos/</path>
    <allowsharing>true</allowsharing>
</source>

I tried playing like approx. 30 different files from these shares.
Guess what. Almost 1/5 of the video files were playing just fine !
The other 4/5 would stop after a few seconds.
Not patterns here. I checked with .mkv, .avi, .mp4 files. Some of them (not matter what the file type was) were playing fine, some other (even of the same type) had the issue.

I don’t even know what to think of this issue right now.
I mean, is it logical that with the older (stable) router’s firmware everything played fine and with the new one I have these issues?
Sounds really strange to me. At this point I don’t even know if this is actually an SMB issue at all !

Device name resolution wouldn’t work for me - only IP addresses. Maybe you have the Fritz box in your hosts file?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice