Issues with SMB sources after Router's firmware update (SMB v2 & 3)

You mean .config/hosts.conf ?
No, the Fritz Box is not there.
I should try what you said. The IP of the router instead of the name resolution, in the sources.xml and the passwords.xml.
I will get back with feedback.

1 Like

They’ve just released a newer beta. I flashed it to my Fritz router.
I set up SMB2 minimum and SMB3 maximum in the KODI settings.
Here is my sources.xml (the bit with the paths):

    <default pathversion="1"></default>
        <name>TV Series</name>
        <path pathversion="1">smb://user1:pass1@ Series/</path>
        <path pathversion="1">smb://user1:pass1@</path>
        <name>Various Videos</name>
        <path pathversion="1">smb://user1:pass1@ Videos/</path>

Here is the passwords.xml file

        <from pathversion="1">smb://</from>
        <to pathversion="1">smb://user1:pass1@</to>

Here are the sharing rights / settings for this user:


and here is the structure of my hard disks and subfolders

Intenso/Video/TV Series
>T V S A R C H I V E S
>T V S W A T C H I N G

>M O V I E S
>M O V I E S A R C H I V E S

Intenso/Video/Various Videos

These are the sharing / SMB settings in the router GUI


At first even getting into the subfolder “TVS Watching” took a few minutes (!).
I played with the “set content” option, it was “none”, I changed it to “TV Shows” so that it will get scrapped by The Movie Database.
The scrapping did proceed this time. Good sign.
However, even now, when I go to play video files, most of them stop after a few seconds.

I’ve also got twice already this Kodi message, while trying to get into a TV Series subfolder (e.g. Big Little Lies > Episode 1x01):

“Write Error Detected.
The destination may not be writeable.
Would you like to continue”?

although eventually it does get into that subfloder and it does play some (very few) of the video files.

Any hints / suggestions, other than throwing the box or the router out of the window ? :blush:

p.s. The Windows 10 Kodi keeps playing nice. No issues there !
p.s. 2: changing Kodi settings to minimum SMB 1 / maximum SMB3 and selecting “enabling support for SMB v1” in the router settings lead to an error: “software caused connection abort” when trying to play a file.


This situation with these files that started playing and stopped made me suspicious of something completely different than what I had thought till today.

So a few months ago I had created an advancedsettings.xml file with this content:


Guess what !
Deleting this file seems to do the trick !
The files now seem to play without issues !
That’s weird. I will keep investigating and write back with any new findings.

I had similar experience with messing with the buffer files. Glad you tracked it down.


I’m not sure I have fixed this 100%
I’m still getting some “the destination may not be writable” errors.
I might end up back to SMB v1 albeit with the new beta firmware. I’ll see

And I still wonder how come a buffer file can in any way mess with the …SMB settings and a “new” firmware for a router. Can’t even think of the connection.

Hello again.
Thought I would share my progress so far.
This might help other people with similar issues.
I would also like to thank everybody that helped here.

My current setup:
Fritz!Box 4040 router with the latest BETA firmware (7.24)
Fritz settings: SMBv1 disabled
Two USB hard disks plugged to the router / used as sources in Kodi / CoreElec
All my devices have static IPs, assigned via the router’s network settings.

Box: Mini M8s II (905x, 16/2GB)
CoreElec 9.2.5 (non -ng) / installed in microSD card

Kodi SMB settings: min SMB2, max SMB3
Sources.xml and Passwords.xml files edited to add manually the sources paths with the IP of the router (instead of the Name) + username and the password that SMB2 requires (as browsing is not allowed). Library was cleared before I applied the new .xml files.

Some notes:

  • the mystery with the advancedsettings.xml file has not been solved. Eventually I had to delete it, for everything to work. Otherwise most of my video files were just not playable. The system would even hang some times with that file in place. I tried various versions of it without success. Still makes me wonder how come the .xml file did not cause problems with the current / older stable firmware of the router, but brings up huge issues with the new BETA firmwares (that will become official soon).

  • the “the destination may not be writable” error was probably due to my mistake of forgetting to edit a path in which I have set the “Backup” add on to keep automatic backups of a few files, just to keep alive one of the hard disks that goes to sleep mode and caused issues in the past.

  • so far this setup seems to work. I wanted to move from SMBv1 to SMB2 / 3 and make use of the new (BETA for the time being) firmware of my router that now supports these SAMBA versions. I’ll keep testing this and get back if anything worth mentioning arises. Let’s hope that this setup will work without any more issues.

1 Like

Just seen your post, I have the the same issue… I’m running OpenWrt 18.06.4 on a BT hub 5, A NTFS formatted disk connected to the USB port
I setup a simple network share (no passwords, users etc theres only tv shows & movies on the disk)

This issue has been around a long time, I just assumed it was the router software (and could still be)…anyway for the advancedsettings.xml, if you set the buffer for true internet streams it plays local content fine e.g.


Hi there.
Whatever number I put in the buffermode tag, the same issue occurs.
Furthermore, I wanted the caching for the local (SMB lan) files, as I mostly watch local videos / movies.
My TV Box has a 100 lan card so I had some buffering in the past with some videos.

I ended up plugging a USB 3.0 to 1Gbit lan adapter to my box’s USB 2.0 and so far I think I have better results on speed.

So maybe I won’t really need the advancedsettings.xml file anymore. I will keep testing and see where this gets me.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.