Issues with SMB sources after Router's firmware update (SMB v2 & 3)

The Coreelec SMB settings is for the inbuild samba server, the Kodi smb settings is for the client side. So you need to ensure that your client is set correctly.


Yeah I flashed again the new/beat firmware on the router.
Same issue.
So I cleaned the library.
Now, when I go to add a new source, I choose “Windows Network (SMB)” and it does not even show me my hard drives.
Something definitely has changed regarding the Samba shares.

On the router it says: “For access via FTP or via a network drive (SMB), a FRITZ!Box user with the right to access NAS contents must be configured. Configure the users in the “System > FRITZ!Box Users > User” area.”

When I go to the User area I do have a user set up, with username and password.
The problem seems to be that CoreElec Kodi does not ask me to enter the credentials of this user when I try to browse my SMB network shares and add a source. How could I do that ?

Sounds like CE is trying to use SMB1, try setting minimum client to V2 on Kodi settings.

You can configure an SMB source manually in Kodi, with user\pass.

My mistake is that I forgot to mention that on both CoreElec and Kodi I have already set up
Minimum SMB2
Maximum SMB3

I just can’t get why it does not even see / let me browse my SMB sources.
I even tried to type by myself the SMB path for my TV series and I got a “invalid argument” error message.

Now next try is to edit the sources I already have, set type to NONE, clean the library and then set type again to TV Shows and see if the Movie Database scraps the files.

Yeah, I just read this:

“SMB v2 and later does not support Browse. You must type the folder name…”

I guess that’s why I cannot browse my sources.
Makes me wonder, though why it does not see the already set up sources I have and just ask me for username and password (one time).
So I’m gonna go clean the library, then add the sources manually and see what I’ll get.

p.s. the irony: I just found a setting within my router’s new firmware that allows me to enable SMB v1.

As part of the security enhancements with SMB V2 and 3 you can’t successfully browse and locate network shares. I have found that the simplest option is to set fixed IP addresses in my router for any devices hosting media for Kodi and then set those IP addresses as the source and the share name for the folder in my Kodi config. I also set a user and password on the shares and use that in the source setup. It’s a bit of a faff for a home network but it works consistently for me, particularly in a mixed linux/windows 10 network.

Its a good idea to drop SMBV1 from your system.
I find that I can still navigate to my shares using Zeroconfig when setting your sources, but not everyone has the same experience.


I have fixed IP addresses for all my network devices, too. I assign the fixed IP addresses via the router’s settings.
In my case the network shares have my router’s IP, because they are two USB hard drives plugged to the router.
Could you please clarify what Kodi config file you mean? Maybe give me an example?
Do you mean the sources.xml like this one?

I tried with Zeroconfig, too but it does not work. I get “invalid argument”, here too.

I tried setting up my network shares from the start (add new network location) and typing myself the path. It got it but when I tried to browse within that path to see the files/ movies I have in there, I got the same issue. It would hang.
I even tried enabling the SMB v1 within the settings of the new firmware, and setting max and min SMB to “none” in the KODI settings, but still I cannot browse the network shares.

For now I reverted again to the stable / current firmware and I will send this topic to the Router’s firmware devs to have a look. Let’s hope that by the time the firmware is released as stable the issue will be fixed. Thanks for the feedback.

In the Kodi dialogue to set up a new source, you specify the router IP address, the share name and the user/password. This will affect the sources.xml file and the passwords.xml file. I found it easier to just set passwords on the shares as this works on my N2 Kodi and also on my satellite box running enigma. I’ve abandoned SMB V1 altogether as I have made sure my various boxes are running up-to-date software.

Here’s a snip of my passwords.xml and sources.xml files:



        <from pathversion="1">smb://</from>
        <to pathversion="1">smb://kodi:password@</to>

My third effort. Here are the steps I followed:

  • I flashed my Fritz router with the new beta firmware that supports SMB2 & 3.
  • I launched CoreElec. I set up minimum SMB 2 and maximum SMB 3 on KODI settings
  • I cleared the Kodi library
  • I modified the sources.xml and I checked the passwords.xml to have the right username and password. I put them in the userdata folder of my CoreElec box and overwrited the old ones.
  • I checked that I have set up the specific user with the right access regarding the SMB shares within the router’s settings.
  • I rebooted CoreElec

The sources were there. I could see that the scrapping was stuck to 0%. This gotta mean something right? I went to play a movie file via Files. Same issue.The movie would play for a few seconds and then stop.

  • I went to my router’s SMB settings and created a new user and gave it the right access permissions on the SMB shares I have.
  • I edited the sources and the passwords.xml to reflect the changes
  • I put the files to the CoreElec box userdata folder overwriting the old ones.

Same issue again.

BUT, to make it even more weird, this time I also found out this:
So I have three shared folders:

    <name>TV Series</name>
    <path pathversion="1">smb://coreelecuser:mypass@FRITZ-NAS/FRITZ.NAS/INTENSO/Video/TV Series/</path>
    <path pathversion="1">smb://coreelecuser:mypass@FRITZ-NAS/FRITZ.NAS/SlimVideoBook/Video/Movies/</path>
    <name>Various Videos</name>
    <path pathversion="1">smb://coreelecuser:mypass@FRITZ-NAS/FRITZ.NAS/INTENSO/Video/Various Videos/</path>

I tried playing like approx. 30 different files from these shares.
Guess what. Almost 1/5 of the video files were playing just fine !
The other 4/5 would stop after a few seconds.
Not patterns here. I checked with .mkv, .avi, .mp4 files. Some of them (not matter what the file type was) were playing fine, some other (even of the same type) had the issue.

I don’t even know what to think of this issue right now.
I mean, is it logical that with the older (stable) router’s firmware everything played fine and with the new one I have these issues?
Sounds really strange to me. At this point I don’t even know if this is actually an SMB issue at all !

Device name resolution wouldn’t work for me - only IP addresses. Maybe you have the Fritz box in your hosts file?

You mean .config/hosts.conf ?
No, the Fritz Box is not there.
I should try what you said. The IP of the router instead of the name resolution, in the sources.xml and the passwords.xml.
I will get back with feedback.

1 Like

They’ve just released a newer beta. I flashed it to my Fritz router.
I set up SMB2 minimum and SMB3 maximum in the KODI settings.
Here is my sources.xml (the bit with the paths):

    <default pathversion="1"></default>
        <name>TV Series</name>
        <path pathversion="1">smb://user1:pass1@ Series/</path>
        <path pathversion="1">smb://user1:pass1@</path>
        <name>Various Videos</name>
        <path pathversion="1">smb://user1:pass1@ Videos/</path>

Here is the passwords.xml file

        <from pathversion="1">smb://</from>
        <to pathversion="1">smb://user1:pass1@</to>

Here are the sharing rights / settings for this user:


and here is the structure of my hard disks and subfolders

Intenso/Video/TV Series
>T V S A R C H I V E S
>T V S W A T C H I N G

>M O V I E S
>M O V I E S A R C H I V E S

Intenso/Video/Various Videos

These are the sharing / SMB settings in the router GUI


At first even getting into the subfolder “TVS Watching” took a few minutes (!).
I played with the “set content” option, it was “none”, I changed it to “TV Shows” so that it will get scrapped by The Movie Database.
The scrapping did proceed this time. Good sign.
However, even now, when I go to play video files, most of them stop after a few seconds.

I’ve also got twice already this Kodi message, while trying to get into a TV Series subfolder (e.g. Big Little Lies > Episode 1x01):

“Write Error Detected.
The destination may not be writeable.
Would you like to continue”?

although eventually it does get into that subfloder and it does play some (very few) of the video files.

Any hints / suggestions, other than throwing the box or the router out of the window ? :blush:

p.s. The Windows 10 Kodi keeps playing nice. No issues there !
p.s. 2: changing Kodi settings to minimum SMB 1 / maximum SMB3 and selecting “enabling support for SMB v1” in the router settings lead to an error: “software caused connection abort” when trying to play a file.


This situation with these files that started playing and stopped made me suspicious of something completely different than what I had thought till today.

So a few months ago I had created an advancedsettings.xml file with this content:


Guess what !
Deleting this file seems to do the trick !
The files now seem to play without issues !
That’s weird. I will keep investigating and write back with any new findings.

I had similar experience with messing with the buffer files. Glad you tracked it down.


I’m not sure I have fixed this 100%
I’m still getting some “the destination may not be writable” errors.
I might end up back to SMB v1 albeit with the new beta firmware. I’ll see

And I still wonder how come a buffer file can in any way mess with the …SMB settings and a “new” firmware for a router. Can’t even think of the connection.

Hello again.
Thought I would share my progress so far.
This might help other people with similar issues.
I would also like to thank everybody that helped here.

My current setup:
Fritz!Box 4040 router with the latest BETA firmware (7.24)
Fritz settings: SMBv1 disabled
Two USB hard disks plugged to the router / used as sources in Kodi / CoreElec
All my devices have static IPs, assigned via the router’s network settings.

Box: Mini M8s II (905x, 16/2GB)
CoreElec 9.2.5 (non -ng) / installed in microSD card

Kodi SMB settings: min SMB2, max SMB3
Sources.xml and Passwords.xml files edited to add manually the sources paths with the IP of the router (instead of the Name) + username and the password that SMB2 requires (as browsing is not allowed). Library was cleared before I applied the new .xml files.

Some notes:

  • the mystery with the advancedsettings.xml file has not been solved. Eventually I had to delete it, for everything to work. Otherwise most of my video files were just not playable. The system would even hang some times with that file in place. I tried various versions of it without success. Still makes me wonder how come the .xml file did not cause problems with the current / older stable firmware of the router, but brings up huge issues with the new BETA firmwares (that will become official soon).

  • the “the destination may not be writable” error was probably due to my mistake of forgetting to edit a path in which I have set the “Backup” add on to keep automatic backups of a few files, just to keep alive one of the hard disks that goes to sleep mode and caused issues in the past.

  • so far this setup seems to work. I wanted to move from SMBv1 to SMB2 / 3 and make use of the new (BETA for the time being) firmware of my router that now supports these SAMBA versions. I’ll keep testing this and get back if anything worth mentioning arises. Let’s hope that this setup will work without any more issues.

1 Like

Just seen your post, I have the the same issue… I’m running OpenWrt 18.06.4 on a BT hub 5, A NTFS formatted disk connected to the USB port
I setup a simple network share (no passwords, users etc theres only tv shows & movies on the disk)

This issue has been around a long time, I just assumed it was the router software (and could still be)…anyway for the advancedsettings.xml, if you set the buffer for true internet streams it plays local content fine e.g.


Hi there.
Whatever number I put in the buffermode tag, the same issue occurs.
Furthermore, I wanted the caching for the local (SMB lan) files, as I mostly watch local videos / movies.
My TV Box has a 100 lan card so I had some buffering in the past with some videos.

I ended up plugging a USB 3.0 to 1Gbit lan adapter to my box’s USB 2.0 and so far I think I have better results on speed.

So maybe I won’t really need the advancedsettings.xml file anymore. I will keep testing and see where this gets me.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.