Java for BD-J menus?

If I activate Full BD menu support I get an error message that java is missing for BD-J. Can you please add java to the next CoreElec builds to support BD-J?

There are no plans to include Java with our releases as this would increase our image size by over 50%.

BD menu support should be fine for files without BD-J.

would love to see this added also, or maybe a guide so we can do it ourselves?

Would it be possible to supply an addon package for Java? This could prevent to increase of the image size.

Unfortunately not, there is plenty of information already available on this topic, Google ‘BD-J Kodi’.

Someone had been working on a plugin for adding BD-J but was only looking at x86. Someone would need to take that work with ARM being the target. You need more then just the JRE as you need to rebuild libbluray to produce libbluray*.jar, so at least the JDE and Apache Ant.

I got so far as installing Zulu as the JDK on my Odroid C2, but haven’t gotten to trying to build libbluray yet.

Hi

i also would like to get java. Sdcards are cheap nowadays and internet connections faster than before. It would be nice to be able to have java (as an option) for those who want it.

thanks to the team and people around here
Rgds

Even with Java not all menus are working :frowning:

wait and see i guess !

I spend lot of time on this in the past with Java and saw no perfection :frowning:

Doesn’t Makemkv supports something similar?

Hi vpeter

mkv is one thing, full untouched (uhd)bluray is another. Kodi has the feature when java is present (assuming it’s working). Everyone is free to choose what’s best for him !

1 Like

If you want to check java try this rpi addon and see if it is working: http://vpeter.libreelec.tv/BD-J/program.java-9.0.101-RPi2.arm.zip
It is arm version so it could? If not you just need to replace java with correct version.

It is from this LE thread: https://forum.libreelec.tv/thread/11701-add-built-in-java-support/?postID=84636#post84636

I don’t run any aml device but I will be happy to help get java running if interested.

1 Like

Hello. Had to create an account here to post a reply about this.

I’m a Blu-ray Disc Java (BD-J) developer, and would also love to see this supported. I.e. have Java as a part of the image file.
BD-J was invented in 2001, when Java had only reached version 1.3. So in theory it should be possible to add a very small version of JRE to make BD-J run.

But let me explain why not all Blu-ray Java menus work for everyone: Because libbluray is developed by volunteers, and hasn’t been completed yet. It contains bugs.
But developers have gotten far, and I’m sure it’ll get even better.

Anyway, about BD-J, it was designed mainly for two things: Cool menus for movies, and bonus content such as games. Movies like “Bolt” and “Ratatoille” contains games you can play with the remote control. And there’s a small community of homebrew gamedevs that makes games with BD-J because it runs on gaming consoles such as PS3, PS4, XB1 and soon PS5 and Xbox Scarlet. One disc runs on all. See www.blu-play.com
So by adding Java, you’ll open up for small homebrew games too. Simply play the ISO or folder structure with “full BD menus”.

You’ll also be able to run other BD-J projects, like my own “8-bit Memoirs”; a diskmag-like eBook about the good old retro consoles and computers from the 80s. See www.8bitMemoirs.com
Kodi is very cool here, in that it actually lets you stream this Blu-ray project via HTTP or WebDAV including the Java part. No need to download the ISO. Just stream it.

There is no need to include Java in image itself because it can easily be installed as addon. One day I will look again in addon I made. But because I do not own any disk I need to rely on downloaded ISO’s. But last time seems my copy got corrupted somehow. Which means I would need to find one which really works.

I will check this “8-bit Memoirs” right now :slight_smile:

Update: Online streaming doesn’t work :frowning:

1 Like

Hm, will check out the online streaming.

Meanwhile, here’s a much smaller ISO you can test with:
http://blu-play.com/iso/UkkosJourney-BluPlay.iso

EDIT2: Hmm… couldn’t get it working at first, but works fine now.

Go to “Movies” -> “Add videos…”
In the path, type: “https://www.8bitmemoirs.com:443/online/Disc/
Give it a name like “8-bit Memoirs online”

Then click Ok to exit to the list of Video sources. Right-click “8-bit Memoirs online” and select “Play”. Then it loads for a minute or so, and then starts playing.

Anyway, if you’re on IRC you can find me in channel #Blu-Play on Freenode or #IndieGameMusic on EsperNet

I found some other small ISO (UkkosJourney-BluPlay.iso ~80MB) and menu was still working on my x86 machine.
I’m expecting Amlogic device soon and when I will get it I will look how to make running there. If it works on Raspberry Pi there is no reason it wouldn’t work on Amlogic too :slight_smile:

Regarding streaming of “8-bit Memoirs”: in Kodi log I see
ERROR: CCurlFile::FillBuffer - Failed: SSL peer certificate or SSH remote key was not OK(60)
Seems some certificate issue even with verifypeer=false. Will look more closely in a next days.

It may have something to do with the way paths are written, not sure.

https://www.8bitmemoirs.com:443/online/Disc/ works fine for me. Notice the port 443 is included. Could you try that?

EDIT: Hmm… As a new user I’m limited to only 3 replies, so adding an edit here:

Actually no. It seems it is the capital M in 8bitMemoirs that was the problem…
I just tried a few different ways of writing it. Very weird! Never thought the domain name had anything to say.
8bitMemoirs doesn’t work, but 8bitmemoirs does, even when omitting the port number… :thinking:

Since I can’t reply anymore due to being new, you can find me on IRC as stated above.

I tried menus on old Amlogic box (Wetek Play 1) and menus worked.

In case anyone would like to try it out on more modern box: http://vpeter.libreelec.tv/BD-J/program.java-9.0.101-WeTek_Play.arm.zip

Hi vpeter

sorry for this late reply, i was a bit busy these last weeks. Thanks a lot. I will try that and report you if i can work sth out of my ordroid n2 with the informations.

:smile:

Thanks vpeter works on my S905 but stutters like hell and video is softvideo decoded only ( BD is Smurfs 2) and yes hardware decoding is set to always in settings