Java for BD-J menus

So you get BD-J menu?

I though playing something from menu is independent from menu itself. Will check and report back.
If you play video in usual way without BD-J menu it plays well?

Exactly ! Bj menu = software decoded video.
No menu = hardware decoded video

It should not work like that.

I still see hw decoded video when using LE 9. Will test on CE in next days.

1 Like

Hello VPeter

hope you’re doing well.

a friend and i had some tests with our odroid N2s yesterday. We installed Java thanks to your link. We had a small 20GB full bluray.
Menus appeared but not videos behind the menus. Then we tried the chapters. It seemed fine but when selecting a chapter, there was no video and we had sound issues(almost no sound actually)

Should we try now to replace content with newer java files ?


I tested this only with limited access to br disks. All the tests were done only with movie Shortwave.2016.COMPLETE.BLURAY-UNTOUCHED.iso and bd game UkkosJourney-BluPlay.iso. Both were working on LibreELEC Generic and Wetek Play. Not yet tested on any other more modern Amlogic device (waiting for CE VIM3 device).

If you actually see BD-J menu then it means that JRE is installed and picked by Kodi correctly. Everything else is a mater or more tests with more movies (which I don’t have).

Hi, Tomti. I think the issue of videos not appearing behind menus is not actually a Java issue because I have a BD that doesn’t have Java and the menus look the same as you described in this topic and I have described here: BD Menu issue

It’s a CoreELEC issue that’s been present since CoreELEC Leia. And it’s the same thing on LibreELEC 9. On LibreELEC 8 I get the video behind menu, but the menu (and the background video) is slow and it doesn’t use HW acceleration on my S905W box.

Hello Ant123 and Vpeter,

i will try with other blurays. But if Ant123 is correct i won’t have more success. I’ll let you know !


I don’t own any device running coreelec but I have some knowledge with libbluray.

Videos not showing is related to old libbluray versions. The new one 1.1.1 works with every menu I tried including UHD bluray.
I have updated it to be used on Kodi x64/x32 but it should work on coreelec.

Here’s the link for the thread with ready to go package

.jar files are not enough because Kodi also must use newer library.

I would like to fix UHD BD subtitle languages (they just show as Unknown) and I guess it is the fault of the libbluray we use.
So I have to get the latest libbluray and if the problem is still there then fix it myself.
Am I right?

Does it exist some sample to test this problem? Something small.

You just need to bump libbluray package and make own CE build. And add 2 .jar files in jre addon (I have them available at

Do you know which version of libbluray is in CE?
I’ll try to make a small sample for you.

LE and CE (and Kodi in general) is using 1.0.2.
But I already check 1.1.2 for some other issue.

It’s not just the jar files in that package.
It has all the dlls for libbluray already compiled and for every other dependency.

But since core elec uses Linux dlls are not usable at all, right?

It could be possible to mount bind newer shared library

I’ve already compiled libbluray on Linux once but the resulting was the already mentioned .jar files.

Maybe I can take a look at compiling it again but aiming Linux OS.

What are you trying to do? I can provide file for a test.

Could you? I would like to test this subtitle thing if possible.

Should I overwrite the 2.0.2 or copy it to the same folder?
CoreELEC:/ # ls -la /usr/lib/libblur*
lrwxrwxrwx 1 root root 18 Jul 20 23:45 /usr/lib/ ->
lrwxrwxrwx 1 root root 18 Jul 20 23:45 /usr/lib/ ->
-rwxr-xr-x 1 root root 231544 Jul 20 23:45 /usr/lib/