Java for BD-J menus

Save file somewhere and use

mount -o bind libbluray.so.2.1.2_aml /usr/lib/libbluray.so.2.0.2
systemctl restart kodi

Thank you!
Unfortunately nothing changed. I mean the bug is still there.
Which is weird, because the UHD BD playlist is almost the same as the normal BD playlist.
Maybe it is just check the version and not even try to get the language info…
Where can I find the source for this 2.1.2?

http://download.videolan.org/pub/videolan/libbluray/1.1.2/libbluray-1.1.2.tar.bz2

OK, I had this already.

So if you can update libbluray and compile it.
Can’t you share or just update it on CoreElec build?

This would improve compatibility.
You would also need to update libxml2 for it to work.

Hi everyone

I was a bit away but happy to see things seem to go in the right direction even if it is now holydays for many people.

thank you vpeter,Pelica,Fandangos,ant123…

Dear all.
I’ve seen this commit in the last CoreElec nightly build:

I cannot test now, anyone knows if it support Amlogic S9XX devices?
Thanks.

1 Like

Still software decoded video with latest CoreELEC and smurfs BD

Sadly I don’t see how video is actually played and why sw decoding is used.

On my Odroid N2, I can not read the menu of my ripped blurays. Is there a manipulation or configuration to implement?

Check Kodi debug log for any clues. It should just show menu without any extra configuration.

1 Like

I saw the jre.zulu somewhere on the CE repo and thought to try it.
It prompts to either pick a playlist or Show Menu. However choosing menu led to only hearing the audio but no video. Only tried one image so far.
Is it supposed to work?

It works but not for all disks.

All the Criterion Collection discs I’ve tried don’t display a menu.

@vpeter I have been following your posts in this topic and installed the jre.zulu addon. I tried to run an bluray iso but I end up with errors in the kodi.log and no menu is not showing up.
The error is “Failed to load libbluray.jar” and I run coreelec nightlies on an Odroid N2

Any advice would be helpful

paradix, after you install this addon you need to restart Kodi or reboot the device. After that it will work. If not post kodi log.

I just made fresh install of the addon and it is still working.

Hmm, ok I’ll try later. But I’m pretty sure I did restart kodi :slight_smile: We will see.

For the time being here is the log from yesterday
https://pastebin.com/pJ6R6TXd

@vpeter need to edit post, as I have only 3 replies as new user :slight_smile:
I’m running coreelec nightly - CoreELEC (official): nightly_20200410 (Amlogic-ng.arm)

But I have updated the library based on the posts previous to

I’m not sure which image you are running because of

DEBUG: CBlurayCallback::Logger - bluray.c:1413: libbluray version 1.1.2

We are still on 1.0.2 (this is what I get in kodi log)

DEBUG: CBlurayCallback::Logger - bluray.c:1408: libbluray version 1.0.2

As a workaround you could copy file libbluray-j2se-1.1.2.jar and libbluray-awt-j2se-1.1.2.jar to folder /storage/.kodi/addons/tools.jre.zulu/

wget -O /storage/.kodi/addons/tools.jre.zulu/libbluray-j2se-1.1.2.jar http://vpeter.libreelec.tv/BD-J/libbluray-j2se-1.1.2.jar
wget -O /storage/.kodi/addons/tools.jre.zulu/libbluray-awt-j2se-1.1.2.jar http://vpeter.libreelec.tv/BD-J/libbluray-awt-j2se-1.1.2.jar

But please tell me which image you are using?

Ok. So I updated to 9.2.2

CoreELEC (official): 9.2.2 (Amlogic-ng.arm)

And now can’t even play the bluray iso at all
https://pastebin.com/sKWXLM4N

@vpeter switched to CoreELEC (official): nightly_20200415 (Amlogic-ng.arm) and still getting the same results as in the pasted log.

I did copy that jars manually but the libbluray is still 1.0.2, so why would it need 1.1.2 jars?