Kernel 5.8 on Le Potato?

My first attempt at updating the dvb-latest drivers. Let me know if this fixes the issue for you.

I can confirm the WinTV-dualHD tuner works nice in the latest coreelec with the dvb-drivers package (currently not sure which one of the two - crazy cat or the other one - might even work with both).
But this is only true if used in usb2 port (actually it is usb2otg port of GT-King Pro in my case, i.e. S922X chipset).
If used in usb3 port, there are usb/i2c errors even when probing for the tuner.
In my opinion it is the usb3 host driver in amlogic-4.9 kernel where the problem is, because it works (can be probed without errors) with usb3 port in 5.7 kernel of libreelec (even in patched 5.1).
It is difficult to update the usb3 driver in aml 4.9.
I will test the ce build from @cdu13a in the evening, but I am afraid it will be the same: working in usb2 port and not working in usb3 port.

Guys, you’re awsome! Thanks!
@cdu13a: Will try as soon as I can and give feedback.
@teacup: Le Potato also has one USB port that’s OTG - I will try that one with all driver packages: I think a long while ago I tested this explicitly, but it made no difference then, so I stopped that at some point.

@Hauke, you should have no problem (with La Potato) running the tuner with current coreelec - the issues with usb3 reported seem to be specific to S922X - see here:

1 Like

@teacup: I am afraid I do have a problem, I just verfied everything. Here’s an overview:

  • Standard CoreELEC drivers: hardware not recognized.
  • CrazyCat driver package: hardware recognised, each tuner shows three services: DVB-T2, DVB-C and ATSC. Both tuners work, but both tuners show heavy distortions.
  • Lates drivers from kernel: hardware recognized, each tuner shows two services, DVB-T2 and DVB-C. Both tuners work, but second tuner shows distortions.

Still, trying this out I learned a few things:

  • OTG port delivers less power on Le Potato --> Had power issues
  • With powered USB hub no power problems (but still no properly working device)
  • It seems always to be the second tuner that is distorted. I first thought that distortions come in as soon as I run two tuners simultaneously, but looking closer it is always tuner #2 that has glitches, even if I use it alone.

So, which driver package was used on the S905X2/S905X3 you mentioned above? I followed the thread you linked in, but I was unable to figure it out…

@cdu13a: I’d really like to try out your driver, but I have no idea how to install it. Do i put your tarball into “update” foider and reboot? Will this overwrite my CoreELEC install/do I need a backup?

Is there anything else I can privide to help here?

Again, a big thanks for taking care!

@Hauke, I am afraid I cannot help you with the problems you describe. I have EU version of the tuner should that matter. In my opinion you should not have problem running the tuner in usb3 with your chipset, but I can say that only based on results posted by @Portisch.
If I remember correctly the standard coreelec dvb drivers did not work for me either. But both crazy cat and dvb-latest drivers seem to work.
The build from @cdu13a updates only dvb-latest drivers, so with that build you should select them to test that specifically. I am not sure what is the best user friendly way to install the build - I just updated kernel and rootfs (system) images on the sdcard manually and checked if dtb was still the same;-)

yes just place the tar file into the update folder and reboot. You can switch back to the nightly build the same way by downloading the tar file, putting it into the update folder and reboot.

If it makes you feel safer then doing a backup first would be best. however the only difference in the build from a recent nightly build is the updated dvb-latest driver. So I would not expect to have any issues with it beyond does the dvb adapter work better or worse.

@cdu13a I tried your drivers, and DVB-T2 is neither better nor worse than before, but Video playback ingeneral is not working well. If I switch to CracyCat drivers, DVB-T2 situation is still unchanged as compared to before with CrazyCat package, but Video playback is back to normal. Are you interested in me testing this further? I got an error message during boot on kernel modules not loaded sucessfully, but yet did not invest time in looking what went wrong. But am willing to do if you deem this helpful!
@teacup Well, I was afraid that you would say so. I also have the EU version. To avaoid misunderstandings: Le Potato does not have USB3. I understand that S905X would have been capable, but due to whatever reason Libre Computer chose only to offer USB 2 on Le Potato. Still, USB port does not make any difference.
After all, I’ll be back to where I have been: Have Raspberry 3 for DVB-T2 reception, and wait for kernel > 4.17 to appear at some point on Le Potato. Or, if this never happens, at some point switch to different hardware sigh
Thanks again for trying to help me!

That error message during boot on kernel modules is in my opinion caused by ‘videodev’ module “warning” backtrace logged from kernel. It may be related to the video playback issues you mention - I did not test playback of some video files, only tested playback of dvb-t2 channel that looked ok (when used with usb2otg).

That’s good enough thanks. I just wanted to see if trying to update the package would change anything. I guess not in this case.

Hi folks,
good news: With the Le Potato NG build the DualTV works now flawlessly! That’s a huge step forward for me - now have to check how ng works elsewise, already have a screen issue, but I suppose I soon can switch off my Raspberry 3…
Thanks for all the good work!