Khadas VIM3 Pro SDR to HDR fault

Any help for a new VIM3 user?
HDR automatically is activated whole time. even on SDR movies. Thats the problem for me.
tone map SDR to HDR and HDR to SDR is both deactivated. but it runs automatically in HDR mode again directly with khadas logo on boot.

I tried “fw_setenv sdr2hdr 0” over ssh, but still nothing changed.
fresh install on a absolute new VIM3 Pro.
Install to emmc single boot.
my LG B9 OLED is displaying 4K-HDR/BT.2020 whole time.

not ok (SDR2HDR is always active, instead off):
nightly 19.2-Matrix_nightly_20210609
CoreELEC-Amlogic-ng.arm-9.2.3-Generic
CoreELEC-Amlogic-ng.arm-9.2.4.2-Generic
CoreELEC-Amlogic-ng.arm-9.2.5-Generic
CoreELEC-Amlogic-ng.arm-9.2.6-Generic
CoreELEC-Amlogic-ng.arm-9.2.7-Generic
CoreELEC-Amlogic-ng.arm-19.0-Matrix-Generic
CoreELEC-Amlogic-ng.arm-19.1-Matrix_rc1-Generic
CoreELEC-Amlogic-ng.arm-19.1-Matrix-Generic
… + all other matrix releases

all used with internal dtb image.

matrix logs:
http://ix.io/3oOX
http://ix.io/3oOY
http://ix.io/3oOZ

BUT!!
ONLY with CoreELEC-Amlogic-ng.arm-9.2.2-Generic all is fine! SDR to HDR is working as it should be.

9.2.2. logs:
http://ix.io/3pkA
http://ix.io/3pkB
http://ix.io/3pkD

HDR is activated in the bootloader, or very early on.
Try to install Android, and then select the adaptive HDR option.
After that, the device should reboot and run in SDR. And only switch to HDR when necessary.

I formatted the EMMC and installed VIM3_Pie_V210527 Android via USB-Burning-Tool.
Right, there was a SDR to HDR option, which was activated. But after deactivating and rebooting the VIM it was still active.
Ok, here I have to ask Khadas I think.

But why is it with CoreELEC-Amlogic-ng.arm-9.2.2 ok?
Is there something I can copy from this version to newest matrix release?

Wow ok
I tried all Android Firmwares. Newer than VIM3_Pie_V190809 doesn’t work correctly.
But this Firmware is ok. Installed coreelec New to internal emmc and still all working good.
perfect. Hope I have no other faults now with such old bootloader.

1 Like

@cdu13a any input on this?

Confirmed, VIM3_Pie_V190809 works ok
Newest VIM3_Pie_V210128 had HDR always on regardless of settings.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

So we have a solution for CoreELEC, you will need to edit the config.ini.
Change the line
# coreelec='quiet'
to
coreelec='quiet hdr_policy=1'

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice