Khadas VIM3 testbuilds

is it possible to disable hdcp 2.2?

I noticed that 4K movies only runs on an hdcp 2.2 hdmi Port.
But all my ports are used,
My old s905 box is working with the port. The VIM3 not

No android, launching CE of SD card
Sony TV, KDL-22EX553

Fans still not working even after trying to push the temps up incase it was temperature controlled… good news tho is that CEC seems
To be working as it should now on Panasonic tv with the latest nightly even after switching sources and tv power cycles CEC continues to work. I’m not sure which nightly CEC was fixed on as I’ve missed a couple of weeks worth due to faulty sd cards but it’s great that it’s working now so thanks for the continued hard work and development!!

@goosh You need to have a Android on your device, otherwise it would not boot.
We need this version of Android installed on the device. If you don’t know you may try to upgrade it to 0907?

@Wizzi07 It got solved some days ago by using the “old” CEC mode. The driver was updated for multiple CEC node address but it looks like not working 100%.

It seems to be working well on Panasonic dx65902b. only 1 button the “options” button for things like marking as watched/add to favourites/Information doesn’t work properly, it brings up the TVs option menu instead of the kodi menu, the button works as it should on s912. This isn’t really a big problem and CEC is still massively improved compared to before!

Do you know why the fan wouldn’t be working? I’m guessing it’s software related rather than faulty hardware but I’d like to rule it out. It’s not really necessary as my temps rarely exceed 50• but now I have it it would be nice if it worked and will be interesting to see how much the temps drop by with it working.
Thanks again.

The currently used kernel isn’t supporting pwm for vim3. That’s what I guess right now. We make some tests on the khadas kernel right now and I have read something about a special khadas fan/pwm control.

Okay, if you need anything testing I would be happy to help

Installing over Android helped, thanks. As I understand the issue is with updated U-boot. Is it possible to just extract U-boot out of 0907 Android image and burn it to emmc(spi)?

Yes, but it’s better to flash it completely as maybe something else is missing like a change in the environment of the bootloader.
There you find a way to extract the bootloader. Then you have it to dd to /dev/bootloader

1 Like

The latest Vim3 testbuild, 20191003-Generic, gives me a funky new color scheme :laughing:

Tried with an update from a previous version and a completely fresh install with the same results.

What? In the nightly? :face_with_hand_over_mouth:
What firmware version is used? 0907?
Can you try older versions of CE too?

And output of
dmesg | grep 'com register:'
For this blue screen

CoreELEC (official): nightly_20191003 (Amlogic-ng.arm)
CoreELEC:~ # dmesg | grep ‘com register:’
[ 0.741345@0] 1A2B com register: 82820501
[ 0.741347@0] 1A4B com register: 82820501
[ 0.741348@0] 1A4C com register: ba97267f
[ 0.741349@0] 1C32 com register: 00000464
[ 0.741350@0] 1C34 com register: 00000004
[ 0.741351@0] 1C3D com register: 00000461
[ 0.741374@0] 1A2B com register: 82820501
[ 0.741374@0] 1A4B com register: 82820501
[ 0.741375@0] 1A4C com register: ba97267f
[ 0.741376@0] 1C32 com register: 00000464
[ 0.741377@0] 1C34 com register: 00000004
[ 0.741378@0] 1C3D com register: 00000461
[ 1.191796@0] 1A2B com register: 82820501
[ 1.191799@0] 1A4B com register: 82820501
[ 1.191800@0] 1A4C com register: ba97267f
[ 1.191802@0] 1C32 com register: 00000464
[ 1.191803@0] 1C34 com register: 00000004
[ 1.191804@0] 1C3D com register: 00000461
[ 1.191826@0] 1A2B com register: 82820501
[ 1.191827@0] 1A4B com register: 82820501
[ 1.191829@0] 1A4C com register: ba97267f
[ 1.191830@0] 1C32 com register: 00000464
[ 1.191831@0] 1C34 com register: 00000004
[ 1.191832@0] 1C3D com register: 00000461

Haven’t updated in a few days so here’s what works / fails

20191003 - fails with blue colors
20191002 - fails with blue colors
20191001 - fails with blue colors
20191030 - fails with blue colors

20190929 - works

How do I check firmware version?

Please try this setting:


No change :frowning:

And when you set it to 1?

Ok, so on when updating 20190929 to 20191003 use_rgb_to_yuv=0 makes no difference, however on a fresh install of 20191003 use_rgb_to_yuv=0 fixes the issue. Not sure why it works on a fresh install but not an upgrade, but at least it works.

Ok, next problem, I already have CoreELEC installed to my Vim3’s emmc using the old installtointernal method from before it was removed, now when I boot a fresh install of 20191003 from SD card and run ceemmc 1 I get the following:-

CoreELEC:~ # ceemmc 1

Starting CoreELEC eMMC installation tool v0.1...

eMMC size: 0x0003a3e00000 [16GB]
Error opening file for reading '/dev/reserved'!
Failed to read original partition table!

You can use ceemmc tool only when Android is installed.