KHADAS VIM3L gives me headaches ... small issues though!

EDIT : OMG, i missed this and just booted fine the generic image :confused:. Remains small issues and questions below …

Hi all,

My issues are not big ones BUT they are annoying, let’s start :

→ My SBC was preloaded with CE because it’s a HTPC Kit AND before doing anything to my board, i dumped eMMC content using OOWOW. I keep it safely.
→ My goal was to boot CE from SD and Ubuntu from internal : done ! BUT it has been a long way to make it …
→ OOWOW has a few bugs with my board, for example i have no way to embed it into SPI, just because i find the key combo access handy in this case … anyway that not my point, it is a very helpful tool.
→ I was aware that CE Team gives almost no support for KRescue CE images and i believe that it was what i had preloaded : in first place i wiped eMMC and flashed a custom Ubuntu Jammy built from KHADAS sources using docker : the build configuration and process is fast and reliable and my image does boot and works very well :+1:. That was step 1.
→ Step 2 : boot official CE image from SD => never worked. I learned of lot of things about my board during multiple tries of SD boot BUT finally i dumped again eMMC (Ubuntu) and flashed KRescue CE image to it without using my first eMMC dump (preloaded CE) AND here issues begin :
→ blue LED is gone
→ u-boot logo is gone
→ To make it the shortest possible : preloaded CE to internal had everything : u-boot logo + CE logo. Ubuntu has evrything too ! u-boot logo + kernel logo + Ubuntu logo. Krescue CE image lacks u-boot logo AND blue LED is gone in every case now …
… untill i tried again to reset MCU without DCIN out the board BUT simply pressing the reset button shortly to boot the board up again with blue LED back (if i DCIN out, then settings were not saved and blue LED was still down) …
… that is a progress BUT blue LED mode appears to be set to hearbeat when power is off or on !? I can provide some videos if is relevant … i do know how to set it back to stock because i found the command lines over the internet BUT i am unable to enter into u-boot mode, either with Ubuntu or CE : if someone could tell me how to do that it would be really great because even hitting space bar since power is on gives nothing else than booting into the OS …

I apologize for this long introduction, now comes bootable SD with CE : i lately known the ceemmc tool, so i ran it from my KRescue CE image and installed it to a SD card => i now have a bootable CE SD card BUT i have a few questions :

→ is it still Krescue or not on the SD ?! If it is, what is the best way to boot official CE image from SD please ? Even if the word official can also apply to Krescue ones i guess …
→ how can i restore u-boot logo on it ? I found answers about Ubuntu and Android, that is all.

I have no intention to renew eMMC installation of CE from SD. Ubuntu is on it and CE on SD and works pretty very well !

To conclude, i am wondering about the best way to boot CE from SD, did i make it right ? Also if anyone can help me to solve this blue LED issue, i would be very happy with it !

PS : i own several ODROIDs and one ROCK960 AND it has not been that difficult for me to learn how to use them, compared to VIM3L. These three brands (HK, 96boards and KHADAS) are great IMO AND even if my head was about to explode because of the VIM3L, i must say that i do have a small preference for it.

Have a nice day,

Any help will be greatly appreciated,


Krescue images are not supported by CE. They use a different boot structure we don’t know.
For CE it’s best to install Khadas Android image on eMMC.
Then boot generic CE image from µSD or USB.
Use ceemmc to migrate to emmc if you want to.
If this does not work maybe you try a older Android image for your device.

It will only work with Ubuntu if the used bootloader on emmc is a Amlogic compatible one.
CE does not touch the bootloader on emmc on VIM3(L).

1 Like

EDIT : you’re right, it’s not working because there was KRescue CE image on eMMC when official generic image did boot up :confused:. If i build an burn AOSP 13 for my board will i be able to boot official
CE from SD ?

Hi and thank you for your answer, i confirm that the Jammy image i built from KHADAS sources is compatible with CE generic 20.2 for ng on my VIM. If i correctly remember, it’s 2015.1 from mainline but i am maybe wrong.

It will stay like this, i’m happy with it,



Krescue CE image breaks blue LED and u-boot logo ! I installed latest Krescue Android 9 arm64 image and blue LED + u-boot logo are OK BUT official CE 20.2 image refuses to boot from TF. Built Jammy image is booting fine form TF with it.

What android version do i need to launch ceemmc from TF ? Is latest Krescue one is OK ? And then, what is the recommended procedure to run official CE from SD, since built Jammy is booting right away ?


PS : shall i use upgrade mode ? adb ? install to CE SD ?

Install Khadas Android image.

… through USB Burning Tool … ?

Thank you :+1:

Yes, i know that now but i am desperately trying to boot CE from SD and i does not work, neither with 64 nor 32 bits version of latest KHADAS Pie for VIM3L :confused:.

I tried every boot method in my knowledge in order to enter upgrade mode and it fails … it’s the same with LE …

There is one thing that i do not understand at all, it’s that i am unable to write / update bootloader to SPI with OOWOW, i have to do it manually and when i reboot it complains about ‘card did not respond to voltage select’ re :confused: … is it a PSU issue ? Because latest OOWOW which uses 0.17.2 works for me, built Ubuntu with a recent bootloader too (from SD), same for KHADAS Pie !?

What i’m doing wrong ?


Use older Android image, burned by USB tool.

Oowow does not support vim3(l), and krescue images use different boot method.

After burning plain Android follow the wiki how to install CE on generic devices.

1 Like


I followed your recommendations and it failed with every Android image available from KHADAS download page for VIM3L, starting from 2019 archives to current release because once Android is installed onto eMMC, then SBC boots into it instead booting from SDCard (tried with stable CE / LE). Not tried USB. CE media is a properly configured generic image.

The only way to boot LE from SDCard is to wipe eMMC and it’s not working with CE…

I really need your opinion about this …

PS : Android is burned with USB Tools and recovery mode is properly activated.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.