Khadas VIM3L HTPC Kit!

Hello,is it normal that wake on lan doesn’t work on latest nightly? Other than that I haven’t found any bugs the little bit I used it . thanks!

CoreELEC Configuration Addon
Hardware Tab and see it is enabled.

1 Like

The Wake on.lan option is enabled,it does work from suspend but not from power off .is that normal?

Think about it. “Wake on LAN” - not “Power ON on LAN”.
The name does actually does explain that it should wake from suspend (aka sleep), not from completely OFF. :wink:

1 Like

Nothing to do with the name if you own a Vim3 Pro.
The Vim3 Pro will wake from Power Off simply by sending a wake up call
using the Wake Up option Kodi Official Remote.

Haha I do !
I just don’t see the need for (or use) WOL for these devices since, I’m always sitting in front of them, when I use them for watching a movie or the like and so the ON button works just fine.
I’ve always used Harmony remotes with all of my boxes, regardless of Brand, so they all just “come on” from whatever mode whenever I turn on the ‘Watch a Movie’ activity :wink:
You live and learn eh? :rofl:

I own vim3l and only wakes up from suspend, not power off , I am using Core too , I Also tried wake up the vim3l from my router just in case , but doesn’t work. So it should wake up the device from power off state too?

WOL wake up from power off or suspend is working here fine. You will need to inject BL301:

1 Like

Anyone know if we can order these from China again yet?

There is a link in the first post of this thread, try it

Is there any new firmware image for vim 3l.
Because my usb hdd not detected on this firmware.

The vim USB ports are quite underpowered. One will be stronger than the other. This can cause problems with juice hungry peripherals like HDD. I would use a powered hub.


My Vim3L has issues with two different powered hubs. It will not boot with either of them plugged in. It will with unpowered hubs (my HDD are all self powered) It will recognize one of my upowered hubs but will not recognize more than two drives no matter what configuration (including 2 in hub and one connected to USB 3 port).
My solution was to turn my LePotato into a NAS NFS server (OpenMediaVault), which works but is not my ideal. I like the Vim and with the latest nightlies it really feels rock solid except for this.

Have you tried on Android to see if the same problem is exhibited?

fyi: announcements is not the place for bug reports.

any idea where I can buy this Kit in Europe?
At I only find the VIM3L bare board for ~80 Euro (~89 USD).
The offer for $89.99 with free worldwide shipping at the Khadas shop seems no longer valid.

Free Shipping is temporarily unavailable due to current Covid 19 Shipping Delays.

How weird. I can understand why no shipping would be currently unavailable but to only exclude free shipping . . . ? :thinking:

I’m just relaying what pops up on their shop website.

I do know their free shipping method uses Domestic Air Cargo as i looked up my previous order with Khadas.
I was told by a friend in logistics that due to very limited international passenger air flights at the moment the freight they normally carry is being backlogged to whatever is available.
That’s a lot of freight. Maybe that’s the reason.

I just got mine yesterday. It was sent by free shipping, but maybe I just got in under the wire. So far everything works right out of the box. Am using the Jellyfin addon to serve my media.

Is this [bl301 injector] obsolete with CE 9.2.2? That option shows up on, but cannot be switched on with my VIM3L box.

I also ssh’ed in to do inject that way. It tells me: Using BL301.bin: Khadas_VIM3L_2b_bl301.bin

It seems safer to just use the custom one already there.