KIII Pro remote doesn't work after last update


#1

Hi, what to do when my original IR remote stopped working after last update? Thank you


#2

Same with my KII pro. Will switch on OK but after that it doesn’t work and won’t shutdown unless I use my rf remote to select shutdown from the menu.

Oh! Spotted it, it’s in the CoreELEC 8.95.6 thread.

echo "meson-ir * mecool" > /storage/.config/rc_maps.cfg

#3

I’m lucky that I have bluetooth remote too, which is working fine, but prefer infra remote due to all the tv buttons, like epg, audio, etc


#4

I followed the instructions below…
Unzip, then eg
Copy kiii to /storage/.config/rc_keymaps
Copy rc_maps.cfg to /storage/.config

Rebooted the box, but it still doesn’t work.
Any advice?


#5

My KIII IR remote worked just fine with the echo command mentioned in release notes.

In one of the other threads somebody mentioned if you have any old files under rc_keymaps the echo command would not work. I don’t suppose you have any old files lying around in that directory?


#6

@Martynet those where not the instructions that where given to you.

SSH to your device and enter the following command.

echo "meson-ir * mecool" > /storage/.config/rc_maps.cfg

Nothing else is needed, please read the announcements in the future as all of this information is already posted.


#7

Thank you. Will read the release note properly next time.


#8

Hi,
I did exactly what you said, but still no working.
I have kiii pro, I edited rc_maps.cg and it has the line echo “meson-ir * mecool”
The file in .config/rc_keymaps/ has the name mecool also.
When the box is in shutdown, the remote works to start it, but when Coreelec starts, only the tv remote works, via hdmi cable…
What elese should I try?


#9

You don’t need any file in rc_keymaps folder so delete it for a start.

Paste output of

ls -l /flash
ls -l /storage/.config
fdtget -t s /flash/dtb.img /meson-remote/ status
fdtget -t s /flash/dtb.img /meson-ir/ status

#10

1- rm /storage/.config/rc_maps.cfg
2- echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg
3- cp /lib/udev/rc_keymaps/mecool /storage/.config/rc_keymaps/.
4- ir-keytable -a /storage/.config/rc_maps.cfg -s rc0

Test now @Martynet


#11

@fc_candido step 3 is unnecessary, you do not have to copy any file.


#12

@adamg
see /storage/.config/rc_keymaps/README

RC keymaps user config dir

put your own keymaps for ir-keytable in this directory

CoreELEC: ~ # ir-keytable -r
scancode 0x0000 = KEY_YELLOW (0x190)
scancode 0x0001 = KEY_LANGUAGE (0x170)
scancode 0x0002 = KEY_INFO (0x166
scancode 0x0003 = KEY_BLUE (0x191)
scancode 0x0004 = KEY_RECORD (0xa7)
scancode 0x0005 = KEY_BACK (0x9e)
scancode 0x0006 = KEY_UP (0x67)
scancode 0x0008 = KEY_PREVIOUSSONG (0xa5)
scancode 0x0009 = KEY_SUBTITLE (0x172)
scancode 0x000b = KEY_NEXTSONG (0xa3)
scancode 0x000c = KEY_9 (0x0a)
scancode 0x000d = KEY_HOME (0x66)
scancode 0x000f = KEY_0 (0x0b)
scancode 0x0010 = KEY_3 (0x04)
scancode 0x0011 = KEY_COMPOSE (0x7f)
scancode 0x0012 = KEY_CONTEXT_MENU (0x1b6)
scancode 0x0013 = KEY_VOLUMEUP (0x73)
scancode 0x0014 = KEY_6 (0x07)
scancode 0x0015 = KEY_CHANNELDOWN (0x193)
scancode 0x0016 = KEY_DOWN (0x6c)
scancode 0x0017 = KEY_VOLUMEDOWN (0x72)
scancode 0x0018 = KEY_TEXT (0x184)
scancode 0x0019 = KEY_MUTE (0x71)
scancode 0x001a = KEY_ENTER (0x1c)
scancode 0x001b = KEY_RIGHT (0x6a)
scancode 0x001f = KEY_FAVORITES (0x16c)
scancode 0x0040 = KEY_GREEN (0x18f)
scancode 0x0042 = KEY_RED (0x18e)
scancode 0x0044 = KEY_STOP (0x80)
scancode 0x0045 = KEY_MENU (0x8b)
scancode 0x0046 = KEY_PLAYPAUSE (0xa4)
scancode 0x0048 = KEY_FASTFORWARD (0xd0)
scancode 0x004a = KEY_REWIND (0xa8)
scancode 0x004c = KEY_8 (0x09)
scancode 0x004d = KEY_EPG (0x16d)
scancode 0x004e = KEY_7 (0x08)
scancode 0x0050 = KEY_2 (0x03)
scancode 0x0051 = KEY_ESC (0x01)
scancode 0x0052 = KEY_1 (0x02)
scancode 0x0054 = KEY_5 (0x06)
scancode 0x0055 = KEY_CHANNELUP (0x192)
scancode 0x0056 = KEY_4 (0x05)
scancode 0x0058 = KEY_CONFIG (0xab)
scancode 0x0059 = KEY_POWER (0x74)
scancode 0x005a = KEY_LEFT (0x69)
Enabled protocols: lirc nec


#13

Here is output:
CoreELEC (official): 8.99.2 (S912.arm)
CoreELEC:~ # ls -l /flash
total 150420
-rwxr-xr-x 1 root root 154013696 Feb 11 22:50 SYSTEM
drwx------ 2 root root 16384 Feb 11 22:50 lost+found
CoreELEC:~ # ls -l /storage/.config
total 76
drwxrwxr-x 2 root root 4096 Feb 4 07:38 aacs
-rw-r–r-- 1 root root 3 Feb 12 00:06 boot.status
-rw-rw-r-- 1 root root 284 Feb 1 11:28 hosts.conf
drwxrwxr-x 2 root root 4096 Feb 4 07:38 hwdb.d
drwxrwxr-x 2 root root 4096 Feb 4 07:38 iptables
drwxrwxr-x 2 root root 4096 Feb 4 07:38 logind.conf.d
drwxrwxr-x 2 root root 4096 Feb 4 07:38 modprobe.d
drwxrwxr-x 2 root root 4096 Feb 4 07:38 modules-load.d
drwx------ 2 root root 4096 Feb 12 06:53 pulse
drwxrwxr-x 2 root root 4096 Feb 4 07:38 pulse-daemon.conf.d
drwxrwxr-x 2 root root 4096 Feb 12 07:12 rc_keymaps
-rw-r–r-- 1 root root 25 Feb 11 23:19 rc_maps.cfg
-rw-rw-r-- 1 root root 720 Feb 4 07:39 rc_maps.cfg.sample
-rw-rw-r-- 1 root root 3726 Feb 4 07:38 samba.conf.sample
drwxrwxr-x 2 root root 4096 Feb 4 07:38 sleep.conf.d
drwxrwxr-x 2 root root 4096 Feb 4 07:38 sysctl.d
drwxrwxr-x 3 root root 4096 Feb 4 07:38 system.d
drwxrwxr-x 2 root root 4096 Feb 4 07:38 tmpfiles.d
drwxrwxr-x 2 root root 4096 Feb 4 07:38 udev.rules.d
CoreELEC:~ # fdtget -t s /flash/dtb.img /meson-remote/ status
Couldn’t open blob from ‘/flash/dtb.img’: No such file or directory
CoreELEC:~ # fdtget -t s /flash/dtb.img /meson-ir/ status
Couldn’t open blob from ‘/flash/dtb.img’: No such file or directory

PS
I find the file dtb.img manually, exists in usb stick, here is the result:
CoreELEC:/var/media/COREELEC # fdtget -t s dtb.img /meson-remote/ status
disabled
CoreELEC:/var/media/COREELEC # fdtget -t s dtb.img /meson-ir/ status
okay

How can I enable it?


#14

You are booting this device from internal? USB stick is not used in this case.

echo "meson-ir * mecool" > /storage/.config/rc_maps.cfg

and reboot, should fix your issue.

If not please paste output of

fdtget -t s /dev/dtb /meson-remote/ status
fdtget -t s /dev/dtb /meson-ir/ status

#15

You are perfectly right! It works!
Thank you very much, now I can use the remote as I wanted too.

After reboot I also did what you asked:
output here:
CoreELEC (official): 8.99.2 (S912.arm)
CoreELEC:~ # fdtget -t s /dev/dtb /meson-remote/ status
disabled
CoreELEC:~ # fdtget -t s /dev/dtb /meson-ir/ status
okay

Anyway, I am happy to be part of this full of documentation forum.


#16

Yes that looks normal now, you can use a remote.conf from the KIII Pro Android image and the remote response will be even better.

Maybe this one here will be okay.

Just save the file as /storage/.config/remote.conf and reboot, if it doesn’t work remove the file and reboot again.


#17

I did exactly what you said, but, unfortunately it did not worked.
I copied the text from first post in file remote.conf and copied to .config

After deleting remote.conf and reboot, again not working the remote.
I entered again the “magic formula” ( echo “meson-ir * mecool” > /storage/.config/rc_maps.cfg) and reboot, but still not working.
again output:
CoreELEC (official): 8.99.2 (S912.arm)
CoreELEC:~ # fdtget -t s /dev/dtb /meson-remote/ status
okay
CoreELEC:~ # fdtget -t s /dev/dtb /meson-ir/ status
okay

What else should I try?

I tried this:
CoreELEC:~ # systemctl stop kodi
CoreELEC:~ # systemctl stop eventlircd
CoreELEC:~ # ir-keytable -t
No devices found
CoreELEC:~ #


#18

You need the right remote.conf, I don’t know if that one would work for your device or not and just thought that maybe you could try it,

fdtput -t s /dev/dtb /meson-remote/ status disabled

Should fix your issue, remember to reboot.


#19

Yes, you are right again.
Now it works my remote.
I will try to find a good remote.conf for my kiii pro