LG OLED 65B8 No video HDR content [Solved Bad Quality HDMI Cable]

Hello, new user here.

Having issues with HDR. Bought an LG OLED65B8. Following the settings here, I cannot get HDR to work or 4k in general I just get a “no signal” coming up on the TV when I click play on 4k content. There isn’t even any sound and I have to press stop to get back to the GUI.

No whitelist setup, resolution 1080p etc refresh rate 60hz (although tried others to no avail).

When I turn on “disable auto colour depth switching” HDR works but I’m told it’s on 8bit rather than 10 and doesn’t give you the wow factor.

Tried whitelisting 4k resolutions for anything 30hz and below for 4k and it started working with auto colour depth switching left to do its thing.

What’s going on here?

Thank you

Kodi will sometimes choose 4096 x 2160 for 3840 x 2160 content. This can cause problems with some setups when the content is 10bit HDR. If this happens the best solution is to whitelist 3840 x 2160, 1920 x 1080 and lower modes if you want them and make sure not to select the 4096 x 2160 modes in the whitelist.

Thank you for coming back so quickly.

Tried whitelisting the 4k resolutions but only seems to work if choosing 30hz or lower refresh rates for 4k?

No idea what’s up but the reccomended settings said not to use whitelist etc.

You may need to enable HDMI 2.0 (Ultra Deep Color) manually in the TV settings for it to work.
If it’s already enabled, then it’s probably a bad HDMI cable.

But I get HDR coming through if I disable the auto switching but I think it’s in 8 bit. The deep colour is automatically enabled in the TV settings.

The problem is that when autoswitching is enabled the box outputs a signal that the TV either can’t “understand” or it’s too high bandwidth, that the input can’t handle it.

Not sure why it won’t work then?

Just put a brand new certified 4k hdmi cable in and it’s the same.

Whitelisting all of the 4k resolutions (including 4096x2160p) it then works ok so seems the issue is Kodi or coreelec not outputting in that format when it’s set to auto switch.

The TV can display them all as shown here


@richardc1983 8bit is not true HDR, disabling auto switching will disable HDR.

Not quite. It will still be HDR, but will probably lead to a lot more banding, because color depth is kept at 8-bits instead of 10-bits. That means x4 less gradation in shades possible.

I don’t know about your display @TheCoolest but mine only says “HDR signal” when running in 10bit, the display profile changes at this point automatically to match the cscd. I don’t get any of this at 8bit.

Other possibilities.

Not all hdmi ports on a TV are equal. Some TV’s only properly support some features on certain hdmi ports.
If you are using an AVR both the TV and the AVR need to be HDMI 2.0 and properly setup to avoid problems.

Just to make sure I’m clear about your issue.
UHD and 4k 50hz and 60hz modes are the ones not working, and there is not a problem with any of the video modes.

edit: Which version of CoreELEC are you using?

You may be right, I have a LG B7 and an older Vizio, both will trigger HDR no problem when the signal is 8-bit.
I would expect the B8 to behave in a similar way, and it most likely does, as richard has said that HDR is triggered.
I think that with an earlier LG FW the color gamut was not as wide in HDR at 8-bit as it was at 10-bit, so colors didn’t pop as you’d expect them to. But I don’t think I can see a difference now with a newer FW version.

I’m running version 8.95.7

If I disable auto switching with nothing selected in whitelist when I play HDR content the TV will display HDR In the top right corner for a few seconds as play back starts.

If I turn back on auto switching as reccomended here again with nothing in the white list selected, the TV may show HDR but then will go to no signal on the display, I then have to stop playback before I get back to see the GUI.

If I then whitelist all 4k modes apart from 4096x2160p 24hz and 4096x2160 23.98hz the same issue occurs as mentioned in the last paragraph above.

I then have to whitelist the modes above for what I assume is 4k HDR 10 bit (TV displays HDR) for it to display the movie with auto switching turned on. Not sure why it’s wanting to use the 4096x2160p modes (24&23.98hz) though unless that’s what HDR is? I’m new to HDR and 4K.

I have followed your instructions to a T even bought a new premium certified HDMI cable to no avail it still does the same, I cannot get it to display with auto switching on so not sure if whitelisting those 4k modes is also working in 10bit all I know is whitelisting is the only way to get 4k HDR working with a picture on the screen with the auto switching enabled.

Here is a script that will help show more information about what is happening.


Use the following to get it on the device and make it executable.

wget https://discourse.coreelec.org/uploads/default/original/1X/a22d7f0fb8a08caa15a63dc8a5dad51c8befbf43.sh -O /storage/dispinfo2.sh
chmod 755 /storage/dispinfo2.sh

then it’s just a a matter of the following to run the script


This will collect display info and post it to a pastebin site, providing you will a url you can post here.

alternately you can see just the current video mode with the following.

cat  /sys/devices/virtual/amhdmitx/amhdmitx0/config

So if you run either while the video is playing it will show what video mode your device is trying to use, at the point you ran the command.

Thank you. I will look into that but still doesn’t explain why the auto switching doesn’t work?

The fact you’re getting ‘No signal’ means it’s working. It just seems to switch into a mode your TV can’t display/doesn’t support. So output from cdu13a’s instructions will let us better understand what’s wrong.

But then what’s the point of auto switch if it switches to a mode the TV doesn’t like? As I say whitelisting all the 4k modes works so it must then switch to the same mode that it does by Auto switching?

@richardc1983 please follow the instructions given to you by @cdu13a here, this will help us understand what is going on and then we may be able to explain why auto switching is not working as it should with your display. We can’t help you further without this.

Only do it whilst you have the black screen whilst attempting to play a video.

Ok so here are two lots of results, the first one is with “whitelist enabled” and the “4k resolutions selected” and “auto switching” enabled. This way plays the movie ok and we see pictures on the screen. Please note this is with the tv turned off as I am doing this remotely as not at home, will post results later when I am home with the TV turned on.

LOUNGE-PA:~ # cat /sys/devices/virtual/amhdmitx/amhdmitx0/config
cur_VIC: 98
VIC: 98 4096x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off

This next set of results shows everything in the whitelist removed and auto switching left on - when we see a black screen no signal. Please note this is with the tv turned off as I am doing this remotely as not at home, will post results later when I am home with the TV turned on.

LOUNGE-PA:~ # cat /sys/devices/virtual/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off