LG OLED 65B8 No video HDR content [Solved Bad Quality HDMI Cable]

Playing the sony swordfish plays perfectly… SAYS 59.940fps

Also the same for one of the Samsung travel with my pet and the LG chess one.

Not sure what 10bit 420 30/60 fps video is??

The 60 fps videos I mention above worked fine but not sure whether they were 10 bit 420 or 10 bit 422 as the command you asked me to run previously was the 422 so not sure how long that stays active for?

With automatic switching CE will use 422.
But video is normally 420, so it doesn’t affect quality.

Can S912/S905 hardware decode 422 content? I had some 1080i/422 material and could not get them to play.
Any reading on 422 compatible amlogic SoC?

I don’t know. As far as I’m aware, all video content is 420, and anything else would be completely non-standard. So I wouldn’t expect it to work on a hardware decoder.

Either way, for HDR, the standard is 10-bit YUV422. We use YUV444 for 24/30Hz resolutions, because the HDMI 2.0 bandwidth spec supports it. Maybe this TV doesn’t like that, I don’t know. My B7 doesn’t have any issues with playing 24p/30/60fps content in CE with autoswitching enabled.

These 1080i/422 videos that I have are recordings of satelite feeds and that is the only source I found for them. They play OK using embeded player in my satelite box, so the tv is OK with them.
All other videos I have are either 444 or 420.

As I said, I’m not aware of any video content that’s anything other than 420…

So what’s the solution then?

If you don’t watch non-HDR 4K content, then the current setup you have with the forced 10bit 422 configuration should work for you.

Those files play fine though if I play them through the video app directly from the NAS.

What do you mean don’t watch 4k non-HDR content?


Is there an update to my question above? It seems the workaround you have given is not ideal. There is nothing wrong with the tv as other people using other sources do not have this issue.

Thank you.

I ran into the same issue (OLED55C8).
My workaround is to set UI at 3840x2160@23.976 before watching HDR content (with 23.976 frame rate)

As I mentioned previously, it’s possible that these TVs don’t like 4K 10-bit YUV444 content even if the HDMI port is set to HDMI 2.0 and can support the bandwidth required. We’ll look into making all 4K 10-bit content use YUV422.

I get a “no signal” with 4:2:0 YUV 10-bit content (UHD Blu-ray remuxes). Switching UI to appropriate mode solves the problem. On Jarvis with HDR support it’s been working. May be I ran into another issue

On Jarvis there’s no automatic color depth/space switching. You can disable it in CE too, and just set a value you want for color depth/space manually via autostart.sh.

The main point is that I can watch 4k 23.976fps HDR10 BT.2020 4:2:0 YUV 10-bit content only by setting UI at 3840x2160@23.976 in advance. Otherwise I get “no signal”

Sadly I don’t have a 2018 OLED to test/debug this.
On my 2017 OLED everything works correctly. What I think is that when CE switches to YUV444 for 4K 10-bit content, the 2018 OLEDs do not accept this type of signal. So we’ll look at switching over to YUV422, because that is what should normally be used with 4K 10-bit content (even if the content itself is 420).

I have the same problem on an LG oled55c8 and CoreELEC 8.99.1
HDR is working for me on the latest semi official build of LibreELEC, for some reason not working on CoreELEC.

What do you mean “Not working”? Also please post logs.

@richardc1983 Here is a test build that may resolve your issue.


Let me know if it does or not. If it doesn’t I have another idea to work around the problem, that we can try instead.