LG OLED 65B8 No video HDR content [Solved Bad Quality HDMI Cable]

Could you create a test build for S912 please?

Thank you, we need a version for s912 thuogh as thats the ones we have.

As soon as we have this I can install the build.

Thank you in advance for the support to date.

My system: Minix U9-H connected via 4K HDMI 2.0 cable directly to Panasonic tx-65fz800e (full HDR compatible TV set)
Watching Sony Mont Blanc HDR UHD 4K Demo.mp4 (https://4kmedia.org/sony-mont-blanc-hdr-uhd-4k-demo/)
automatic color depth switching disabled
All resolution except 4096x2160 whitelisted

CE-Minix:~ # echo ‘10bit,422’ > /sys/class/amhdmitx/amhdmitx0/attr
CE-Minix:~ # cat /sys/devices/virtual/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p50hz
Colour depth: 8-bit
Colourspace: YUV420
Colour range: limited
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: on
3D config: off

When streeming this file via uPnP server on TV there is information displayed on TV: “HDR (PQ)”

Other demo HDR files available on 4kmedia.org also showing as EOTF: SDR

I just started the upload for the S912 build of the test. So should be available in a few minutes.

edit: same link as before https://drive.google.com/drive/folders/15csxZW6it9prDt1HnWizgMY3p3HHat1o

minor note the version number of the s905 and s912 files is different, but they are the same test build.

@rabaraf just an FYI but after you execute echo ‘10bit,422’ > /sys/class/amhdmitx/amhdmitx0/attr you need to perform a resolution change for the change to take affect, that is why the second command is still showing 8bit

Thanks adamg for your reply.
I will test your suggestion later today. Do I understand you correctly that I need to

  • run the command echo ‘10bit,422’ > /sys/class/amhdmitx/amhdmitx0/attr
  • change in Kodi’s GUI resolution to 3840x2160 (which fps? does it matter?)
  • start demo movie
  • run command cat /sys/devices/virtual/amhdmitx/amhdmitx0/config
  • automatic color depth switching remain disabled?
  • All resolution except 4096x2160 be whitelisted?

Just for information these are Sony Mont Blanc HDR UHD 4K Demo.mp4 clip’s parameters:
Format : HEVC
Format/Info : High Efficiency Video Coding
Commercial name : HDR10
Format profile : Main 10@L5.1@High
Codec ID : hvc1
Codec ID/Info : High Efficiency Video Coding
Duration : 1 min 28 s
Bit rate : 71.8 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 50.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.173
Stream size : 753 MiB (100%)
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : R: x=1.000000 y=1.000000, G: x=1.000000 y=1.000000, B: x=1.000000 y=1.000000, White point: x=1.000000 y=1.000000
Mastering display luminance : min: 0.1000 cd/m2, max: 1 cd/m2

No HDR on Minix U9-H connected via 4K HDMI 2.0 cable directly to Panasonic tx-65fz800e.
Testing with demo file Sony Mont Blanc HDR UHD 4K Demo.mp4 (https://4kmedia.org/sony-mont-blanc-hdr-uhd-4k-demo/)
Whatever combination with GUI settings, Automatic Color Depth Switching settings, resolutions whitelisted I’m not getting HDR on TV set.
Watching this file via uPnP server giving me HDR result.
Don’t know why.
I have tested also:

None of them works - no HDR output :frowning:

HDR should just work, it has nothing to do with color depth (8/10 bit) or color space settings.
Make sure that the HDMI input on your TV is set to “Deep Color”, or whatever term Panasonic is using for HDMI 2.0 mode on the HDMI input.

HDR definitely works for me with a new install on the U9-H.

So the test build solved your problem?

Just so I can see what is happening on your device when using the test build can you play the samsung demo file and give me the output of cat /sys/devices/virtual/amhdmitx/amhdmitx0/config from while the video is playing. thanks.

The same with the test build.
If 4096x2160@23.98 mode is selected in the whitelist (no matter either with other modes or not), my workaround with switching UI to 3840x2160@23.98 won’t work

Sorry guys, my fault… I was not able to find HDMI setting on my TV set when I was watching TV program - simply HDMI setting is not popping up in the TV menu while you are not watching anything on HDMI input :slight_smile:
Once I switched to HDMI input I saw “HDMI HDR Setting” option in the menu which was set to “Off” When I changed that to “Dynamic” HDR content is properly handled by CoreELEC-Kodi.
But I decided to use wrxtasy-kszaq LibreELEC-S912.arm- build (https://github.com/wrxtasy/LibreELEC.tv/releases/tag/

Still same problem with the test version. Black screen. Semi Official LibeELEC 9.0.0 works fine. Very Strange.

Log with no resolutions whitelisted: http://ix.io/1zSJ
Log with compatible resolutions whitelisted: http://ix.io/1zSJ

Log from LibreELEC 9.0.0 (hdr working): http://ix.io/1zSW

New test build with a different approach to work around the problem.


I just started the upload so it might take a few minutes for builds for all platforms to appear.

The build posted yesterday is not working for me same issue as before. Some stuff I tried yesterday was not HDR it seems.

We are working on it from a different angle, hopefully it’ll fix the problem.
@cdu13a will update when he has a build ready to test.

@richardc1983 Did you get a chance to try the last build I posted today?


I will have a go tomorrow, thank you.

Just an update, working fine with the latest build with whitelist disabled and colour depth switching enabled.

Not sure what you have done but it seems to have fixed it, for me anyway.

Can you explain what you have changed and why Kodi was not working that way before as you mentioned something being the new standard which you was working towards?

The change I made was in the HDMI drivers not kodi.

Before the change the HDMI driver was set to automatically use the absolute highest quality setting(YUV444) that the HDMI 2.0 standard would allow for encoding it’s video output for 10bit at uhd/4k resolutions. Some TV’s apparently don’t like this. So I changed it to use the slightly more conservative setting(YUV422), that more TV’s should be ok with.

The change from YUV444 to YUV422 doesn’t make any difference to what you will see on your TV. Since YUV422 is still better then the YUV420 used by consumer video.(Bluray, DVD, streaming formats, etc…)

As for why it was not this way before, YUV422 was at one point in time the default in CoreELEC but with all the changes and improvements with auto switching the colour space/bit depth/HDR/etc… the new code wasn’t setup that way.

1 Like