LG OLED 65B8 No video HDR content [Solved Bad Quality HDMI Cable]

Sorry I didn’t mean to sound abrupt. What I meant was I don’t really understand the technical side to it but I am interested to know more.

We still don’t really know what is wrong exactly. I have a B7, and none of those problems, but it seems that with the 2018 models, something doesn’t play well together between CE and the TV.
I can’t really give out any more information, since we don’t really know what’s wrong exactly.

You see I thought the b7 was the same as the b8 apart from the processor.

Well, the processor can make a lot of difference. :slight_smile:

This seems like a corner case…

@richardc1983, is your TV able to show the signal properties it is receiving? I would be interesting to know what information it says it’s receiving before playback and when it looses signal. Ex resolution, bitdepth, HDR, Chroma Subsampling etc.

Ok I have had a look at most of the info files the Files that work have

video_clk:             297000000

And the ones that don’t have

video_clk:             594000000

Even the 25hz content is being displayed at 50Hz

current vinfo:
name: 2160p50hz
mode: 34
width: 3840
height: 2160
field_height: 2160
aspect_ratio_num: 16
aspect_ratio_den: 9
sync_duration_num: 50
sync_duration_den: 1
screen_real_width: 1600
screen_real_height: 900
video_clk: 594000000
viu_color_fmt: 2

So I know its probably been asked before is you HDMI Cable capable of working at that high a bandwidth.

The HDMI cables are brand new I’ve spent quite a bit on replacement ones.

It’s a hdmi certified one I got from Amazon. SlimHDMI 0.25m (25cm) Premium Certified HDMI Cable with Secure Lock Connector (4K Ultra HD, Gold Plated, 1080p, 3D, High Speed, ARC) https://www.amazon.co.uk/dp/B07FQTPSKD/ref=cm_sw_r_cp_apa_i_-ysRCbAJESZNN

I know we are going down the hdmi route again but before this update to CE one of the test builds that was put out by @cdu13a fixed the issue entirely. If it was a hdmi issue different builds of CE would not cause it to start working again on ALL content type.

This is deffo a LE Or Kodi issue.

Unfortunately not there is no way to pull that information up.

It depends, if that image wasn’t pushing the whole HDMI 2.0 bandwidth it would have worked.
Maybe you should install that build again and post the same dispinfo logs with it so that we can compare what changed.

It was using the same sample images as above.

OK I have just tried one of your Problematic files on my S905x and its not got a problem on my PANASONIC UHD. I notice you have a S912 I will try it one tomorrow its connected to a different HDTV at the moment. I will see if I can “prize the UHD TV remote from the wife’s dead cold hand” tomorrow and plug in my S912 box and report back to you.

I noticed that’s an Amazon UK link are you based in the UK I have a load of cables that definitely work

They are cheap that and I haven’t had a problem even at UHD10Bit 60Hz I gave up with amazon having received a load of fake 16G sandisk Micro SDCards that turned out to be 2GB. As I returned them it stopped me leaving they were fakes to warn other users.


OK I used the travel XP file and on the S905x about 8 seconds in you get a loud chip like you get from a corrupted DVB file but it then continues to play the S912 gets to the same point and Crashes completely my laptop using VLC also only plays the first 8 seconds before stopping.

I will try another file when I get a mo, Its a bit more complicated for me as the network card is only 100M so I have to copy the media to the internal card to test it.

@ffimon it’s not the files that are the problem, and I don’t believe it was the cable either.

While I was working on fixing up the hdmi drivers several months back at least one of the test builds did work perfectly fine for @richardc1983

Unfortunately, since hdmi is not a simple standard and different manufactures sometimes have slightly different interpretations of standards, you can end up in a situation where the same settings that make one device happy upset an other. So it ends up being a balancing act trying to support them all.

Good advice @ffimon but it is definitely not the cable. The one I bought was reccomended from others in a UK forum for people having hdmi connection problems, there was nothing wrong with my other cable but it wasn’t certified but because of the problems I was having with 4k and it being a new tv set I thought I would replace as caution.

I look forward to what @cdu13a manages to find out as like he says one of the test builds worked perfectly for us from just installing it with default settings.

Just to point out for anyone else the the Travel XP file is corrupt the coruption does not crash the S905X but Does crash S912 (Box Freezes) and VLC on a PC, so don’t use it as a test file.

I encoded a 60000/1001 Hz small file that is 4k PQ that can be used as a test file. https://drive.google.com/uc?authuser=0&id=1vkMi967o_hH5jwQiyMlfUU0fZMsMdNLR&export=download

I have uploaded some new logs to my original post with two new 50fps video samples, one of them being yours @ffimon

50fps - Sony Mont Blanc HDR

  1. HDR logo then no signal - http://ix.io/1FM5
  2. HDR logo then no signal - http://ix.io/1FMh

50fps - ffimon upload test file (libx265-cry 26.5 fast.mkv)

  1. HDR logo then no signal - http://ix.io/1FMe
  2. HDR logo then no signal - http://ix.io/1FMl

Thats a 60Hz clip

Please install the old build that worked and post the same logs as in this post LG OLED 65B8 No video HDR content [Solved Bad Quality HDMI Cable]

Oh I thought your file was a 50fps?

To do this will take some time and my brother will have to do it.

We’re not in a hurry, get to it when you can.