Locked when installing CE in internal memory

I bought this Box AML 905D 2GB / 16GB, I install CoreELEC through the usb but when installing it in the internal memory it does not start the device in any way, I cannot find the firmware of this device for usb burning tool and the manufacturer tells me that there is no original firmware nor warranty, nor return. How do I get it back? Can someone help me, I have tried with the Mecool firmwares but nothing does not work, nor does it start with CE. Thanks

By the way, no one buys it, because of CoreELEC the satellite tuner does not detect tvheadend, it does not have a TF slot for micro SD, outdated android … A help is appreciated if someone knows how to recover it.

I woul recommend that you also post on a TV box specialist site such as Freaktab.

From the settings, also post the firmware revision as that will assist in enabling somebody to search for an appropriate Android image that will work with your box, even if it one built for another with similar specs.

Thanks, I’ll post there in the next few days, I’ve tried several signatures from that community but nothing doesn’t work. For CE I made it work with the dtb.img of the Mecool KI PRO and everything worked except the satellite tuner by tvheadend. Now not responsive with KI, K2, or other AML 905D firmwares. I attach some screenshots of this box.

Posted here too. Thanks.

Recovered. I have installed CE 20 Nexus in the internal memory of this device, the iptv net client works fine but in Tvheadend it fails to detect the satellite tuner that this device carries. It would be good if it could detect it to use the satellite dish, it is the same hardware or very similar to that of the Mecool KI PRO but the satellite tuner is different. Any solution, Thanks.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.