Logitech Harmony bluetooth setup with CE 8.99.1.1

#1

Hello,

I’m trying to connect my harmony remote via bluetooth, but when i go to CE settings -> Bluetooth
the list is flickering, like it is constantly refreshing, I can see my remote BT appearing in the list and disappearing almost instantly, so I dont have time to select it.

Does anyone experiencing the same issue ? Any known workaround ?
I already tried to disable / enable BT then restart the device, but still same issue :confused:

My device is a Minix U9H

Thank you

#2

Just to comment that you’re not alone with this problem.
I gave up and just used IR. Too bad tho because it’s a lot slower…

#3

So it’s actually working now for me, but I did nothing in particular…

  1. I connect via ssh and checked the bluetooth version with below 2 commands:
    systemctl status bluetooth
    bluetoothctl --version

  2. Then, I gave up and let the box running idle for several hours.

When I came back to it, to my surprise bluetooth was stable and all my devices were listed correctly. I then was able to connect my remote via bluetooth and it’s now working flawlessly for almost 24h so far.

#4

Which device did u add on the logitech?
Anything extra that u did?

#5

I’m using the profile microsoft / Media Center.
But no i didnt do anything special on CE or Kodi.

After, on another thread i posted, the CE devs mentioned I didnt use the right device tree, that could be the cause.
Maybe you should check if you are using the correct device tree.

#6

It worked for me with adding as entertainment device.
Manufacturer: Microsoft
Device:Kodi

The experience is much better! :smile:
Feels very snappy now.

Thank you! Finally got rid of the anoyying IR…

#7

I’m having the same flickering problem - did you add CE to the Harmony as an entertainment device Microsoft | Kodi, then CE was able to detect the remote? Or is there another step?

Thanks, Carl.

#8

Yes, added as entertainment device. Microsoft, Kodi

#9

That did it - thanks.