Looking for users with no working WiFi or BT

Please test again with this update:

It include the “latest” available driver for this chip.

Thanks. I am on 21 beta. I’m gonna give it some more time for team to fix it there :ok_hand:

I will not until it’s tested. Please just boot and try it. Then the fix go also into ce-21.

1 Like

I didn’t have any 20.x so I deployed the stable 20.2. I booted it up with the module plugged in, WLAN and BT worked out of the box.
Then I upgraded to the build you supplied, it’s still working good

1 Like

Well, what’s interesting is that I came across an issue with TV Shows scraping, which doesn’t work at all, on any release, I installed the 21 build from tonight and WLAN works ok, as well as on yesterday’s build. So it looks like it’s working when one of the recent releases is installed, and not when it’s upgraded on top of previous ones.

Anyway, can anybody purge their TV shows library and set it up again? I’m loosing my mind… don’t know why it won’t fetch anything

2023-11-09 13:27:53.938 T:4902 warning : No information found for item ‘/storage/tvshows/The.Crowded.Room.S01E03.mkv’, it won’t be added to the library

I guess you got same hardware like here:

Update with the test image and make a dmesg | paste log.

Some T95W2 clone with S905W2 2Gb ram 16Gb rom

CoreELEC 21.0-Omega_beta1 installed

  • Internal WiFi work (only in beta image) but it’s terrible slow
  • External USB RTL8821CU not supported





Hi! Bluetooth doesn’t work on my X96Max Plus Ultra. The chip is Fn Link K255B-SR C03043 (W155S1)

I use CoreELEC-Amlogic-ng.arm-21.0-Omega_nightly_20231206-Generic.img

mee to have H96 MAX W2
any news for wifi and bt driver ?
This is great piece of hardware at about 20€

nothing has changed, wifi and bt doesn’t work

I have a question whether wifi on this RTL8822BU usb chip will work with coreelec ?

Yes, since two weeks.

A post was merged into an existing topic: New Order: Looking for users with no working WiFi or BT

A post was merged into an existing topic: New Order: Looking for users with no working WiFi or BT

A post was merged into an existing topic: New Order: Looking for users with no working WiFi or BT

s905x4 212 meson, with the rtl8821c chipset Bluetooth over u_art exposed as serial not found, DTS was generic shows it should be attached to u_art 1 or a board reference calls for u_art 5 or d with the rockchip version though. Original box does insmod with the driver and restarts broadcoms Bluetooth stack.

Please advise I tried modifying my DTS file to have the correct values without source and while the modifications I initially added didn’t crash they didn’t help so I reverted those.

Unrelated to follow
/*board also has a fd655 that actually drives the vfd and works fine after much testing.

I did get the LEDs on this device to shut off by setting open vfd to use the fd6551 the board dev shunted RGB mode values to through an IR code on the remote.

Willing to bet each bit change may result in some manner of control over those but how would I run a second open vfd service or even just a pwm python script or something.*/

Hello All,

The wifi works, but the bluettoth does not work on my X96 X4 box with coreelec-ne 20.3, but on coreelec-no wifi also does not work.
Here is the link from ne version ssh : https://paste.coreelec.org/fqLXQ3

Thanks fro your help!

Use forum search!

Hello! Mecool KM6 Classic.
Non-working BT and wifi: CoreELEC-Amlogic-ne.aarch64-20.3-Nexus-Generic.img.
Non-working BT: CoreELEC-Amlogic-ng.arm-20.3-Nexus-Generic.img and CoreELEC-Amlogic-no.aarch64-21.0-Omega_nightly_20240209-Generic.img.

This is because the NG driver is included but only 4.9 compatible.
NE is 5.4, no driver exists
NO is 5.15 and RTW88 driver is used.

1 Like