Looking for users with no working WiFi or BT

Do a reboot and post dmesg result

dmesg | paste

Here it is not so easy to connect ethernet from router to target. Just now already unplug the setup.

Please state whatever data u guys needed all here.
I can do it all together during free time.

Sorry

dmesg_X96maxplus2_T.txt (126.4 KB)

Please someone help

Really need WIFI for this new box ::frowning:

PS: Currently I am running old Coreelec version due to some reason

I think your hardware is not supported by current 4.9 kernel. So support is not possible.

Me too

The box seems to be Vermax UHD300X (s905x 2g RAM 8g flash) branded by our local service provider under the name Movix Pro

Bluetooth and WiFi are up, BT pairing and wifi connection are working until reboot only, then no luck to pair/connect again, neither auto nor manual. The only way is to delete the connection and create it again. Yet the box may freeze up during the deletion, search or creation

Also I noticed the duplicated bluetooth MAC address of the paired device: the saved line with the address and below the same one from the scanning. Neither one can be connected to

There are no issues like these when running the original adapted Android 9 firmware: BT/wifi work great

P: /devices/platform/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
L: 0
E: DEVPATH=/devices/platform/d0070000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
E: DRIVER=rtl88x2cs
E: SDIO_CLASS=07
E: SDIO_ID=024C:C822
E: MODALIAS=sdio:c07v024CdC822
E: SUBSYSTEM=sdio
E: USEC_INITIALIZED=18002548
E: SYSTEMD_WANTS=rtkbt-firmware-aml.service
E: TAGS=:systemd:
E: CURRENT_TAGS=:systemd:

A post was merged into an existing topic: BT earbud connection issue

No WiFi on M96X (S905X). It’s an RTL8189es that works on 9.2.7

9.2.7

19.2 Nightly_20210712

device H96 Max X3 S905X3 4GB Ram, 1G lan.

WiFi only works for b/g. 5G wifi or ac not working.

module should be bcm4339

http://ix.io/3t7m

I have just received a 4th X96Air but unlike the other 3 this one seems to have a BCM4354 WiFi/BT chip for which there appears to be no driver
The box identifies itself to Android as X96Air_A1000 with Android 9 build 20210531_1609

Is there any chance of getting this Wifi chip to work

Here’s some data from "hwinfo |grep -e BCM -e bcm "

btbcm 16384 1 hci_uart, Live 0xffffff80027b3000
bluetooth 425984 27 hci_uart,btqca,btbcm,btintel, Live 0xffffff80026ad000
Model: “Broadcom BCM4354 WLAN card”
Device: sdio 0x4354 “BCM4354 WLAN card”
Driver: “bcmsdh_sdmmc”
Model: “Broadcom BCM4354 WLAN card”
Device: sdio 0x4354 “BCM4354 WLAN card”
Driver: “bcmsdh_sdmmc”
Model: “Broadcom BCM4354 WLAN card”
Device: sdio 0x4354 “BCM4354 WLAN card”
Driver: “bcmsdh_sdmmc”
Driver: “bcmsdh_sdmmc”

More from “hwinfo --network --wlan”

16: None 00.0: 1070a WLAN
[Created at net.126]
Unique ID: AYEt.QXn1l67RSa1
Parent ID: S5pc.+JPLo_ySGl4
SysFS ID: /class/net/wlan0
SysFS Device Link: /devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:2
Hardware Class: network interface
Model: “WLAN network interface”
Driver: “bcmsdh_sdmmc”
Device File: wlan0
HW Address: 90:b6:86:28:68:ff
Permanent HW Address: 90:b6:86:28:68:ff
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #8 (Network controller)

I’ll be grateful for any help :sweat_smile:

Following up … it appears the WiFi/BT device is recognised and firmware load(brcm/fw_bcm4354a1_ag.bin) is attempted, but fails. Is it possible the card identifies itself incorrectly or similar problem ? Any suggestions on what action to take ?

Log is available here PasteBin->CoreElec Syslog BCM4354 WiFi/BT Problem

More information.
The Bluetooth section of the chip is now working, but still no WiFi after I copied the Android firmware elements to /storage/.config/firmware/brcm

Any chance of including the brcmfmac driver for Broadcom devices like my BCM4354 ? The Wireless Wiki indicates that this SDIO device needs the brcfmac driver Wireless Wiki BRCM80211

I managed to find the various Android firmware elements by mounting the android emmc partitions using instructions found here Access Android Partitions From CoreElec … though I needed to make a simple update for access to the “vendor” partition where the files are located

As we said already it’s not supported by 4.9 kernel. It should work on next 5.4 kernel someday…

ok, thanks Portisch.
(I didn’t realise your last note was a reply to me)

Hi Portisch,

I actually got my wifi working on my X96 Max Plus T(AM7256) by inserting stock wifi drivers( nvram_ap6354.txt and fw_bcm4354a1_ag.bin) and instructing dhd_config to load the correct nvram files… Bluetooth is still unusable though(Can pair my android phone, but can’t play audio to CE; nor can it pair a bluetooth speaker)

Stock firmware uses Linux Kernel 4.9 too so I guess maybe something outside the kernel is responsible for unusable WiFi and bluetooth?

Dear BCM4354 users @ruz88 @AlexHalogen @redger : please try this devel image:
227.32 MB file on MEGA

It’s based on 19.2 Matrix and you need to be already on CE-19 Matrix before update!

Please make a dmesg | paste log.

EDIT:
Here a new link. It should include the firmware needed:

Hi Portisch:

The log goes:
http://ix.io/3uZ4

WiFi isn’t working on 2.4/5G(Open nvram file failed); BT works for some devices but not others(while they work with stock).

Thank you so much for your time and effort!

Can you create file /storage/.config/modprobe.d/options.conf with the content

options dhd firmware_path=/usr/lib/firmware/brcm/fw_bcm4354a1_ag.bin nvram_path=/usr/lib/firmware/brcm/nvram_ap6354.txt

and reboot.

Nope that didn’t work - fw_path is correctly set but nv_path is still /usr/lib/firmware/brcm/.
However I tried to set the options manually by insmod dhd.ko nvram_path=/usr/lib/firmware/brcm/nvram_ap6354.txt firmware_path=/usr/lib/firmware/brcm/fw_bcm4354a1.bin - and WiFi is up and running(2.4G only).

I also tried inserting 17236 1 nvram_ap6354.txt \ to the nv_by_chip section in /usr/lib/firmware/brcm/config.txt, and WiFi is running(2.4G only). Replacing nvram_ap6354.txt with the file from stock firmware enables 5GHz.

Hope that information helps!

Ok, can you remove the file /storage/.config/modprobe.d/options.conf and use /storage/.config/modprobe.d/dhd.conf ?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice