Looking for users with no working WiFi or BT

Please also run dmesg|paste

I got this: http://ix.io/3L7G

actualy without space: http://ix.io/3L7J

ngbruno, reboot the device and run the command again.

After rebooting no bt or wifi working, as expected

for the command “udevadm info /sys/bus/sdio/devices/* | paste” I got:
Unknown device “/sys/bus/sdio/devices/*”: No such device

for the command “dmesg|paste” I got:

I used the generic CE Matrix -ng firmware as recommended for this S905X3 Magicsee N5 Max 4GB box and used the suggested DTB sm1_s905x3_4g After going to Arthur L’s Github site I got a working VFD Conf file (thanks a lot Arthur) for the front panel display and found using the X96+ remote.conf file this worked well for the IR remote.

However I notice there is no WiFi available at all. Not sure about Bluetooth as forgot to test that and the box is now with a friend I set it up for who does not use BT anyway but he would like WiFi as a fall back though he normally uses Ethernet cable.

Can anyone help here ??

6 posts were merged into an existing topic: What box to buy for CoreELEC in 2022? (no premium streaming apps needed)

My tvbox H96Max plus5 wifi can not work.

Some infomaiton
device H96Max plus5 2G/16Gb
android :slimbox sbx_x96max_plus_5_atv_14_9

please help me to fix the wifi issue

Please read the first post of this topic and provide the information asked.

Your box uses Amlogic W150S1 WIFI chip, which is unsupported…

@Daoshuailx please run the command in SSH connection:

udevadm info /sys/bus/sdio/devices/*

And post the results here.

@rolfi79 @Daoshuailx Please try this this test image:

It include a driver for the Amlogic W150S1 WiFi chip:

alias:          sdio:c*v6D61d9007*
alias:          sdio:c*v8888d8888*

Please test if WiFi is starting working and upload a log by:
dmesg | paste


I have a Vontar X96 Air 4/64. Under 19.4-Matrix_rc3 with sm1_s905x3_4g_1gbit dtb there is no wifi or BT.

udevadm output: http://ix.io/3QwP
dmesg output: http://ix.io/3Qxb

@rolfi79 @Daoshuailx any update on this?

I wrote about wifi on X96 mini plus. I gave it to my girlfriend. It only runs on LAN. WIFI does not need.

Then at least check if it works or not?

I Tried this on x96 max+ V5 2G 16G. Its getting there the bluetooth was not recognized. The wifi was recognized each router was shown twice but did not connect. I don’t have access to the box at the moment but will dump logs by the weekend.

Without log we can’t do anything

I want to add QCA6174 driver for S905, I tried to add QCA6174-AML in /Amlogic/options, but failed to compile. Is there a QCA6174 driver that can be used by Amlogic