Looking for users with no working WiFi or BT

No change, WiFi/BT still not working.

There happen a kernel oops, so I guess no chance to get the driver working without a dev in touch with the hardware. That’s why CE do not recommend to buy such cheap hardware. You don’t know what you get and maybe it will not work fully ever…

Just got my Tanix X4 today and it all works fine in Android 11. Configured an ultrafast 32GB SD card with CoreELEC 19.5 rc2 and all booted fine into CoreELEC but only using the standard generic SC2 dtb. If I try the 1G LAN dtb it does not boot. I tried both as there is ambiguity as to whether this new Tanix X4 box has a Gigabit LAN port or a standard 100Mb one as you see some listings saying its 1Gb (1000Mb) and some saying 100Mb. Anyway it must be only 100Mb as the 1Gb DTB will not work at all.

So for feed back to others here asking I can confirm that I have NO Bluetooth device available, NO WiFi available and NO VFD files I can find that work for the front panel display (was kind of hoping the Tanix TX5 Deluxe S905X3 working VFD.conf file would work wihtthe X4 but alas it does not). I have not tested the SPF port as have not the means to do so.

I appreciate this is a new model box and we only just have the first compatible CoreELEC firmnware for it, so I will have to be patient. I do not have the up to date expertise to be able to make a VFD file but I see others here are already working on it so appreciate what they are doing. Anyway I can live without Bluetooth and always use an Ethernet LAN connection with my main streaming box via my TV cabinet’s Gigabit LAN Switch. So I am patient to wait for the WiFi and Bluetooth drivers to become available here.

Many thanks to all the CoreELEC developers for the new rc2 update which makes the X4 boxes now available for all us grateful CoreELEC users.

For the Vacuum Fluorescent Display you can follow the directions listed here. You may want to skip right away to the troubleshooting option.

For Bluetooth, WiFi and LAN, please follow these instructions to assist our developers with obtaining required information.



And a bit of a refresher:

A post was merged into an existing topic: Nightly builds (NEW)

Okay no WiFi or BT on my Tanix X4 device here is the link from the above SSH command:- http://ix.io/48uz I hope that is correct and that a suitable device tree can be coded to enable the WiFi and BT to work on my new box

This use the Amlogic -S1 chip, no working driver do exist in public

So the Tanix X4 box is a waste of money then. Will there be a driver for it eventually do you think?

Ask your vendor, not us. We don’t have any such source or hardware.

I have a working CE 19.5rc2 in my X88 King EMMC (4Gb/128Gb), with home assistant plugin and a few docker containers, and Emuelec Addon. USB doesn’t work at all in Armbian, a working DTB is needed for 5.X kernels.
In CE, bluetooth works, but wifi doesn’t. I had some experience compiling kernel sources and debugging in previous Amlogic and Rockchip devices.

I also have a H96 Max X3, and I had a working Armbian in the emmc, but I need to resolder the DC plug, it’s loose and turns off all the time. I ordered it in Aliexpress, but it will take a couple of months to get here. Wifi and BT don’t work with CE, nor with Armbian.

udevadm info /sys/bus/sdio/devices/* | paste

dmesg | paste

And this is my decompiled DTB

X88King:~ # dtc -I dtb -O dts -o /storage/X88King_devicetree.dts /storage/g12b_s922x_x88_king_rev_a.dtb
X88King:~ # cat /storage/X88King_devicetree.dts | paste

Can you try this image and check if you have wifi.

1 Like

Thanks vpeter, I’ll try tonight and report tomorrow!
But balena etcher is not accepting this tar image, how can I install it into a usb flash?

It is .tar file to update already working USB stick.
But here is the image if you prefer it.

1 Like

Thanks a lot!
I have CE in the X88 King’s EMMC, and I prefer not to mess with it, as I have some docker containers with live home servers as homeassistant, piwigo, photoprism (testing) and my photo archive.

Thank you, you are the man @vpeter!
Now usb, wifi and bluetooth all work for the first time in a non Android OS!
Not that I need it right now, as I use ethernet, but this is great as now X88 King is fully supported in CE for everyone with this device.

CoreELEC:~ # udevadm info /sys/bus/sdio/devices/* | paste
CoreELEC:~ # dmesg | paste

Could I use this kernel and dtb with any linux as armbian, ubuntu or archlinux? Does it use the same dtb as before and the changes have been in the kernel and modules or did you modify the dtb?

It would be really nice to get USB working in kernel 5.x and mainstream linux, I examined CE dts files and the USB portions were really similar to khadas vim3 dts, just a couple of changes. Do you think this would be possible? If so, I could help you debug, it would be really great for all X88 King users.

We are using this driver Commits · CoreELEC/ap6xxx-aml · GitHub
No other changes has been made.

Using CE kernel and dtb for other distros could work in theory. But practice shows different results :slight_smile:

1 Like

In most cases this will not be a drop and go experience, especially when most distros are using 5.x kernel and CE has a 4.9 kernel. Many stuffs in other distros are therefore built against newer kernel and most certainly different kconfig. Things might work — you could get kernel booted up if you’re lucky, but then prepare for a lot of incompatible drivers and userspace programs due to different ABI

The same rule also applies for DTB, the DTB binding changed a LOT since 4.9:

You could in theory use Armbian’s build system to build an image with CE’s kernel (alas, note Armbian itself is not a distro, it’s a framework that provides that exact build system), but that’s another story.

1 Like

@vpeter I installed your image to a usb stick, and it worked great as I reported. But I forgot to disable auto update and at the next reboot CE got updated and wifi stopped working. Will this changes make it to CE repos, so next updates will include the driver? Would I need to switch to nightly builds? Meanwhile, do I overwrite kernel.img or does SYSTEM need to be overwritten as well?

Nightly builds already includes this change.

1 Like

Great, thanks again!