Magicsee N5 MAX - ethernet not working

Hi, after installing coreelec on Magicsee N5 Max, ethernet doesn’t work. I used this file g12a_s905x2_2g_1gbit. If I use a 100m file it works but the internet speed doesn’t satisfy me. What can I do?

I would say if the gbit device tree does not work then your device is not gbit capable as some adverts have been known to mislead users.

Have you tried Android to see if your device connects at gbit?

On Android speed is the same as on coreelec (~ 56mb / s, my internet is 120mb / s). I downloaded several applications and found information that the system is installed as 100m, not 1gb. I understand that I was fooled and bought a box with 100m ethernet instead of 1gb?
The site clearly says that the box has 1gb ethernet

It possible description is wrong
2gb version could be cheaper and with 100Mbit ethernet

1 Like

You should be using iperf to test the throughput, not speedtest.
But it’s very likely that the 2GB versions use different hardware. There’s a similar thing going on with another box.

Ask for refund since they obviously cheated you :wink:

Hi, he is not fooled, the chip is 1Gb in real but have some wrong parameter set.
I have the same issue. Opened the box, the chip is RTL8211F, theoretically Gigabit capable.
Ethtool reporting this:

CoreELECx2:~ # ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes: 10baseT/Half 10baseT/ Full
100baseT/Half 100baseT/Full
Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: MII
Transceiver: external
Auto-negotiation: on
Supports Wake-on: ug
Wake-on: d
Current message level: 0x0000003f (63)
drv probe link timer ifdown ifup
Link detected: yes

With this setup it’s speed is only 100kbps which is unusable.
Iperf cannot measure any noticable speed even.

Whent set it to 100mbps it works well.

Now I use a USB NIC in usb3, that can perform 940mbps measured with iperf. When I compare the two eth device the difference is only the “advertised pause frame use” as the built in dev’s is off. Tried to set it on with ethtool -A but reported to not supported to change pause parameters. I suppose some config file maybe had wrong accessibility and ethtool cannot write it in.

Or the driver failures?

Anyway my box even not works well under Droid by eth cable but one of my topic-pal reported full Gigabit speed under Droid with the same hw. Maybe it could be router dependent too with the missing autoneg set?

Notice on my last: the opening post is about 2G ram box which is specified as 100mbit lan, my one is the 4gb which is Gigabit.

It seems like a hardware failure.
On your picture (maybe just the photo) the PM6C-1001’s soldering not looks great.
I would try to resolder that and the passives around the RTL 8211F, and the chip itself.
Also I would check the resistor values on the RX and TX line.

Hete is a closer look, I cannot decide if it is bad, maybe later will take some better pictures…

Can you take a wider photo? This isn’t the component we’re talking about.

It seems three parts are missing.
The last one above the 8211 probably a missing resistor.
The second from the top on the right of the 8211 probably a missing capacitor.
The middle part below the 8211 is missing too.

The question is if those are missing by design or by mistake?

It doesn’t work at all so I guess it isn’t by design…

It turned out it is by design. (Another box with semi-working LAN has the same missing parts)

I think all these boxes are just using the same configuration. They most likely just implement the same circuit depicted in the RTL8211F datasheet.
So a crap PCB design could still cause issues, due to the very high frequencies required by 1Gbit to work.
You probably have the same issue that the Beelink GT-King had/has.

Do you mean the one which could be solved by shortcut one resistor?
All in all everyone is assuming hw problem? Isn’t here a member with the same box?

Here it is, SamWillson had some N5 max…
Maybe he has some photos in detail.