Magicsee N5

SD Card. Later on I will considering internal installation.
Skunz

hmm maybe display works because you use sd no internall After you run CE from sd first time the display worked or no do you remember

If I remember well after first installation the display was not working.
Skunz

@ffimon @Skunz

I found a problem why the clock not worked in my box. This box have two version of display controler:
FD655S (works) and FD6551 (not works)

Interesting. It’s possible you’re right.
I’ll try to contact the manufacturer for a datasheet and see if support can be added to the openvfd driver for it.

@ffimon @supermegazord
Ok, I emailed the manufacturer last night, and this morning I already had the datasheet and some code samples.
Here’s a build of the driver which will hopefully work with the FD6551 chip. Make sure to also use the attached vfd.conf file.
openvfd.zip (64.1 KB)
magicsee-n5-2-vfd.conf (1.5 KB)
You need to extract the zip in your box, then run sh test_led.sh.

@TheCoolest

Great job and super fast but when i extract the file and run test_led.sh inconsole show:

No command line options were found, showing usage instructions.

Usage: OpenVFDService [-t] [-dt TYPE] [-h]

    -t              Run OpenVFDService in display test mode.
    -dm             Run OpenVFDService in display demo mode.
    -dt N           Specifies which display type to use.
    -co N...        < D HH:MM > Order of display chars.
                    Valid values are 0 - 6.
                    (D=dots, represented by a single char)
    -h              This text.

That is not an error, it’s by design.
Does the screen work with this driver or is it still off?

Still not work

dmesg | grep vfd
[ 3411.784962@1] OpenVFD: vfd_gpio_clk:         #0 = 0x01; #1 = 0x04; #2 = 0x10;
[ 3411.784970@1] OpenVFD: vfd_gpio_dat:         #0 = 0x01; #1 = 0x05; #2 = 0x10;
[ 3411.784976@1] OpenVFD: vfd_gpio_stb:         #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 3411.784982@1] OpenVFD: vfd_gpio0:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 3411.784988@1] OpenVFD: vfd_gpio1:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 3411.784994@1] OpenVFD: vfd_gpio2:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 3411.785001@1] OpenVFD: vfd_gpio3:            #0 = 0x00; #1 = 0x00; #2 = 0xFF;
[ 3411.785009@1] OpenVFD: vfd_chars:            #0 = 0x00; #1 = 0x01; #2 = 0x02; #3 = 0x03; #4 = 0x04;
[ 3411.785018@1] OpenVFD: vfd_dot_bits:         #0 = 0x00; #1 = 0x01; #2 = 0x02; #3 = 0x03; #4 = 0x04; #5 = 0x05; #6 = 0x06;
[ 3411.785025@1] OpenVFD: vfd_display_type:     #0 = 0x01; #1 = 0x00; #2 = 0x00; #3 = 0x06;
[ 3411.785048@1] OpenVFD: Skipping vfd_gpio_stb evaluation (0xFF)
[ 3411.785052@1] OpenVFD: Skipping vfd_gpio0 evaluation (0xFF)
[ 3411.785056@1] OpenVFD: Skipping vfd_gpio1 evaluation (0xFF)
[ 3411.785060@1] OpenVFD: Skipping vfd_gpio2 evaluation (0xFF)
[ 3411.785063@1] OpenVFD: Skipping vfd_gpio3 evaluation (0xFF)

Hi all,
Happy new year 2019.
Just bought a new s905x machine: Magicsee N5. I performed a smooth installation of CoreELEC 8.95.6 with gxl_p212_2g dtb. I have trouble with internal bluetooth not recognized by CoreELEC. this is the output of hcitool dev command:

Devices:

and this is the output of dmesg | /usr/bin/pastebinit

http://ix.io/1xfM

Bluetooth works very well with an external adapter.

Thanks in advance for your help !
Rgds
Skunz

Anyone can help me ?
Thanks
Skunz

There are some good pictures of the internals on this and the origonal firmware
I have one of these I haven’t had chance to try it yet I will report back when I get a chance

It looks like some unknown sdio combined wifi+bt chip in use on this device… Cdtech judging by the pictures, I’m guessing your wifi is not working either?

@ffimon @anon88919003 thanks for your reply.
The Wifi is working well on 2.4G and 5G band with limited range capabilities. Performing more test on my device i understood that using an external wifi usb adapter the bluetooth sometimes is working and sometimes not in random and strange behaviour.
If u need more information or logs please do not esitate to ask.
Many thanks.
Skunz

Can you type lsmod on SSH and paste the results

TestBox:~ # lsmod
Module Size Used by
8021q 19039 0
wlan 3451360 0
cfg80211 374882 1 wlan
mali 192433 5
ir_nec_decoder 2741 0
wifi_dummy 806 0
meson_ir 3997 0
rc_core 25833 3 meson_ir,ir_nec_decoder
amlvideodri 12226 0
videobuf_res 5386 1 amlvideodri
videobuf_core 16651 2 amlvideodri,videobuf_res
videodev 152169 1 amlvideodri
dwc_otg 233217 0
fbcon 38031 0
bitblit 4468 1 fbcon
softcursor 1168 1 bitblit
font 7327 1 fbcon

Thanks @ffimon it looks like your device is using the QCA9377 which has a very well developed open-source driver, we already have support for this.

Can you try and do /usr/bin/hciattach -n -s 115200 /dev/ttyS1 qca 2000000

and then hcitool dev

Here it is :slight_smile:

/usr/bin/hciattach -n -s 115200 /dev/ttyS1 qca 2000000

hci_send_vs_cmd: Send failed with ret value: 0
Failed to attach the patch payload to the Controller!
qca_soc_init: Rome Version (0x00000000)
qca_soc_init: Detected unknown ROME version
Can’t initialize device: Success

hcitool dev

Devices:
hci0 A0:9D:C1:F8:B8:8F

After the commands I try again to pair a bluetooth keyboard but without success. Same strange behaviour. First I can se the device, then , after 30 seconds no more devices.
Skunz

The remote files for this can be found here

What is a correct DTB file for this box?