Mecool KI Pro boot problem

Hi to everyone!

I’m trying to install CoreElec on my new KI pro. I prepared the SD and with the toothstick it begins to install. However, when it reboots, it stuck on Mecool logo…

After several attempts changing the dvb.img and more, i created a USB flash as the same way…My surprise is with the USB it works.

Is strange because if I boot the native Android OS and I introduce the SD, it recognizes it and I can see the files on the explorer, but is not working to install/boot :frowning_face:

I read this topic: Mecool KI Pro - problem with booting from SD card and it seems that is similar to my problem. The question here is that I don’t really know how the user solve it :S

Could anyone help me with it? Thank you very much in advace to all.

Have a nice day!

I’ve fixed it with a small piece of tape on sd card to make it thicker.

It’s not dvb.img you should be renaming the dtb to, its dtb.img.

Sorry, I renamed it dtb.img, however it didn’t work. Now is working with USB but SD is not :frowning:

I’m going to try!


Which dtb did you use?


Would you mind to show me a picture about how did you solve it, please?! I’m not able to boot it from SD :frowning:

Thank you very much!

Hi relkai!

I’m using gxl_p230_k1_pro. I think is not the problem as I created an USB with the same procedure and dtb and it’s working. Is a problem with the SD only. I’ve seen two users who have solved it with tape, so i think is a hardware problem in KI Pro…


Hi shark,

just cut a piece of adhesive tape of the same size as the SD card and stick it to the SD card. Then check if the box is booting. If not, repeat the procedure mentioned in the first sentence.