Mecool KI Pro not booting from SD with correct dtb.img, fake?!

Could be, don’t know how is your box wired, but DON’T install to internal before you sort booting from peripherals.

I know that it isn’t a brilliant idea. However, I can’t send the box back to China that easily after dissembling it. Thus, I have to make it usable at some point. Honestly, I’m a little bit pissed that I’m the first one running into this issue of a “different” Mecool KI Pro. Solution finding is interesting though.



log files (70.1 KB)

If you need anything @afl1 . Tell me.

I can’t see any wifi issue in kernel log. Your chipset is BCM4335 rev 1 fully supported in CE. Most likely is something wrong with your hw.

I see your point. But if it works in Android, there might be another problem right??

Right, there is most probably a problem with your CE installation.

Any suggestions what to do next?

Well, I’m not really an expert, but in a situation like yours I’d first check USB voltage under load, then try with another power supply that I trust, which can supply enough power. If everything checks, I’d try a fresh CE install with a trusted USB2.0 flash drive, fresh formatted to Fat32.
If that does not work with any dtb.img, I’d try with some LibreElec instillation aimed for this box.
After that I’d give up and wait for some new ideas to cross my mind…

I don’t get any output from the UART. Could somebody tell me what could be the reason? The same adapter is working on another box.

Do I have to solder anything else?

You already soldered too much. :slight_smile: You don’t need the 3.3V cable.
Make sure you reversing the data cables (TX to RX, RX to TX)

I use a esp8266 to catch the serial output via WIFI, so I need the power from the board. However, I don’t get any output. I changed the RXD and TXD already, but nothing. Do I need to connect some solder bridges visible in the picture? Anyone aware of not connected serial ports? :smile:

What speed is your serial set to? It should be 115,200 bps

Do you have a custom program in the esp8266?
It waits AT commands on RX pin and send back reply on TX on default firmware.
Can’t imagine how it worked on the other box.

It is a serial to wifi firmware. I would have to check the name. It does 115200 bps, I can set it. At least it should through some garbage otherwise.

If you are not aware of any other modifications I would need, I blame also my esp8266. I have another serial adapter at home.

However, this one is working on my odroid N2.

I see.
Is it connects to your wifi network?
How do you receive the serial data on your computer?

Via telnet (putty). There is a port for settings like baud rate, wifi scan, etc… And another port to receive/send the serial data

So any of the s905, s905d should output something on the uart port without doing any other modifications. Then I search the problem somewhere else. I will let you know, maybe I will quickly check with the oscilloscope.

First check: the RX, TX and power line have to be high (3.3V)

I just tried with another UART adapter. Nothing. Did anyone here about a device not showing something on the serial port?

Update: The UART pins were not connected. I bridged them now. So here is what I get. Power of seems to bring the box in suspend/power off mode from which it fails to wake up/come back. Am I right? Could somebody help me?

Update2: I just found, when I keep pushing the button on the bottom of the box. The box starts up after a power off. In case this helps you in any way.

booting_ok.log (15.4 KB)
power_button_off_suspend.log (410 Bytes)
booting_fails_power_button_on.log (391 Bytes)
power_off_through_kodi.log (410 Bytes)
booting_fails_power_button_on1.log (392 Bytes)
reboot_ok.log (15.6 KB)

(WIFI short reconnects)
dmesg_coreelec_wifi_dissconnects.log (99.0 KB)

power_button_off_android.log (2.5 KB)
booting_ok_android.log (107.0 KB)

you have to add 2R24 and 2R1 resistance for uart. my box has

I just found it. Thanks @taki taki! It was kind of obvious, however, after having a closer look. So no I have the UART logs. Any idea would be welcome.

What do you guys think is the problem?

It boots without a problem to Android after a power off.