MECOOL KM9 Pro Classic (2 GB / 16 GB) with AndroidTV 10

I am a newbie and I have MECOOL KM9 Pro Classic (2 GB RAM / 16 GB ROM) with AndroidTV 10.

I want to install CoreELEC but it does not work.

I tried g12a_s905x2_2g.dtb and it came the following error:

'### Starting debugging shell for boot step: mount_flash… type exit to quit ###
*** Error in mount_flash: mount_common: Could not mount LABEL=COREELEC ***

Then I tried g12a_s905x2_4g.dtb and no error came only the box-logo and nothing happened.

Before I try further, my question, is there a problem with AndroidTV 10? Can CoreELEC be installed with it at all?

If not, is it possible to downgrade to AndroidTV 9 and how?
On the internet I found (includes IMG and USB burning tool). But I do not know if this is correct and how to install then?

1 Like

Do you boot from SD card? Then try using USB stick.

1 Like

I used a USB stick (FAT / 2 GB). I do not have an SD card, I would have to buy first. I can do that, but what type, what size?

But if there is a problem with Android TV 10 ( I read about it, though a few years ago), then an SD card will not work either.

There are currently few users which can’t boot from SD card. That’s why I though your issue is the same.
But if USB also doesn’t boot then this is different issue (like you mentioned AndroidTV 10).

Could you attach keyboard and type few commands in console which appears after the error message?

And maybe I can make you one test image also after lunch.

1 Like

Sorry, I don’t have a keyboard to plug in.

Ok, then please try with this image and let me know if it boots or not.
If it boots then after you get into system enable SSH server and type this command and post url you get.

dmesg | paste

Just write it to USB as before and copy correct dtb file.

1 Like

The CoreELEC logo is on the screen - for a few minutes, that’s all that happens.

I used the rear USB port on the KM9 Pro with the toothpick method.

Now the logo has disappeared and the screen is black.

Now I tried the other, front USB port. Again the CoreELEC logo appears and nothing else happens.

And now the screen is black again.

Do you see any text on TV with CE logo?

Maybe you should really try to install Android 9 on this box (if exists). But I don’t have instructions for that.

1 Like

No text and no error message, only the logo.

Regarding AndroidTV 9 I had found on the Internet: (contains IMG and USB burning tool).
But I do not know if this is correct and how to install then?

Anyway thanks for your support.

If you want try this image and check if you see ANY text on TV.

1 Like

Thank you.

Are there any known issues with not being able to install CoreELEC when AndroidTV 10 is on a box?
Maybe the boatloader is blocked on my box?

What can it mean that with your test file the CoreELEC logo appears, but then it does not go further?

Hard to tell because none of the devs has this box to tell exactly what is wrong.

Because CoreELEC logo appears then it starts booting. But then …

1 Like

As a new user I was not allowed to create a new post yesterday, I had to wait 18 hours.
I also could not find anything to write you a personal message (probably I am not authorized for that).
Therefore, I supplemented a post of mine, but that was apparently not seen?

Now with a new post:
I have tested your latest image. Now text/error comes next to the CoreELEC logo (see attachment).

If you want please try this image. There will be no CoreELEC splash but only some text on screen. Make a picture of it.

1 Like

Thank you.
Here are the text:

With this image you should get little more output.

1 Like

Thank you.
Here is the text:

#6 could be a winner :slight_smile:

1 Like