Mecool M8S Plus W - installtointernal not working

I tried several dtb files, but I always give the following error message:
One of BOOT, SYTEM, DATA or DTB partitions is missing.
Make sure that you are using a correct device tree and a device with internal memory!

I uploaded the original android dtb.img:

so, you have downloaded the latest coreelec image file, burnt it to sd card or usb, & then from the devices trees folder have tried all of the dtb files?

Yes I tried the following files (the box is 1/8):

It looks like, this type of NAND chip is not supported by the CE’s kernel.

If you are successfully booting from SD/USB and only have issues with the installtointernal command, as the title suggests, give this a try instead

Thanks, but I like to using with only internal memory.

The NAND/eMMC type is: Micron 7SG22 NW814

Any chance to add this type to chip to the kernel driver?
Kszaq said this is the source definiton file:

This is the dmesg output:

dmesg with _nand dtb:

installtointernal is something we provide on an as-is basis and don’t really provide support for, your welcome to add it to the kernel yourself and we will merge any pull request sent to us so it is included with future builds.

Thank you, where are the CE’s kernel source on github?

Any update on this?

No and there is unlikely to be a resolution to this issue with this device.