Mibox s 2nd received an error: Error in mount_flash

Hello, I am a user of mibox s 2nd (mdz_28_aa).

I saw that homatics can boot coreelec from a USB drive, and since the CPU of mibox s 2nd is the same, I tried to boot coreelec from a USB drive. However, I couldn’t start it, and I received the following error message:

'### Starting debugging shell for boot step: mount_flash… type exit to quit ###
*** Error in mount_flash: mount_common: Could not mount LABEL=COREELEC ***

Bad USB stick?

I’ve tried two USB sticks, one of which is newly purchased, and both of them display this error.

You are making usb stick correctly?

I am making usb stick correctly. I used both balenaEtcher and Rufus.

I’m just guessing what can be wrong but do you have any stick with led to see if maybe usb is not powered when you see this message?

When my TV box starts up, the LED on the USB stick blinks for a while. when I see this message, the LED on the USB stick stops blinking.

Maybe the usb power got cut. Which means it doesn’t allow booting from usb.

Original box didn’t allow booting CoreELEC: Xiaomi Mi BOX - CE and DRM

But I think I saw somewhere how to boot from this device but can’t find the source.

Or this was mibox3? https://www.reddit.com/r/MiBox/comments/uolzc7/if_you_have_a_mibox33c_mdz16aa_you_can_now_flash/

Thank you for your help.I will continue to try.

I have Xiaomi old box Chinese only.
MDZ- 18-AA.

Havd you tried to boot CoreELEC from recovery

Remove power supply from box.

Insert USB Drive with CoreELEC

Now must hokd in 2 button’s on remote control at same time…

The OK button and BACK button

Continue holding and apply power to box.
Keep holding button until CoreELEC boots
Or you are taken to recovery

Maybe will work

Happy Testing

Thanks, i’ll try

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.