Xiaomi Mi BOX - CE and DRM


#1

Hi there,

I have purchased a Xiaomi Mi Box which has proper DRM / Playready support.
With this it should be possible to get Amazon/Netflix as least in FullHD.

I have a few questions:

  1. Can I boot CE from USB (there is no SD)
  2. Will the DRM capability be usable in CE?

#2

No and no.

The boot loader /kernel is locked so no installing other roms/os builds.


#3

Ok thanks,
didn’t know this. I have only checked the cpu.


#4

Having said that, I’ve found v5.34 builds of ARMBIAN do actually boot. Most other images I’ve tried on my Mi Box MDZ-16-AB don’t boot.

I’m not sure what is special about the kernel on these though.

If you’re interested, they’re here: https://yadi.sk/d/srrtn6kpnsKz2/Linux/ARMBIAN/5.34

I haven’t got their Kodi debs working yet though.


#5

Interesting. Wonder if it is signed to mimic a valid Mi-Box image


#6

I wasn’t sure that would be possible, otherwise it would defeat the whole point of the locked bootloader.

I’ve only stumbled on it because I totally broke my Android setup on there by fiddling with an Oreo downgrade.

I’m playing with the Debian stretch build of Armbian, and it seems to work fairly well, but I’d much prefer to go to CoreELEC. Kodi is failing for me with a Mali userspace/kernel version mismatch. Ugh.


#7

can you explain how you did it? just flashed in a usb drive? that’s very good news!


#8

Yeah, pretty much. I used a USB hub so I could also connect a keyboard too.

I had soldered some wires to the board for a TTL adapter so I could get access to uboot and the kernel messages which helped. It may actually not be necessary though.

I can dig up the link I found with more detail of anyone is interested.

I’m running a Debian 9 xfce environment, and it’s not bad.


#9

please do! I bet every mibox owner will be interested…!


#10

I originally got my info from here:

I soldered my GND connection to the pin underneath the ‘R’ label for RXD in that pic. Then (on Linux) I used:
cu -l /dev/ttyUSB1 -s 115200
to access the console.

As I said before, the 5.34 Armbian builds did boot successfully. Didn’t supply any dtb.img or anything. I think that the image on a USB drive should just work, but there was some info in that XDA thread about uboot commands. I think the aml_autoboot script should just take care of it.

Other Armbian builds look like they might have worked, but something might have been up with their kernels, as it looked like it loaded ok, but no console log or anything. Didn’t look into it any more than that.

Compared that to these LibreELEC and CoreELEC builds, I suspect they actually fail the kernel load process. The uboot logs are very different. I can provide logs if you’re interested.

Hope this helps.


#11

I’m not the right person to help with that, just very interested in get rid of buggy androidtv on the MiBox.
But you should post those logs when you can. both the working Armbian and the not working Coreelec.

@adamg Can you help? or point someone who could?


#13

150balbes does not use git properly so he has made it extremely difficult to see what changes he has made in Armbian.

if you have access to UART by soldering a header then you should be able to interrupt the u-boot process and enter the commands in aml_autoscript and boot CE.

I don’t believe the bootloader is locked, they have probably just disabled booting from external unless you use the above method but without a device to hand then I would not be able to confirm this, I have been able to do this on another device though that was similar.


#14

Maybe you are right, but I thought a locked bootloader is a requirement for getting DRM keys - and after unlocking the bootloader you will lose your DRM keys.

Would be great to have booth: CE with DRM keys and Mi Box would be the best 905 Box you can buy :smiley:


#15

I’m not sure on that but the Minix U9-H doesn’t have a locked bootloader and you don’t lose the DRM keys by installing CE or any other O/S as they are saved on a separate partition dedicated for them as are most if not all Amlogic devices.


#16

Ah, I did not know that Box. But Mi Box has also Play Ready 3.0 + Google Widevine Level 1 and is half of the price. If it would be work with CE I would buy this Box instant :smiley:


#17

It certainly ticks the right boxes… S905X which I believe is the best CPU to buy at present, aesthetically pleasing and 802.11ac.

Without one to hand though to see what’s going on with it then it’s difficult to add support unless 150balbes sheds some light on what he did.


#18

Well, I contacted 150balbes, he wants to help but needs a tester. PM me who wants to help.


#19

I’m keen. Let me know how I can help.

I’m going to post the uboot logs later today too.


#20

Here’s a couple of logs from some builds I’ve tried.

CoreELEC-S905.arm-8.90.5.img:
https://paste.ubuntu.com/p/jS6tBmcdT8/

Armbian_5.34_S9xxx_Debian_stretch_4.9.40_server_20171112.img:
https://paste.ubuntu.com/p/z8g8PVB66H/ <— success!!

NOTE: I believe other Armbian builds do successfully load the kernel, but it fails from there, so I assume some sort of kernel/hardware problem and not a fault of the bootloader


#23

WRT rooting Xiaomi MDZ-16-AB or accessing the bootloader, I submit you are all chasing your tails.

Don’t foresee a successful outcome for this endeavor.

Willing to be surprised by some enterprising folks!!