Microstutters on some content

This past month or so, I’ve been replacing all of my equipment. I use to have an old Core2Quad PC running OpenElec on a 10yr old Sony Bravia, and then switched to a Beelink android box with CoreElec with my hard drives in a NAS setup (WD MyCloud EX2 Ultra).

Got it all sorted and running, then yesterday the TV was replace with TCL 6-series 55".

Played with some settings, image was too sharp and clear, everything looked like shot with a camcorder and ghosting. Switched that and everything looks good, except some videos tend to microstutter. Not size related either. I have a single MKV file, X265, 10-bit, 4K, around 50GB of Infinity Wars and seems stutter free. I’ll grab an x265 1080p around 4000kbps (3.5GB) and microstutter.

So many settings, not sure where to start… any ideas?

I am running off ethernet, gigabit router with Cat6e ethernet cables. NAS is about 3 feet away as is the router so, ethernet from NAS-Router-Beelink.

This is not a hardware, moved to the correct subcategory.

This usually happens on wrongly encoded content, as you said you have a 50GB file that is stutter free.

You can try playing with /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin to see if it improves playback.

Nah, still in Hardware

Hardware category is for peripheral issues ie dvb/wifi/ethernet etc…

This is clearly a playback issue.

1 Like

" You can try playing with /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin to see if it improves playback."

… umm… do I type that in somewhere? or, is it a file I need to change or something?

My Kodi/Linux skills end at copying to an SD card and booting it up. :smiley:

Wrongly encoded wise, I use VidCoder (handbrake) and encode using x265, variable bitrate, fps I click to keep the same as source, and audio is converted from DTS to AC3 5.1 640kbps. Quality between 18-23 depending how much I like the movie and if lots of CGI and such. Pretty straight forward/basic encode.

use putty or something to ssh to your box
login: root
password: coreelec
cat /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin to check current default value
echo 8 > /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin to set value to 8
try values 8, 10, 12, 16 to check that is better for your encoded material

1 Like

So, what does that do? increase the buffer? (guessing because I saw buf in there)… if that value goes up, does it affect anything else? (ie. higher number decreases available ram or something).

Not disputing what you recommend, just, trying to learn versus blindly doing something and not knowing why. :slight_smile:

sorry for the question, but i only had to to put these two lines in putty to change the value ?

first for check which value is active and the second
-> echo 12 > /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin

for example to put the value to 12 ?
is that right, i tried that alrdy but there no confirmation in putty or ?
…just blank cursor in the next line


Yes. cat will print the content of the file and echo "value" > will write “value” to the file.

1 Like

ok i tried several values, but got same issue all the time
after 7 minutes video freeze, stutter, but i checked also something different
i always work with an advancedsettings.xml :slight_smile:
buffermode 1
memorysize 0 (using local hard drive for cache)
but i think there is an issue with the sd card slot, because sometimes android boots and i have to restart the app boot 2 libreelec, afterwards coreelec boots fine again.

changed memorysize to 104857600 -> so using RAM for chache now

first test, stutters are gone -> fingers crossed :smile:
just want to share my practice

Hadn’t the chance to try anything yet, been a bit busy and now sick… But I think I noticed what the problem is.

I seem to get the stutters when I have subs enabled. SRT files, and when the sub changes to the next sub it gives a quick stutter.

Ever hear of that?

If your Beelink runs a S912, you can try a nightly : S912 Subtitles stutter fix 🛠

Looks like I already have 9.0.1 installed

Subtitles on S912 was only fixed in the nightlies, 9.0.1 does not contain the fix.

Oh, I just clicked the link, it said 9.0.1 and looked at my system and said same thing.

Is there a way to manually update with the nightly through the system? or do I need to overwrite my SD card?

I switched the updates to manual, but 9.0.1 was all I could find.

Download the generic tar file from here and put it into your /storage/.update/ folder:

root/coreelec don’t seem to let me login

The folder is shared via SMB too, and it’s called “Update”, just drop the tar file there and reboot.

If root/coreelec doesn’t work then you’ve either changed the password at one point or you upgrade from LibreELEC (which is a big no-no) and the password will be libreelec.
If you indeed upgraded from LE, then I suggest you do a clean install and try again.

Nope, didn’t change any particular or upgrade. I had OpenElec on my PC, when I switched to the Beelink I had a new SD card and started from scratch.

Maybe it doesn’t like being connected to via tablet.

EDIT - On my Tablet (Android) I can see the CoreElec but not access. When I go to my PC (Win10) and go to Network, I can’t find it. I installed CuteFTP and was able to add it and access it no problem. Added the file, rebooted and shows updating now. Fingers crossed.

Tested a few movies and TV series and the stutters seem to be gone. So, I guess not wrongly encoded content or a hardware issue, rather a known subtitle issue?

I still get some stutter when I have the bottom menu open, but not concerned about that since I only open it to pause/unpause videos or enable/disable subs.

But yup… been off the past few days with a cold so, watched a lot of videos and didn’t see any stutter.