Movie scraper issues

#1

Hey guys,

Just migrated from LibreELEC and so far I’ve noticed that CoreELEC is much snappier and responsive on my system (Odroid C2).

However, most my movie covers are turning out as blanks (or as still scenes from the movie itself) for some reason. In LibreELEC they were all there out of the box.

I’ve tried using both themoviedb and universalmoviescraper scrapers, with basically the same results.

Tried cleaning up my library a bunch of times as well, with no success.

Could you give me a hand here?

Thanks,

M.

PS: Just noticed that all my movies are showing up duplicated as well.

#2

How did you migrate your system over? Did you use the Backup Addon, Kodi’s built-in method, or are you using a media server like Plex or Emby?

1 Like
#3

This below is all assuming you’re not using a media server app (see above mentioned Plex/Emby).

The artwork issue sounds like your artwork cache needs to be rebuilt. Deleting the contents of the Thumbnails folder from the Userdata SMB share and rebooting/restarting Kodi should force a rebuild.

The duplicates sounds like you’ve imported your old library in a second time. Go into Settings->Media->Library and you should see “Clean Library” near the bottom of the Video Library section. Run it. Make sure you’re switched to “advanced settings” and not “standard” or the option won’t show up. Do the same under the Music Library section if you’ve got a music library as well. This will remove anything from the database that’s not currently accessible (including entries for files on non-attached removable drives).

1 Like
#4

Hey zang74,

So, I did an update via ssh using the method described in this thread, then did a hard reset:

Everything seems to be working super fine, except for this scraper issue.

#5

“Clean Library” didn’t work to clean up the duplicates. What ended up working was going to video configuration and deleting all other sources I’m not using. All my movies in an external HD attached via USB to my Odroid C2. I don’t need the other default sources.

The problem with the missing covers persists, though.

I’ve deleted the thumbnails cache as you advised and it didn’t work.

Tried changing scrapers again, followed by “clean library” and reboot and it didn’t work either.

That’s pretty weird.

#6

Try running “Update Library” after having deleted the covers.

#7

Tried that a bunch of times already, zang. It dodn’t work.

#8

Duh, my fault. I forgot to mention to delete Userdata->Database->Texturesxx.db (all version numbers and any db-shm & db-wal to cover all bases). Then “Update Library”.

#9

Deleted it as well, but didn’t work.

It seems there’s more local info stored somewhere.

When I access “information” on these movies, via context menu “C”, and then select “update”, a pop-up appears saying something like “there’s already local information about this movie. Do you wish to replace it with online information?”.

So, like I said, it seems there’s local information about these movies stored somewhere else, and it’s preventing scrapers to replace it with online info.

The good new is that I can fix it manually, using the process described above.

The bad news is that I’ll have to do it 120 times or so…lol

Do you have any idea about where else there might be local info about these moves which needs to be deleted?

Thanks again,

M.

#10

It may be that you have to edit your “Movie” source in your video configuration. Get the context menu up on your “Movies” source and “Edit source”. Then click to the right and hit “OK” to get to next panel. Make sure that the “This directory contains” setting is set to “Movies”. It may be set to “None”. I have found this when transferring files from one device to another or trying to copy files from LE to CE etc.

#11

Well, that “local info” isn’t just the artwork, it’s also metadata scraped down in the form of .NFO files in your media folders. If you use a media manager (Ember, MediaElch, etc.), or have previously exported your library, then you should have NFO files in the folders with your media. Kodi generally only reads these files on first import (or a forced “local data” refresh), so if you wish to use these NFO files, then you’ll need to delete your MyVideosXX.db files and re-scan the source. If your source is set to use a scraper, then it should scrape online after the initial NFO scrape.

Removing all sources and re-adding them would possibly fix the problem as well, but may not be as foolproof as just deleting the databases.

Deleting the video database means you’ll lose play states, play counts, etc–they aren’t stored in the NFO files unless your library has been previously exported from Kodi. If they are important to you, installing and doing an initial scan and upload with the Trakt Addon would keep track of 99% of that. That also involves creating a free account on Trakt.com.

One other thing to check is that you don’t have multiple MyVideoXX.db files. Each successive major version of Kodi bumps up the XX number and they’re imported into a new db. These old databases can sometimes hang around and cause issues.

1 Like
#12

There’s indeed a nfo sucker inside every movie folder…Thought about deleting them but now I’m more than halfway through updating each movie with missing cover manually, so I don’t want risk what I’ve done so far.

Anyway, do you have any idea why some nfos can be replaced by the scrapers and others can’t? There must be something else we’re missing here.

#13

The old databases are always left - by design - and cause no issues. Only the highest number is ever loaded.

#14

I noticed that both these scrapers were updated earlier today, maybe the problem was / is that these scraper addons needed updating on your C2.

Anyway if it were me, I’d just delete the MyVideosxx.db and Texturesxx.db from the Database folder, delete everything in the Thumbnails folder, reboot, make sure the scrapers are up to date then rescrape everything using the Universal scraper.

This would be a last resort though.

#15

If the videos are showing up in Kodi and already in the local database, then delete the NFO Files with no worry. That said, they shouldn’t be causing missing artwork issues.

At this point, you might want to give this Addon a try:
https://forum.kodi.tv/showthread.php?tid=158373

#16

Thanks, I’ll give it a try. :slight_smile:

I’ve been trying this one as well. So far, it’s awesome:

https://forum.kodi.tv/showthread.php?tid=258886