Movies scale incorrectly

I just got my got my N2 CoreElec edition and upgraded to 9.2.1

I have kept the resolution at 1080 in the menu, if I change this to 4k it zooms so I can only see 1/4 of the screen, see the image I uploaded

Then I ran the Video calibrate and the menu now fits on my 4K TV

But when I enter a 720p/1080p movie it seems a bit and do not use the calibrate I just did
If I enter a 4k movie its zooms as if I changed the menu to 4k and I can only see part of the movie

Side note: When I enter a movie, the tv will flickr and then display “HDMI 2” (Which it was already on) indicating that something about the input has changed

My tv is with a Sony HT-ST5000 soundbar that my N2 is connected to

I went to System -> CoreELEC -> Enabled “Disable GUI scaling” and then did the Video Calibration again

This is right solution:

If you are confused on how to actually peform the recommended solution:
systemctl stop kodi
delete all resolution related sections from guisettings.xml
systemctl start kodi

Let us know and we can provide further details. In a nutshell, you’ll need another computer which will send commands to your N2 box.

Thanks that worked