Gui at 3840 x 2160

Thanks. So set GUI to 4k, leave new scaling feature as default (unchecked) and then recalibrate GUI and any videos that are not the right size?

It’s better to not use calibration at all… it should be at right position by default.
If you have one more sd card try to clean install on it and check. If all looks good with fresh install then some of your settings is wrong.

Sorted now. Set GUI to 3840 x 2160 and then recalibrated GUI (which is very tricky as menu is hidden), recalibrated a few 4k videos (also tricky) and everything is working again under 9.2.1. GUI stays at right res as do the videos and thanks to my new HDR passthrough, TV detects HDR and switches accordingly.

If your TV has HDR then you should not need to calibrate Kodi at all.

Your picture size settings are wrong on your TV, calibration is totally unnecessary.

@Chuzz you need to stop Kodi before removing the settings from guisettings.xml otherwise they will just come straight back when rebooting.

Right solution:
systemctl stop kodi
delete all resolution related sections from guisettings.xml
systemctl start kodi

1 Like

Erm, why would one want Kodi/CE to upscale and not the TV? Potentially, the TV will do a better job no (depending on the TV of course)? Confused.

Not sure I understand the need for this upscaling - possibly I have missed the reasons behind it somewhere.

Edit : Just to add, I will have a Vertex 2 in between which will do the upscaling so I should leave the option disabled?

We’re talking about the GUI itself, not video or output resolution.
Originally it was always rendered at up to 1080P. At 4K resolutions it would still be rendered at 1080P and
then upscaled to 4K.
In -NG we allowed GUI to run at native resolution, but it introduced issues with some devices. So now the default is like it was in the past, and the user can opt into running the GUI without scaling, depending on the hardware they have and how it handles it.

1 Like

Believe me my TV is awful IMHO at scaling seriously… its a Panasonic and never got my head round it so always use another source to Scale but I didnt realise my Denon amp did it. I had all the manuals out again yesterday morning lol but im happy with the amp scaling the Gui from 1080 to 3840 and it just passes thru any 4k content in fact I would go as far as to say its picking up the hdr content better with this version as I had maybe one or 2 misses with 9.2.0 none with 9.2.1 Yet :slight_smile:

Im happy with the solution I ended up with.

If I have done a calibration already - how can I get rid of it without a new install? Edit guisettings.xml? Which keys have to be removed or modified?

<resolution> section
5 messages above:

thank you…

There is another way do it do a Hard Reset for coreelec from the coreelec settings but be warned it puts passthrough audio back to SPDIF and I’m guessing most have hdmi in fact there aint spdif on the N2 is there? Nah :slight_smile:

Doing a hard reset is pretty much equivalent to doing a clean install, this should only be a “last resort”.

Yes agree TheCoolest but if you don’t feel comfortable with command line its the only way but you will LOOSE ALL apps and library data the LOT so start from scratch scenario.

I am running GUI at 1080 as per you’re teams recommendation but as I posted previously my amp is scaling.

Anyways thanks for everyone’s input it is appreciated

Thanks and Regards

That worked thanks!

Although I will probably keep it disable as my Samsung Q9FN has excellent scaling as will my Vertex 2 when I get around to slipping it into the chain.

1 Like

Worked for me too under 9.2.1! Thank you @boot2k3. I have no <resolutions> section at all now and everything is working just fine with GUI @ 3840 x 2160. Woohoo.

1 Like

for me, too. GUI resolution @3840x2160 gives a much more precise image quality (not pixeled) for movie thumbnails (with Confluence, other skins I didn’t try) in the Files-section than with GUI @1920X1080

I used a Beelink GT King but since CoreElec stable V9.2.1 I can’t solve the problem about 4K Video.
“don’t scale GUI option” set or not set is the same.
Disable GUI scaling off = zoomed 4K video
Disable GUI scaling on = Minimised 4K video
What is the good setting for a GT King ?

I reset video parameters in system/video menu
I changed “scalingmethod>1</scalingmethod” by “scalingmethod>0</scalingmethod” but nothing solved and after reboot it comes back to 1

I should like you explain clearly (for no anglophone people) step after step what I have to do to solve that because since more than a day, I read everything about that in the forum but i d’nt find the solution.

In a french gt-King forum we are many to have same problem and I should like to explain to them how to do.


You should delete <resolutions> sections and your scaling changes too

About | FAQ | Terms of Service | Privacy Policy | Legal Notice