MP4 video playback freezes during fast forward

Hello all,
I have an issue. I have an Odroid N2 with 4GB RAM and have completely rebuilt the current Coreelec 19.1 Matrix release.

I have a problem when I play MP4 videos, or meanwhile fast forward and want to play again, that the video freezes or jerks strongly, also the sound is then gone.

I had this behavior with the Coreelec 9.2.7 version and with Kodi 18.9 not. There it worked without problems.

Does anyone of you have an idea what this could be?
I am grateful for any help / support.

I’ve noticed the same issue with mp4 files. Annoying for sure but I found it odd remuxing the file to mkv got rid of the problem.

I noticed that too. Fast forwarding MKV videos during playback is not a problem, but converting all MP4 videos to MKV cannot be a solution. All videos from the mediathek are MP4 files. Then I rather stay with Coreelec 9.2.7 with Kodi 18.9 and wait that the problem is fixed in the player.

As nobody collect any logs it will never be solved.

Did someone try it with Kodi on another platform like Windows or Ubuntu?

I’ll see if I can create some log files. Somewhere in this forum, was described, I think, how to create them.

No, I have not tried anything else. But I wrote above that Kodi 18.9 with the Coreelec release 9.2.7 did not have these problems. All this for comparison on the same HW (Odroid N2, 4GB) and with the same settings in the corresponding skin and Coreelec menus.

Log files created, see http://ix.io/3nno

you search a error in kodi so it would be good to choose the option to include kodi.log…

also debug logging in kodi must be enabled. and video/audio component as well as it’s video issue…

Hello Portisch,
I did it exactly as it says here.
https://discourse.coreelec.org/t/how-to-post-debug-logs/6494

I had the audio/video components enabled when I turned on debug logging.

Why the kodi.log was not there, no idea. What do I have to do? It should be there.

PS: Sorry Portisch, I made a mistake.I wanted to generate a new logfile, but whenever I select the menu item “Update latest Kodi log and configs. and view the short URL” it fails, always.

PPS: The error message on the screen is “Failed to paste log files, try again”

I have zipped the Kodi log file and attached it here to this post. I hope this helps.
kodi.zip (6.1 MB)

Hello Portisch,
can you do anything with this, or is there another way I can help you? I don’t mean via the Coreelec system menu “Update latest Kodi log and configs. and view the short URL”.

When I find more free time…
In the mean time please make the same logs with 9.2.7 where it’s working.
And upload your mp4 sample somewhere please.

Sorry Portisch,
in Coreelec 9.2.7 and Kodi 18.9 the export from the Coreelec system menu does not work either. Exactly the same error message “Failed to paste log files, try again”.

I also don’t know how to send you a 800MB MP4 file (German documentation). Somehow nobody is interested in it. No offense, but I think I’ll give up.

I’ve gone back to the old system that works fine and will stay there until maybe this is fixed someday.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice