My Beelink Mini MXIII (S905) and x96 mini (S905w) no longer boot from micro-SD

I have two Android TV boxes which are no longer booting CoreELEC from the Micro-SD card.
The first one that didn’t allow booting was the Beelink Mini MXIII (S905). But Android starts normally and it is also possible to access the micro-SD card with the File Explorer.
The second TV box, x96 mini (S905w) doesn’t allow booting anymore, after I installed the current and new original ROM; “X96_MINI_S905W_3.01.2019_AndroidPC” which is usual garbage (security patch from 2017 … to laugh about).
After the flashing it could be started without problems but there was no possibility to boot from micro-SD CoreELEC anymore, not even with other micro-SDs (Samsung Evo/ SanDisk Ultra etc…). I then flashed the current “atvxperience”… but I couldn’t boot from the micro SD card here either…
The third thing I tried was to flash an old (05-12-2018) original Rom (same garbage as the current one, only older, the security patch was there)… and also here the box couldn’t be brought into the dual boot anymore.
… maybe it’s my fault, because I removed both Android TV boxes and sprayed them with liquid rubber (car rims)… But it’s not conductive… and one of the two boxes ran until the update.

What stage do you get to when you say “Doesn’t allow booting from SD Card”
In other words , What is the failure ??
Freezes on CE or Boots to Android or whatever.
Please explain what happens .

Sry, deepl translate.
With the x96 mini, just boot into the Android, no matter which rom I install, it works fine, also the micro SD can be read in the Android, no problem.
However, the box doesn’t matter if I use the toothpick while booting or not, I renamed the matching dtb to dtb.img (no double img). … CoreELEC is simply no longer booted.

With the Beelink MX MimiIII I get at least a small answer;

Strange, with my X96 mini (S905W) after every Android update I had to use the toothpick method to first boot into CE. After that everything worked as before.

Did you try with a new/fresh install?

Go to Coreelec does not boot in X96 mini

Thank you, I’m aware of that. I’ve been using CoreELEC (previously LibreELEC) for some time, I’m aware that with a new ROM or CoreELEC micro-SD card copy the toothpick always has to be there.

Only this doesn’t work anymore… that’s my problem…

… there I travelled, before writing my contribution… only there is no solution…

Too bad nobody has been able to help me so far.

Since both boxes are from eMMC booting, is there a possibility to flash CoreELEC to the internal eMMC via USB cable (booting works, but not from the micro-SD)?

Otherwise… what would be reasonable to buy at the moment, I don’t need Wlan… but maybe a box that doesn’t break down at 50Mbits even with a Gigabit adapter…

tx3 mini mình cũng bị mong giúp đỡ.!!!

I also had this problem when I installed the wrong dtb.img on the micro-SD.
Too bad that nobody can help, both TV boxes can be booted from the internal eMMC, so it would be nice if coreELEC could be installed on the internal eMMC via USB connection…

So you can’t really do anything with the box…

Have you tried booting from a usb stick? The Beelink should boot from microsd or eitherof the usb ports. Download a fresh copy of CE, write the image to a usb stick using ‘gxbb_p200_2G_1Gbit_RealtekWiFi.dtb’ as dtb.img, (try to) boot using the toothpick - do you get the same error?

Hi, thank you very much for your help, but unfortunately this doesn’t bring any progress either… both boxes, no matter which USB port, and of course the right one “dtb.img”, they always boot from the internal eMMC, so Android. Too bad that there is no “usb burning tool” possibility to flash coreELEC to the internal eMMC… ;(