My X96max WIFI and Bluetooth don't work

I just bought a X96max, 4G/32G, and made the latest image file with the SD card: CoreELEC-Amlogic-ng.arm-9.1-nightly_20190827-Generic.img, and successfully run Coreelec. The problem now is that WIFI and Bluetooth don’t work, I guess the manufacturer changed the wireless module.
This is the run log:
If necessary, I can open the box to see what wireless module is.
Thanks to the efforts of the COREELEC team.

udevadm info /sys/bus/sdio/devices/sdio* | paste
Let’s see if output from it can help figure out what’s wrong.

Looks like your box has a RTL8822BS wifi chip. We currently don’t have a driver for it.

Drviver is included in RTL8723BS-aml. We have to add it to Amlogic-ng project.

Good news, very looking forward to

Sorry for for wrong info. In RTL8723BS-am is not allowed build RTL8822BU. We have to add new driver.

Ok, at least know what module, I hope to get the driver earlier. Thank you for your reply.

I just found the driver for RTL8822BS:
Does it work?

We will look into it. I’ve seen a driver in one of Khadas’ repos, maybe it will work.

I added RTL8822BS driver from Khadas repository. Pls test next nightly build if it works.

1 Like

Just upgraded to the latest nightly build, wifi can work, but Bluetooth still doesn’t work, suggesting that the Bluetooth adapter is not found.

You have the same problem than my Tanix TX3 Max with chip RTL8723BS. WiFi works flawlessly but Bluetooth doesn’t.

It seems that make Bluetooth to work is difficult, I’ve open a thread some weeks ago and they tried to help me to find a way to make it work, but it doesn’t. Hope they find the problem, I guess it’s related to the driver or kernel.

See you guys.

@Danny @Vapor

Try the following build, hopefully both BT adapters should work in it. (make sure to unrar the file first)!xL422aAI!FhrxOSKJFxt4gklldS_VAjZRqcKbyMBlaNQOZONR-Ts

Unpacking the box, the wireless module is Fn-Link 6222B, it is RTL8822BS

See my post above.

If BT will start working on both boxes, I’ll push the changes and they will be available in the following nightly build.

I unzipped the rar file and uploaded the tar file into the update folder through sftp, but can’t be update because a message appears that says “The update from 3.14 is not supported!”

This is because from the beginning, I installed the Amlogic.img image, not Amlogic-ng.img. Perhaps if I had installed the Amlogic-ng.img from the beginning, Bluetooth would already be working? :thinking:

I think have to download the last Amlogic-ng.img and delete the sistem are installed now.

Thanks guys!

Ah, I thought you had a box with S905X2. You can’t use this image, as it’s meant for S905X2/S922X.
In 3.14 builds the 8723 BT firmware is already there, and should work.

Ah, I see, Amlogic-ng.img is only for S905X2 devices, so I forget it.

My device is updated to the latest Nightly version everyday, but Bluetooth still doesn’t work, maybe I have to do a completely new installation?

PD: I downloaded the last Nightly image and burned it in the MicroSD, a completely new and fresh system was installed. I immediately went to the Bluetooth section but can’t detect devices, maybe I have to write something in SSH

Here is some pictures.


Hi all,
also mine (T95Z Max: s912 2/16/1 gbit - gxm_q201_2g_1gbit.dtb) doesn’t find bluetooth adapter with recent nightly builds (since middle august?):

The same works with CE 3.0.

Thanks for helping (or trying to :slight_smile: )