N2 9.2.2 & DVB-T issues.

Hi there, new user of coreelec.
I installed 9.2.2 to my new shiny N2, in the emmc.
As a media player it plays great, good job.

Unfortuantely, I face multiple issues with DVB-T tuners/sticks.
Am I alone?

My experiance:
I tried with both tvheadend backends, in all 4 rear usb ports.
The usb ports seem ok (the remote’s dongle and/or keyb/mouse all work ok).
For now I didn’t test with the front usb (no otg adapter available).
I tested one tuner at the time.
Generally, the tuners are detected ok when using latest linux drivers,

1st tuner: a generic cheapo Astrometa (panasonic/realtek),
it is being detected, scans ok with latest linux drivers, many errors,
usualy changes channel successfuly (sometimes it will need a restart…),
usually being lost on restart/suspend/cold-boot,
it will re-appear if I change the drivers module
from latest linux to default and back, only to disapear again on next shutdown/suspend.
I suppose an issue when loading the tuner firmware maybe?

2nd tuner: Volar HD 835 (afatech AF9033), a bit more stable, mpeg2 streams skipping,
scans ok, many errors too, no reception values from backend, still disapearing on suspend/shutdown,
it will also re-appear if I switch module drivers back and forth and/or after repeated restarts.

3rd tuner: xbox one dvb tuner (panasonic), I couldn’t test a lot,
incomplete scan, most of the services/channels not found,
frontend errors-out when trying to switch to a channel.

I tried to delay the start-up of tvheadend for 5 secs,
but i see no diference.

The tuners operate ok when attached to a pi3+ running latest libreelec,
so the hardware is ok I guess.
RF reception is also not an issue.

I searched around but i couldn’t find any relevant posts.

So, i guess, either my M2 has a hardware issue,
or there are (known?) software issues with usb tuners and 9.2.2?

Is the team aware/working on similar issues to fix on 9.2.3?
I could test/provide relevant logs if guided.


Not at all, take a look at the Hardkernel forum and you will see there are plenty of people with issues using the rear USB ports with various tuners, including me. For Example. Using the front micro USB was OK for me and others.

What is strange is some people have no issues at all, while others using the same tuners do have issues. It’s very weird. I eventually went down the HDHR path and my problems disappeared…

Yes, i did read for some issues that users had/hadn’t with usb 3.0,
and mostly bus saturation with HDs.
The discussion/reports are all over so it’s getting difficult to follow the progress.
I was under the impression that the issue was (mostly) patched/fixed(?) lately
in the odroid os images (i suppose in the corelec kernel too?).
And the tuners are usb 2.0, so I took the liberty to assume that they would be ok.
Maybe not…
Anyway, if anyone of the devs is interested to solve this,
I have the above 3 tuners and I can provide logs.
Other than that, I have limited knowledge of linux inner-workings.
Especially for the x-box tuner, it would be beneficial for the community to restore support.
Its both dvb-t/t2, relatively well-made, and can be found for like 10$, which is a steal.
I will order an otg adapter to test the front usb port.
Worst case, I need a new box, which is a pity since otherwise is a great player,
and the picture quality is outstanding in my eyes.
HD homerun, could be a solution but it’s another box,
and its not really available here.
Thanks anyway.

Xbox tuner should work because it’s well supported and for 10$ what it does still amazes me. But it’s not perfect and I had some problems in some muxes using dvb-c. There were some errors too but it was pretty usable. I have also a mygica t230 usb tuner. What I can tell you is that using multiple different tuners can present a problem because each one can work better with a different set of dvb modules. In dvb-c I had the Khadas vtv that worked better with default modules, Xbox tuner that worked better with latest and mygica that worked better with crazycat (in -ng devices, in 3.14 it worked with dvb latest and crazycat).
I got an hdhomerun expand and still use the other tuners for testing purposes.

I couldn’t test dvb-c, not available here, only dvb-t(1).

Understandable,but all 3 tuners exhibit similar behavior with N2,
and I only use/test one at the time switching modules as needed on the way.
Having one that works reliably with any module would be enough.

I wait for an otg adapter to test with the front usb port to eliminate or not
the possibility the issue stems from the rear usb quirks.
Or maybe it’s my luck and i got a dud.

Having said that, and after reading this, it seems that at least some issues are acknowledged/fixed upstream from AML for 4.9.

I suppose that the devs have extensive experience with N2 and AML sources,
and (hopefully) some sort of relationship/access with AML.
So if anyone could shed some insight on the nature of the usb issues I would appreciate it.
Is it a silicon/hardware/design/engineering issue, or what?
Can we expect it to be fixed (or mitigated) in software at some point,
or we just have to accept that the rear usb ports have “issues…”?

Well… guess what?
I got myself an otg adapter,
and magically the xbox tuner operates fine when connected on the front usb port.
Tried both latest kernel & TBS/crazycat modules,
both work ok with DVB-T broadcasts.
Changing channels still skips frames for like 3-5 secs on change,
but other than that its ok.
Tuner is available after a restart and after waking from suspend as it should.
The backend is still missing signal info (per/snr/signal) but reception is good,
and TVheadend 4.2 finds all expected services, epg works ok too.
I didn’t have time to test the other tuners/modules combinations,
but I suppose it would be the same.
I can test if someone needs the info.

Sooo… there is definitely something funky with the rear usb ports on N2.

My immediate issue is solved,
but if a dev. is in the mood to investigate I can still provide logs with the 3 tuners attached to the rear usb.
I sincerely hope its a software issue that can/will be solved because I’m starting to lose my confidence on odroid hardware.