Netflix buffering on Odroid N2


Since week or so I have a lot of problems with Netflix service. The problem is that it is buffering all the time although my Internet connection is very fast (100Mbps). After the restart of the box it happens that the first time it works Ok, but when I try to play again the same movie it is buffering all the time (you can take as example Dragons: Rescue Riders

Does anybody else has the same problem?

you can find the logs here:

Appreciate for any help.

Try with a fresh CoreElec 9.2.2 installation and only Netflix addon. If it has the same behavior, then report the problem to NF addon developer here.

I have tried with a completely new sd card and fresh CoreELEC instalation - only Netflix add-on still the same issue. On my laptop the situation is better (but also not perfect).

Could some users kindly try the “72 Cutest Animals” Episode 5 (on this one I always have problems) launch several times in row? Rewind a bit and report if they have the same issue or not?

I will also try a different LAN card. If none of the users has the same symptoms and the second card will give no improvement then I will report it to the developer.

Bad news for you, checked that episode on my N2 connected with LAN cable to my router with 200/100 Mbit/s optical internet connection, and the episode plays perfectly. I can seek/skip forwards/backwards, start over from beginning without any problems.
I noticed that this episode on several scenes runs at rather high bitrate, about 12-14 Mbit/s.
To check if you internet connection is able to cope with high bitrate NF streams check how “Our Planet” Episode 1 One Planet runs on your N2. Check from scenes from 4-8 minutes, which have the highest bitrates that I encountered; at present 14-16 Mbit/s. If it behaves the same as with “72 Cutest Animals” Episode 5, than you have internet connection speed problem, not NF addon!

More bad news for you, with present Corona virus pandemic Netflix lowered bitrates of their streams by half. Before the bitrate on mentioned scenes of Episode One of Our Planet jumped occasionally as high as 28-32 Mbit/s. So, when things get back to normal and NF returns to original bitrates to their streams it will just get worse for you…

Thank you for the testing, I’m really appreciated. I don’t see it as a bad news, but only a news. There definitely is something wrong in my setup or with the provider or some other thing I need to sort out. It used to work flawlessly, and I have to find out a reason what’s wrong or make a complaint to the provider.
Anyway, thankfully to your testing I’m 100% sure the the problem is @ my site and there is no need to bother the developers for example.

I know the scene from the first episode from Our Planet, I’ve been testing it a lot especially with the previous amlogic box. That’s the reason I finally bought the N2 :wink: What is weird, for me is that, when I run the benchmark of speed test addon I have the download 100Mbp (fibre channel as you have), upload over 10Mbps. All services are working flawlessly, only the Netlix is problematic.

I will report in this topic, when I will find the solution.

Best regards

If you have a Smart TV with a Netflix application, with it you can check your connection speed to Netflix servers, usually 3 of them are active.
On the laptop you can check your connection with a Netflix Speed Test to see if there is everything OK. Maybe it’s dependent on your regional Netflix servers…


On the I have transfer rates at about 90Mbps, but anyway it does not translate into the quality of Netflix service itsefl. Today I’ve tried several things:

  1. I took the Odroid to work where we have different provider - everything worked flawlessly. Also tried the performance on my laptop - either the Kodi + Netflix addon or Netflix through Edge works perfectly
  2. Back at home I tried the same devieces and everywhere either it is stuttering and buffering (Kodi + Netflix addon) or the quality is very bad (Netflix with Edge 240p).
    The conclusion is that this is problem with my provider, so I have to make a complaint there. It will be difficult to prove - yesterday I called there, and of course they asked about the other services witch are working good (all speed tests around 100Mbps).At the moment I’m preparing movies - got prepared from work, have to prepare from home, but I know this will be a difficult fight.
    Tomorrow I will have different router, so I’ll be sure that my hardware is also OK…
    Best regards.
1 Like

During the weekend I had opportunity to test second router - it was the same. I have written complaint to my provider.
At the moment I had no issues playing Netflix on my Odroid N2, because the resolution is limited to SD, like written on this topic: - I’m very disappointed, because that is why I bought the Odroid N2 - to have stutter less FullHD Netflix…

Yes, one of the reasons why I bought mine…
I’ll cancel my Netflix HD subscription and subscribe to SD only. I see no reason why to pay more for getting less. Well done Netflix…

You can go the official way using a certified Netflix device.
CE is not certified

I AM paying for HD and am using “a certified Netflix device” for HD reproduction ->on my LG TV.

Reason for using Kodi addon is (was) only to get proper looking subtitles. The subtitles that are offered on my certified device are a joke, the looks and font selection is appalling.
So I’m not steeling anything from NF, nor am I watching anything I did not pay for in advance, and yet I’m blocked to SD and forced to watch HD on my LG with their terrible subtitles…

I never said anything about steeling
Also I don´t understand why Netflix is blocking kodi app, You can only watch if You pay for it

NF addon in Kodi on Android NF certified device (e.g. Android TV) is working fine with FHD/UHD content.

Yesterday a miracle had happened

  • Kodi Netflix has worked in full HD
  • no more buffering issues after the complaint to provider.

Thank you Sholander for help and testing and finding the source of the problem.

1 Like