Netflix plugin not working for me on odroid c2 running latest build


#1

Hi Guys…

Is there anyone who can tell me why the Netflix plugin does not work…
I run a odroid c2. with build 8.95.1 I Have installed inputstream.adaptive from jcoreelec source…
when I openend Netflix plugin it asked me to download and install widevine… this all is done without errors…
So I opened a movie but it does not run…
here a part of the log.

09:43:14.112 T:3554669424 NOTICE: Creating InputStream
09:43:14.136 T:3554669424 ERROR: GetDirectory - Error getting /usr/lib/kodi/addons/inputstream.adaptive/
09:43:15.733 T:3554669424 ERROR: AddOnLog: InputStream Adaptive: Unable to load widevine shared library (/storage/.kodi/cdm/libwidevinecdm.so)
09:43:15.733 T:3554669424 ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed
09:43:15.735 T:3554669424 ERROR: CVideoPlayer::OpenInputStream - error opening [plugin://plugin.video.netflix/?action=play_video&infoLabels=%7B%27rating%27%3A+0%2C+

I hope you guys can help me out here…


#2

The newest widevine is incompatible with inputstream adaptive.
Here is a workaround to this problem:


#3

Thank you for your fast answer… Is much appreciated…!!
I go there and see if I can fix…

Ok… did as being told in that post… and can confirm it is solved …

Thanks you again…

Best Regards…


#4

Guys can anyone help me out with Netflix addon? I followed the workaround steps and substituted the widevine file from the one available on the chrome os iso, but again, no video starts from Netflix addon.
Log here: http://ix.io/1v6U

Thanks a lot!


#5

https://github.com/asciidisco/plugin.video.netflix/archive/0.13.20.zip


#6

Dear sir, updating the addon didn’t make the magic unfortunately. Seems to be an inputstream.adaptive issue, but the version of widevine contained in that version of the chrome os iso doesn’t work on my c2.


#7

The main problem is, that you followed a quite old guide and replaced your widevine version with an old one.
You should remove the widevine library you’ve downloaded before, remove the inputstream-helper addon, re-install it and let it download the newest widevine version again.


#8

Dear relkai, I followed your instruction removing both the Netflix addon and everything that deals with inputstream. Then, after a reboot, I re-installed the inputstream-helper and the latest Netflix addon (by zip).
At first on a Netflix video a popup from inputstream notifies that widevine has to be extracted from the chrome os image. Unfortunately, even though the extraction ends successfully, the playback issue persists. When I hit for reproduction I get the kodi spinning wheel for half a second and then… Nothing.
Kodi log available at http://ix.io/1vbW.
Any kind suggestion is highly appreciated. If anyone with a c2 would be so kind to zip its widevine folder, that would be great.

Edit: lurking on the log, found out something that might help:
ERROR: GetDirectory - Error getting /usr/lib/kodi/addons/inputstream.Adaptive/

Needless to say /usr/lib/kodi/addons/ does not contain any inputstream* directory, neither it’s possible to simlink due to the fact /usr/lib/kodi/addons/ is read-only.

Additional info:
Inputstream Adaptive v. 2.3.6.0
Netflix addon 0.13.21

Everything seems up to date, so my guess is there’s something messy from the previous trial/workaround, even though I uninstalled everything and also manually deleted the addon data / script input helper before reinstalling it…

ADDITIONAL EDIT:
I started with a brand new CoreElec installation (8.95.6), then installed the Netflix addon (0.13.21) and the InputStream Adaptive (2.3.12.0).
The same error arises: clicking on any netflix video, the KODI spinning gear appears for a moment and then… nothing.
From the log, I get again the same blocking error:
ERROR: GetDirectory - Error getting /usr/lib/kodi/addons/inputstream.Adaptive/

I’m stuck even though I started from scratch with the latest releases. Any suggestion would be highly appreciated, thanks!


#9

To be honest, I have no idea, what is going on. It is working for me without any manual fixes on two different devices.
The crash.log isn’t really helpful. Could you please copy the full kodi.log directly after trying to play a stream on Netflix?
You should also install the newest 8.95.6.


#10

Sure sir, here it is:
https://paste.kodi.tv/tewoloralo
From row 210 on…
System config: brand new 8.95.6 (installed from scratch)
Netflix addon 0.13.21
InputStream Adaptive 2.3.12.0
On the first run the helper extracted the libwidevinecdm.so from the downloaded chromeOs iso; the file is now located at /userdata/addon_data/script.module.inputstreamhelper/cdm.

Any help would be really useful, I’m stuck’d on this error and can’t get Netflix working on the c2 (and since the TV is a quite old Toshiba without a native Netflix app, I don’t have any workaround but the pc…)
Thanks again!

EDIT: accessing CE by ssh I’ve seen that inputstream.adaptive is actually located at /storage/.kodi/addons/inputstream.adsptive. Tried to simlink or copy to /usr/lib/kodi/addons/inputstream.Adaptive but I can’t do that due to the fact it’s a read-only file system, that’s the shell message but it could be misleading.


#11

You don’t have the “inputstream adaptive” addon installed, which is mandatory for the Netflix addon to work properly.

EDIT:
Excuse me…actually it is installed according to the log.
You don’t need to symlink it, because it is executed from the storage partition, when correctly installed.

EDIT 2:
The good news is, that I’m getting the same error message about a missing directory in /usr/lib/kodi/addons/, but after that my video is playing without any problems.
Could you please enable debug logging and post again your kodi.log after starting a video?


#12

Thanks relkai for your support and patience.
Here it is: http://paste.kodi.tv/anidadegiw
(log with debug logging enabled)


#13

Okay, thanks.
This doesn’t look bad. inputstream.helper is reporting, that the widevine libraries are loaded and inputstream.adaptive is successfully loaded, too.
The solution is hidden in row 3264 (base64 encoded error data):

{"internalcode":205007,"messageid":2839488990811642,"errorcode":7,"errormsg":"Email or password is incorrect.","timestamp":1544081869}

Therefore you have a credential problem instead of a technical one.


#14

That’s weird… How could that be an authentication problem? The login has been performed successfully, and since this happens when I try to play a video (that means, I’m actually logged in) I assume there’s some mess with the profile… Actually I deleted/renamed the default profile in Netflix (it was by default my email address without the domain part), could this be related to the problem in your opinion?
BTW, I tried to access to the account from an old LG TV, it works like a charm.

Thanks once again for your help, I’ll further investigate then revert back.


#15

This message comes directly from the Netflix servers, so it isn’t a problem of the addon itself.
Netflix is a bit strange, because you can browse the library even with wrong login credentials, but it fails when starting a video.
Your Netflix login name should be the email address you registered with, not the profile name.
I also renamed the default profile and have 3 additional profiles, so this can’t be the problem.


#16

Seems too weird; I tried to logout from the Netflix app from my smartphone and then re-logging with the same credentials I use on the kodi addon. Everything works fine on my smartphone, so credentials are correct.
May be a problem on the addon in case of special characters in the password? I’ll try detaching the account from the addon, change the password and then log on again.
Thanks for your support! I’ll revert back after the tests.


#17

Just a quick note to notify the problem has been solved. I changed the password of my account removing some special characters that might be the cause of the auth failure. Re-configuring afterwards the plugin did the magic.
Thanks relkai, without your support I would be again on that fictitious error which basically was not in any way related to the real problem. I’ll try to check which element of my previous password created the problem in order to eventually post a ticket on the Netflix addon github.


#18

I’m glad, you solved it.
If you know, which character in your password caused the problem, please write it down here, too.
This should help others with a similar problem.


#19

Sorry everyone for the OT: I can’t get the addon to use the proper language. Every video I play starts in German even though the Netflix account is Italian as well as Italian is the main kodi language. Everytime I play something I have to manually switch the audio track to Italian. Is this the proper behaviour also on your setup?
Thanks once again


#20

Yes, on my setup every clip is played in German, too…but that is expected, because I want it to output German audio. :wink:

Could you please check your preferred audio language under “Settings > Player > Language”?
The Netflix plugin should respect and pick up this setting.