New Order: Looking for users with no working WiFi or BT

In case you updated to Amlogic-no (New Order) and you got no Wifi/BT working please make a report:

  1. Tried lasted available Nightly build?
  2. Device used?
  3. Wifi/BT is working by using Amlogic-ng and or Amlogic-ne? If this is the case please provide dmesg | paste with latest corresponding nightly installed!
  4. SDIO Wifi SoC
    4.1 udevadm info /sys/bus/sdio/devices/* | paste
  5. USB Wifi SoC
    5.1 lsusb | paste
  6. PCI Wifi SoC
    6.1 udevadm info /sys/bus/pci/devices/* | paste
    6.2 lspci | paste
  7. dmesg | paste after reboot

Please follow the CoreELEC Wiki for more details how to create useful logs. In case of a request from Team CoreELEC enable a Tmate session to share the device for remote debugging.

1 Like

I’m testing the new Amlogic-no on my MECOOL M8S and everything works except wifi.
I am using the g12a_s905x2_2g.dtb file. This box uses wifi card rtl8189fs on sdio .
Can I ask you to modify the dts file as follows?
The key lines are:

  •   max-frequency = <40000000>;
  • rtl8189fs: wifi@1 {

  •           reg = <1>;
  •   };
+/* SDIO */
+&sd_emmc_a {
+       status = "okay";
+       pinctrl-0 = <&sdio_pins>;
+       pinctrl-1 = <&sdio_clk_gate_pins>;
+       pinctrl-names = "default", "clk-gate";
+       #address-cells = <1>;
+       #size-cells = <0>;
+       bus-width = <4>;
+       cap-sd-highspeed;
+       max-frequency = <40000000>;
+       non-removable;
+       disable-wp;
+       /* WiFi firmware requires power to be kept while in suspend */
+       keep-power-in-suspend;
+       mmc-pwrseq = <&sdio_pwrseq>;
+       vmmc-supply = <&vddao_3v3>;
+       vqmmc-supply = <&vddao_1v8>;
+       rtl8189fs: wifi@1 {
+               reg = <1>;
+       };

I’m adding more information:

dmesg from Amlogic-ng:
and SDIO WiFi SoC:

I am sorry but this want work. Like sdio_clk_gate_pins is not defined at all so how it should work?

Your problem only is that Amlogic-no does not (yet) include a driver for 024C:F179.
The driver RTL8189FS-aml must be fixed to compile with 5.15 kernel.

1 Like

Thanks, I’ll wait then.
This example was with LibreElec and kernel 6.x.
If necessary, I will paste the dts file from kernel 4.9.

WiFi and BT are not working in NO build (latest nightly), but work in NG builds.
Device: X96 Max Plus2 (S905x3, 4GB RAM, 1Gbit Ethernet)
DTB: sm1_s905x3_4g_1gbit

Is this log from NG or NO?
Because the NO dmesg log says:

[    7.457572] [extern_wifi_set_enable] WIFI  Enable! 482
[    7.784384] meson-gx-mmc ffe03000.sdio: card claims to support voltages below defined range
[    7.824972] mmc2: tuning failed, reduce freq and retuning
[    7.825402] mmc2: tuning failed, reduce freq and retuning
[    7.825953] mmc2: tuning failed, reduce freq and retuning
[    7.826516] mmc2: tuning failed, reduce freq and retuning
[    7.827163] mmc2: tuning failed, reduce freq and retuning
[    7.827858] mmc2: final result of tuning failed
[    7.827868] mmc2: tuning execution failed: -1
[    7.827879] mmc2: error -1 whilst initialising SDIO card

It’s from NG because on NO I’m getting
Unknown device "/sys/bus/sdio/devices/*": No such device

I also can’t get Wifi working right now on SM1. But maybe the newer kernel version will fix this issue.

@DigiTo please try again after update with new nightly:

Now it works correctly, thanks.

Moving it here since it’s amlogic-no

Got an issue with an 8822bu WiFi USB adapter.


Kernel panic always occurs when trying to transfer files to the device. Related to VHT I’m guessing?

Rate marked as a VHT rate but data is invalid: MCS: 0, NSS: 0

It’s an Odroid N2 running amlogic-no.

it only looks like a warning:

[  279.858272] Rate marked as a VHT rate but data is invalid: MCS: 0, NSS: 0
[  279.858297] WARNING: CPU: 3 PID: 31 at net/mac80211/rx.c:4933 ieee80211_rx_list+0x6e8/0x9b0

And wifi looks like working:

wlan0: authenticated

Please make a issue at the driver author:

Maybe the drivers from this source will be suitable for my WiFi card?

yes, this looks good:

The driver used for Amlogic-ng is not compatible and it’s a lot of work to lift it up to 5.15.
So such solution looks better. I will try when I get some time.

@Secam7 please try new nightly if your USB RTL8189FS does work now, thx.
alias sdio:c*v024CdF179* 8189fs

Unfortunately, the card did not start: dmesg
Problem initializing sdio port?

Looks like, yes. The new Kernel version have some fixes about SDIO & g12a so maybe it start working with this version.

Using dtc, I reduced the max-frequency to this: max-frequency = <0xa21fe80>;

After such a change, loading the 8198fs module causes the box to reboot.

Too bad it doesn’t work, but thank you very much for your help.