NEW Repo for Remote files (Thanks to Betatester)

Original default remote.conf for AZW (Beelink) W95 S905W Box:

Guy, i have a problem unsolved. I bought a remote like in the post below:

I had managed to get the remote to work and everything was fine. It is now since this summer that the POWER button works for the PowerON but it does not work for the PowerOFF. I don’t think it’s a problem with the remote control otherwise the PowerOn wouldn’t work either, don’t you think? This is a problem that other users have found and it seems to me that we have not solved them either. I also tried the Keytable command from SSh to understand something more but that command doesn’t find any .cfg files that are there.

If this remote has a learn function, try relearning from the original remote that came with the device.

Do you still have the remote that came with the box? If yes, you can teach the USB remote how to turn on the box. The tutorial on how to do that is in the Library section of the Repository.

@bubblegum57 @Betatester

I try to give some more information to try to understand the problem. I tried to completely delete the remote control cfg file and Configfiles \ rc_keymaps folder. The remote still works without custom configuration. The original remote no longer works. If I try to learn the power button it stops working even in power_on. Same with another device that mounts the S912 instead of the 905X. Same remote and same problem. I tried the procedure described at How to configure IR remote control. I am able to stop systemctl services stop kodi e
systemctl stop eventlircd but pressing remote keys read nothing. In previous versions they worked. If you need more info or photos I will send them to you.

Then try this:


Hello, both my devices s905x and s912 does not have that sub menu.

Can you send me a picture of Kodi Settings / System Information / Summary

It’s only supported on NG releases. You can use NG with your S905X device.

Quad-core is 905X and Octa-core is 912.

@TheCoolest can I install NG version in both chipset?

Only S905X.

Any suggestion to resolve also in S912 (Mecool BB2 not Pro)? I seen exist specific image for BB2. I attached the photo of the S905X device. Name M96X.

A post was merged into an existing topic: CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - Getting Started

This is the remote no longer work. Can you say me which cfg file works with this? Keed in mind he have external usb adapter to work. In this case the command “ir-keytable -t” does not work and i can’t read the code on cmd!.

The repo has pictures for comparison. Maybe start there.

It should work out of the box.
All my USB receiver type remotes work OTB.

Did this previously work with a previous CE image ?
You say “No longer works”

Let’s make order. The remote control initially worked without any problem both in power on and power off. Then one day it stopped working as a power off. This will probably happen when the image of 905x and 912 has been merged. Now even if I program the power on from the original remote control it doesn’t work anymore. That is, the original remote control programs the ir button but does not work on the 905x. I have two identical remotes. On the 912 it works in power on but does not work in power off. On the 905x after reinstalling it does not work either on or off even when inserting the previous configuration files. The secondary remote works everything except the power button via ir. I hope I have clarified the problem.

FYI, the remote you have is a WeChip G20S which is intended as a replacement remote for NVIDIA Shield.


I repeat that it worked earlier and when I bought it it gave compatibility with Linux. If it never worked then I would understand. But first he worked and that’s what I don’t understand.

I stopped using the original remote control because the aiming had to be very precise and directed towards the box otherwise it didn’t work. But I would have continued to use that.