NEW Repo for Remote files (Thanks to Betatester)

so, whats the difference between AMremote and Mesen_IR ?

Personally, I haven’t a scoobie.

In general: amremote use the hardware decoder, meson-ir is software decoder.

meson-ir is also in upstream I think, amremote not.

amremote was used before meson-ir was developed (before Kodi Krypton?).

CoreELEC:~ # ir-keytable –t
ir-keytable: Too many arguments
Try `ir-keytable --help' or `ir-keytable --usage' for more information.

That’s weird, since IR-KEYTABLE -? does show me option -T

In the copy-paste there is a wrong dash character. It’s – not a -.

I already noticed this. but I also copy&pasted the argument from the ir-keytable -?

Neither -t nor –t is working

CoreELEC:~ # ir-keytable -t
/sys/class/rc/: No such file or directory
No devices found
CoreELEC:~ # ir-keytable -t
/sys/class/rc/: No such file or directory
No devices found

Tested with MacOS Terminal and iTerm2…

ir-keytable -V. is working fine, and as said, copy and paste of the ‘dash’ doesnt work either / rather a “device” is needed if I understand “-h” correctly:
Usage: ir-keytable [OPTION…] --device [/dev/input/event device]*

you need to stop Kodi and eventlirc before.
Also meson-ir needs to be enabled. So remove any remote.config as meson-ir is than enabled by default.

Cleared everything that has to do with remote files -->
Yes, I did end kodi like the manual (or your link) says: error’s still the same

*s922x:~ # systemctl stop kodi *
*s922x:~ # systemctl stop eventlircd *
s922x:~ # ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t
/sys/class/rc/: No such file or directory
No devices found

After deleting all remote-related files I was able to create the config for my remote.

Everything is working fine: I made this zip to be added to the repo!
X96MAX (37.9 KB)

(Now, only the VFD is missing - will post it as well, as soon as I got it to work!)

Thank you very much for your help ! :vulcan_salute:t4:

1 Like

@bubblegum57: New REMOTE CONFIG file for Repo! :wink:

Thanks for this. I am letting Betatester deal with these nowdays. Still suffering the after effects of radiotherapy.

1 Like

Thanks, I will review and add the file as soon as I have a moment.

1 Like

Original default remote.conf for AZW (Beelink) W95 S905W Box:

Guy, i have a problem unsolved. I bought a remote like in the post below:

I had managed to get the remote to work and everything was fine. It is now since this summer that the POWER button works for the PowerON but it does not work for the PowerOFF. I don’t think it’s a problem with the remote control otherwise the PowerOn wouldn’t work either, don’t you think? This is a problem that other users have found and it seems to me that we have not solved them either. I also tried the Keytable command from SSh to understand something more but that command doesn’t find any .cfg files that are there.

If this remote has a learn function, try relearning from the original remote that came with the device.

Do you still have the remote that came with the box? If yes, you can teach the USB remote how to turn on the box. The tutorial on how to do that is in the Library section of the Repository.

@bubblegum57 @Betatester

I try to give some more information to try to understand the problem. I tried to completely delete the remote control cfg file and Configfiles \ rc_keymaps folder. The remote still works without custom configuration. The original remote no longer works. If I try to learn the power button it stops working even in power_on. Same with another device that mounts the S912 instead of the 905X. Same remote and same problem. I tried the procedure described at How to configure IR remote control. I am able to stop systemctl services stop kodi e
systemctl stop eventlircd but pressing remote keys read nothing. In previous versions they worked. If you need more info or photos I will send them to you.

Then try this:


Hello, both my devices s905x and s912 does not have that sub menu.